Jump to content
The simFlight Network Forums
stopnicki

PMDG's new B747-400 and FSUIPC5

Recommended Posts

I think PMDG may have located the problem. It seems they DO use FSUIPC, and have used the old ModuleUser.lib code which dates back about 17 years and which is not compatible with a 64-bit prrocess like P3D4.

They've only just told me they use this, and it really surprised me.

I will temporarily make FSUIPC ignore module user calls until I work out a 64-bit implementation. That change will be in FSUIPC 5.101k, later today.

Pete

 

Share this post


Link to post
Share on other sites
12 hours ago, Pete Dowson said:

Does it? Where do you see that? It isn't according to what PMDG are telling me.

Pete

 

Between the thread here and the thread at the PMDG forum, I did a quick count showing 10 people reporting this problem specifying that they are running win7, 1 person on win10, 4 did not specify OS; in addition, 4 reports of all OK on win10, and in one case someone experiencing this problem on win7 installed win10 and stopped having the issue.

I don't know much about programming (and don't claim to), and I can only try to understand the problem based on what I can see in the forums (all that I have access to). But the above stats, plus your statement that you've compiled with target set to win10, it gave me the impression (perhaps an "intuitive hunch") that it might be OS related.

4 hours ago, Pete Dowson said:

Here I can make the PMDG 747 work flawlessly on my Win7 system -- provided I load itt as the first aircraft at the Scenario menu. And thereafter I can swap aircraft back and forth at will.

If I load a different aircraft as the first aircraft and THEN load the PMDG 747, it gives me a black screen only and P3D4 hangs, needing a Task Manager "terminate process" to get rid of it.

And this is exactly the same whether FSUIPC5 is being loaded or not!

This does suggest a loading or initialisation problem in the 747 code.

Incidentally, have you asked PMDG to create a Win7-targetted build to test with? If not, why not? Why only ask me?

Pete

 

Thank you for your explanation, now I understand how you've arrived at the conclusion that it's a PMDG initialisation problem (which I previously struggled to understand).

To answer your question at the end, I don't actually know what PMDG's compile target was (I guess there's a high chance it would be win10), and this forum here is where I got the hunch and my post this morning was the first time I put it into a sentence. That is a very good idea sir, and I shall go and contact PMDG.

Share this post


Link to post
Share on other sites
4 minutes ago, cathay808 said:

To answer your question at the end, I don't actually know what PMDG's compile target was (I guess there's a high chance it would be win10), and this forum here is where I got the hunch and my post this morning was the first time I put it into a sentence. That is a very good idea sir, and I shall go and contact PMDG.

First please see my last post in this thread, just before yours.

Pete

 

Share this post


Link to post
Share on other sites
Just now, Pete Dowson said:

First please see my last post in this thread, just before yours.

Pete

 

Just saw it after I posted. Thank you very much for the update, and I look forward to testing with 5.101k.

Share this post


Link to post
Share on other sites
10 minutes ago, cathay808 said:

Just saw it after I posted. Thank you very much for the update, and I look forward to testing with 5.101k.

Or the fix which PMDG may put out. Keep an eye out for that.

Pete

 

Share this post


Link to post
Share on other sites

Very good news!

We'll keep one eye here for the "k" version and the other eye on the PMDG forum, for their fixes.

Roberto

Share this post


Link to post
Share on other sites

Hi Pete,

Just installed 5.101k and now PMDG 744 does not Initialize anymore, no landing gear, all gauges are dead, VC is "frozen" no buttons, switches.....reacts.
When PMDG aircraft loads there is the green bar counting down the initialization process, It is just all dead now.

Installed 5.101j and everything works again.

5.101k seems to totally "Kill" PMDG 744

Win10 Creators Update.

FSUIPC5.log

FSUIPC5.ini

Share this post


Link to post
Share on other sites

Hi,

I think PMDG may have located the problem. It seems they DO use FSUIPC, and have used the old ModuleUser.lib code which dates back about 17 years
and which is not compatible with a 64-bit prrocess like P3D4. 
They've only just told me they use this, and it really surprised me. 
I will temporarily make FSUIPC ignore module user calls until I work out a 64-bit implementation. That change will be in FSUIPC 5.101k, later today. 

when you read above from Pete you will find that PMDG is using an old 32-bit facility the shouldn't. In case Pete now ignores any of those calls because of the problems while they use it. You will have to wait for a PMDG fix where they don't use that facility anymore, as it was always said they don't use FSUIPC at all, or a 64-bit implementation is available and they have still to fix their code to use the correct 64-bit library.

Thomas

Share this post


Link to post
Share on other sites

I am experiencing the same issue as "jannier" above. (Excluding the "FSUIPC kills PMDG" comment, as we now know that it is a PMDG issue).

This is just a report, for Pete's benefit (if any).

Regards,

Roberto

Share this post


Link to post
Share on other sites

Good morning,

This is another 5.101k test report - after installing 5.101k, starting a scenario directly on the PMDG 747 still led to the initialisation failure (blank screens etc), but more interestingly the workaround of loading default aircraft first also stopped working. I've only done a brief few tests but haven't been able to get the PMDG 747 to load properly at all on 5.101k.

I then reverted to 5.101j and loaded using the workaround successfully.

Quite fascinating - I think this shows an interaction between PMDG 747 and FSUIPC5? Whereas previously we haven't been able to show that altering FSUIPC5 (whether through the ini parameters or otherwise) could predictably affect whether the 747 would load.

Regards,

David

Share this post


Link to post
Share on other sites
8 hours ago, cathay808 said:

Quite fascinating - I think this shows an interaction between PMDG 747 and FSUIPC5?

Yes, PMDG have admitted it. Apparently, and unbeknownst to me, they do make calls into FSUIPC but using my 17-year old 32-bit ModuleUser library code! I think the problem is actually occurring in that code which must be compiled in one of their modules.

FSUIPC 5.101k actually provides 64-bit application and modules support now, but only with programs compiled to use it correctly. There aren't any yet -- I have to write something to test it with.

I'll put an option in to try to fend off any such calls, though that might not help if my theory is correct. Meanwhile, PMDG did say they'd release a fix. Have you looked?  It may have only gone out to those who;ve reported the problem to them so far, so they can prove it.

It'll be in the morning now ...

Pete

 

 

Share this post


Link to post
Share on other sites
8 hours ago, Pete Dowson said:

I'll put an option in to try to fend off any such calls, though that might not help if my theory is correct. Meanwhile, PMDG did say they'd release a fix. Have you looked?  It may have only gone out to those who;ve reported the problem to them so far, so they can prove it

 

With the latest 747-400 released this year, PMDG now pushes "real time" updates to us via their Operations Centre software. I've just checked there and no update yet, but being that this has all happened in the last 12 hours or so, I'll stand by and see if an update comes out over the weekend.

Share this post


Link to post
Share on other sites
6 hours ago, Pete Dowson said:

Yes, PMDG have admitted it. Apparently, and unbeknownst to me, they do make calls into FSUIPC but using my 17-year old 32-bit ModuleUser library code! I think the problem is actually occurring in that code which must be compiled in one of their modules.

FSUIPC 5.101k actually provides 64-bit application and modules support now, but only with programs compiled to use it correctly. There aren't any yet -- I have to write something to test it with.

I'll put an option in to try to fend off any such calls, though that might not help if my theory is correct. Meanwhile, PMSG did say they'd release a fix. Have you looked?  It may have only gone out to those who;ve reported the problem to them so far, so they can prove it.

It'll be in the morning now ...

Pete

 

 

I just installed the 747-400 build 8334 via the PMDG Operations Centre and it fixed the "dead" issue with fsuipc 5.101k.
All is working again.

From PMDG OP Centre Change-log:
 

PMDG 747-400 Queen of the Skies II - Build 3.00.8334 (Released 2017-06-09) [ View Issues ]
==================================================================
- VARIOUS: [General] - Various non specific fixes.
- VARIOUS: [General] - Temporary disablement of Squawkbox/IVAP/FSUIPC interface within 747-400 in Prepar3D v4 to prevent failure mode.


Share this post


Link to post
Share on other sites
15 hours ago, Pete Dowson said:

I'll put an option in to try to fend off any such calls, though that might not help if my theory is correct. Meanwhile, PMDG did say they'd release a fix.

This fix has now been released (via the updater in the PMDG Operations Centre software), and announced by forum post. I'll quote from the announcement below:

8 hours ago, rsrandazzo said:

PMDG 747-400 Queen of the Skies II for Prepar3D v4:  Along with a few minor tweaks, this product was updated to temporarily disable a process that allowed users to connect the 747 to Squawkbox/IVAP using FSUIPC.  This connection process was causing the 747 to fail and will be reintroduced once a solution is found.  This disablement only affects Prepar3D v4.

I've also tried out the fix with 5.101k (which previously rendered the 747 unable to initialise regardless of load order), and it is now working properly even when loaded directly from the startup interface.

 

8 hours ago, rsrandazzo said:

It is important also to point out that we have disabled the ability to use FSUIPC to connect the 777 to Squawkbox/IVAP while we work through some compatibility issues that create problems for the operation of the airplane for some users.  This disablement is expected to be temporary.

It's interesting to note that even the PMDG 777 (which has been released for P3D v4 today - albeit only the -200LR and 777F) announcement came with a similar note.

 

Seems to be all going for me now - many thanks for your efforts on this matter Pete!!

I know I said earlier that I only really use FSUIPC to run FTG ACARS (which remains the case), but as a small token of appreciation I've purchased a license key for FSUIPC5 anyway. Who knows, it might just open the door to features I'll come to swear by!

 

EDIT: Also just tested with 5.101m and (as expected) works fine.

Share this post


Link to post
Share on other sites

I am also glad to report that all is well with "m" and both PMDG's 747 and 777.

I have read in another forum, that L-M has found and fixed an issue related to the flag SIMCONNECT_CLIENT_DATA_PERIOD_ON_SET not working with SimConnect_RequestClientData, and is now testing it. 

Not that it is very important at this point, but I just wonder if all of this is somehow connected.

We waited patiently for PMDG to resolve their issue and now, hopefully, L-M will soon relase their fix.

Roberto 

Share this post


Link to post
Share on other sites
3 hours ago, stopnicki said:

I have read in another forum, that L-M has found and fixed an issue related to the flag SIMCONNECT_CLIENT_DATA_PERIOD_ON_SET not working with SimConnect_RequestClientData, and is now testing it. 

Not that it is very important at this point, but I just wonder if all of this is somehow connected.

No, it actually wasn't connected, though it might well have been had PMDG recompiled the 32-bit 17 year old library code they were using to access FSUIPC, because the facility that would have invoked uses that flag.

That P3D fix is important for those wanting to use the FSUIPC mapped offsets to the PMDG variables, as that P3D facility is used for that.

Pete

 

Share this post


Link to post
Share on other sites

I have another problem which looks like FSUIPC is involved.

I have P3D V4 with FSUIPC5 (latest update), I fly the queen with the latest updates (today updated) and the problem I have is that every 1 minute (exactly one minute) the P3D freeze for 5 seconds and then continues normaly for a minute. Then again the same. I removed fsuipc and everything came back to normal.  I have a network setup using widefs and another laptop.

Any ideas? I need to have the fsuipc!!!!!!!!!!!!!!!!!!!!

S.

Share this post


Link to post
Share on other sites

Hi,

if you check the manual you will find that for PMDG the Option Auto Save should not be used because of the big amount of data PMDG saves that you will get the freezing effect. Just disable in FSUIPC the Auto Save option and you will be fine.

Thomas

Share this post


Link to post
Share on other sites

Hello I try to do all the forum and it does not work 747 p3dv4, I bought the fsuipc I changed the dll's to fuipc I added the lines and nothing I do not know what to do

Edited by benicio

Share this post


Link to post
Share on other sites

Hi,

7 hours ago, benicio said:

Hello I try to do all the forum and it does not work 747 p3dv4, I bought the fsuipc I changed the dll's to fuipc I added the lines and nothing I do not know what to do

that doesn't tell anything about a problem you might have? Best would be if your problem is not related to this topic to just start a new topic and describe precise what your problem is. Also having some information about the used versions does then help in addition, FSUIPC5.log file.

Thomas

 

Share this post


Link to post
Share on other sites
12 hours ago, benicio said:

Hello I try to do all the forum and it does not work 747 p3dv4,

PMDG are aware of this problem with the 747 and are working to fix it. You need to keep an eye on the PMDG forum. It is not an FSUIPC matter, PMDG have assured me of this.

Pete

 

Share this post


Link to post
Share on other sites
8 hours ago, Jackaroo05 said:

Okay, I have looked around this and nothing worked. Want it to work. Any help?

You've added a meaningless request to a six-month old and dead thread, which is three pages long! If you want help with FSUIPC or WideFs, post a new thread with an appropriate title and full details, or if it is primarily about PMDG aircrft, post in the PMDG forums.

Pete

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.