Jump to content
The simFlight Network Forums
Sign in to follow this  
canuck21a

Long delay with FSUIPC5 loaded

Recommended Posts

July 9, 2017

Issue with P3Dv4 and FSUIPC5 (fully licensed version with WideFS Server).

When P3Dv4 starts it launches and the aircraft appears but the sim is non-responsive for seemingly 2 minutes.

If I wait patiently I have found that the sim eventually becomes active and responsive.

If I deactivate FSUIPC5 and restart P3Dv4 it starts and runs right away.

I have reinstalled Xpack simconnect but that makes no difference.

Removing GFDevv64.dll makes no difference.

FSUIPC5.log Contents:

********* FSUIPC5, Version 5.103e (3rd July 2017) by Pete Dowson *********
Running inside Prepar3D v4
Module base=7FFAF4EE0000
Windows 10 Pro 64 Bit reported as Build 15063, Release ID: 1703 (OS 10.0)
Prepar3D.exe version = 4.0.28.21686
Checking the Registrations now ...
User Name="Darryl Wightman"
User Addr="darryl.wightman@cogeco.ca"
FSUIPC5 Key is provided
WideFS7 Key is provided
        0 System time = 09/07/2017 10:36:43
       15 FLT UNC path = "\\HELION\Users\darryl\Documents\Prepar3D v4 Files\"
       15 ------ Module Version Check ------
       15        acontain.dll: 4.0.28.21686
       15             api.dll: 4.0.28.21686
       15        controls.dll: 4.0.28.21686
       15      fs-traffic.dll: 4.0.28.21686
       15             G3D.dll: 4.0.28.21686
       15        language.dll: 4.0.28.21686
       15            sim1.dll: 4.0.28.21686
       15        visualfx.dll: 4.0.28.21686
       15         weather.dll: 4.0.28.21686
       15          window.dll: 4.0.28.21686
       15 ----------------------------------
       31 FS UNC path = "\\HELION\E\Program Files\Lockheed Martin\Prepar3D v4\"
      172 ---------------------- Joystick Device Scan -----------------------
      172 -------------------------------------------------------------------
      203 LogOptions=00000000 00000001
      203 SimConnect_Open succeeded: waiting to check version okay
      203 Opened separate AI Traffic client okay
     3812 Running in "Lockheed Martin® Prepar3D® v4", Version: 4.0.28.21686 (SimConnect: 4.0.0.0)
     3812 Initialising SimConnect data requests now
     3812 FSUIPC Menu entry added
     3812 ... Using Prepar3D with Professional License
     3828 \\HELION\Users\darryl\Documents\Prepar3D v4 Files\BARON.fxml
     3828 \\HELION\E\Program Files\Lockheed Martin\Prepar3D v4\SimObjects\Airplanes\beech_baron_58\Beech_Baron_58.air
    28531 Aircraft loaded: running normally now ...
    28531 User Aircraft ID 1 supplied, now being used
    29234 System time = 09/07/2017 10:37:13, Simulator time = 10:36:48 (15:36Z)
    29234 Aircraft="Beech Baron 58 Paint2"
    36234 Starting everything now ...
    79047 **** No SimConnect events or states being received! Re-connecting now ... ****
    79390 SimConnect_Open succeeded: waiting to check version okay
    79390 Opened separate AI Traffic client okay
   122109 Running in "Lockheed Martin® Prepar3D® v4", Version: 4.0.28.21686 (SimConnect: 4.0.0.0)
   122109 Initialising SimConnect data requests now
   122109 FSUIPC Menu entry added
   122109 ... Using Prepar3D with Professional License
   122109 User Aircraft ID 1 supplied, now being used
   123109 System time = 09/07/2017 10:38:47, Simulator time = 10:36:56 (15:36Z)
   123265 Advanced Weather Interface Enabled
   142015 Sim stopped: average frame rate for last 20 secs = 133.7 fps
   142015    Max AI traffic was 0 aircraft
   143453 === Closing session: waiting for DLLStop to be called ...
   152765 === DLLStop called ...
   152765 === Closing external processes we started ...
   153765 === About to kill any Lua plug-ins still running ...
   153906 === Closing global Lua thread
   154906 === About to kill my timers ...
   155109 === Restoring window procs ...
   155109 === Unloading libraries ...
   155109 === stopping other threads ...
   155109 === ... Button scanning ...
   155218 === ... Axis scanning ...
   155312 === Releasing joystick devices ...
   155312 === Freeing macro memory
   155312 === Removing any offset overrides
   155312 === Closing all WideFS threads
   156672 === Clearing any displays left
   156672 === Calling SimConnect_Close ...
   157375 === SimConnect_Close done!
   157375 === AI slots deleted!
   157375 === Freeing button memory ...
   157375 === Closing my Windows ...
   157375 === Freeing FS libraries ...
   158375 === Closing devices ...
   158375 === Closing the Log ... Bye Bye! ...
   158375 System time = 09/07/2017 10:39:22, Simulator time = 10:37:13 (15:37Z)
   158375 *** FSUIPC log file being closed
Minimum frame rate was 113.8 fps, Maximum was 150.3 fps
Average frame rate for running time of 27 secs = 137.4 fps
Maximum AI traffic for session was 0 aircraft
Memory managed: 13 Allocs, 12 Freed
********* FSUIPC Log file closed ***********
 

p3dv4-simconnectversions.jpg

p3dv4-notrespondingfsuipc.jpg

p3dv4-respondingfsuipc.jpg

Share this post


Link to post
Share on other sites

I've split your question into a separate thread as it really needs its own title. I hope you manage to find it.

This delay, actuially about 85 seconds here, but in your case this is making it longer:

On 7/9/2017 at 4:00 PM, canuck21a said:

36234 Starting everything now ...
79047 **** No SimConnect events or states being received! Re-connecting now ... ****
79390 SimConnect_Open succeeded: waiting to check version okay  

The main delay here occurs on one PC but oddly not on another. I know how to stop it -- remove the facilities for all of the PMDG aircraft offsets --  but of course folks are using these.

Up until your report, rather hidden in another thread originally, I thought I was the only one with this problem, so i put it down to something else wrong on my PC 9which is may well be, of course), but didn't spend any time trying to work out what it was.

Your report makes it a different matter altogether now.

Because whilst in this delay FSUIPC itself gets not calls at all, from any part of Simconnect, and is just stick waiting for one, I'm sure it is some odd problem in P3D4 itself, but as it seemed to only affect me I've not yet reported it to L-M. I shall now have to gather evidence and details to get them to look at it.

Meanwhile I will add options into the INI file for disabling each of the three PMDG faciliyties (separately) -- i.e. 737NG, 777 and 747.  Then, if you use none of those you can disable them to stop this delay occurring. Maybe only enably one, as needed, will help.

I will also try to find a way to specifically identify when the aircraft are loaded, and so enabling them then, but there are such a variety of names (and folds can rename them in any case) that this is not so easy.

Look out for an update in the Download Links subforum withing the next day or two, in which i shall do the first option, i.e. make the PMDG stuff optional by user parameters.

Pete

 

Share this post


Link to post
Share on other sites

Hi Pete

I have a similar problem in P3D_V3. Meanwhile the PMDG737NGX starts straight away, at closing there is a strange delay of about 6 sec, until the closure window of P3D appears. In the log file I have the same lines as above:

    30907 Starting everything now ...
    32203 Advanced Weather Interface Enabled
    42141 === Closing session: waiting for DLLStop to be called ...
    52063 === DLLStop called ...
    52063 === Closing external processes we started ...

This waiting for DLLStop seems to be the problem, right? When FSUIPC is disabled, PMDG is closed without any delay. This is just to inform you that there is something wrong also with P3D_V3.4.

Best regards

Urs

Share this post


Link to post
Share on other sites
15 minutes ago, Alpin-Flier said:

When FSUIPC is disabled, PMDG is closed without any delay.

That's quite short. I've not idea what SimConnect is doing in that time (here's in both P3Dv3 and v4 it's more like 30 seconds) , but it isn't FSUIPC that's holding matters up. I think it is P3D tidying itself up -- after all FSUIPC does make it extremely busy!

14 minutes ago, Alpin-Flier said:

This waiting for DLLStop seems to be the problem, right?

Not the "problem", but the indication of what it is doing. Until Simconnect actually calls FSUIPC's "DLLStop" function, FSUIPC cannot proceed to clear its own stuff down. Otherwise you'd get a crash for sure.

16 minutes ago, Alpin-Flier said:

When FSUIPC is disabled, PMDG is closed without any delay

Well, FSUIPC has asked SimConnect to do an awful lot -- everything really. FSUIPC is the biggest customer SimConnect has, by far.

17 minutes ago, Alpin-Flier said:

This is just to inform you that there is something wrong also with P3D_V3.4.

It isn't "wrong", it is just the way it is. FSX and FSX-SE are similar.

Pete

 

Share this post


Link to post
Share on other sites

Hi Pete

Thank you very much for your infos. I just made a check down in my homecockpit (separate PC and installation). There I don't have a delay at closure. So I had a look into the log file. I have seen, it's an older FSUIPC:

********* FSUIPC4, Version 4.949h by Pete Dowson *********
Prepar3D.exe version = 3.4.22.19868
Reading options from "C:\Prepar3D v3\Modules\FSUIPC4.ini"
Running inside Prepar3D v3 on Windows 8.0
Module base=597C0000

....

    35484 Starting everything now ...
    36812 Advanced Weather Interface Enabled
    61750 Sim stopped: average frame rate for last 33 secs = 27.1 fps
    73984 === NOTE: not calling SimConnect_Close ...
    74984 System time = 18/07/2017 19:14:33, Simulator time = 16:30:40 (14:30Z)
    74984 *** FSUIPC log file being closed

That looks different, in fact. Then, of course, I'm using Win10.  I'm sure you have an explanation :-)

Thanks again and best regards

Urs

Share this post


Link to post
Share on other sites
20 minutes ago, Alpin-Flier said:

That looks different, in fact. Then, of course, I'm using Win10.  I'm sure you have an explanation :-)

Yes:

1. The log entry saying "waiting for DLLstop was added later, and
2. Calling "Simconnect_Close used to cause crashes on some systems with earlier versdions of P3D, so it was optional disabled defaulted to not do it).

Don't you see the 12 second gap between 
    61750 Sim stopped: average frame rate for last 33 secs = 27.1 fps

and
    73984 === NOTE: not calling SimConnect_Close ...

The values on the lft are in milliseconds, so that's a bit over 12 seconds!

Pete

  

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.