Jump to content
The simFlight Network Forums
jgoggi

No runways designators by ATC to AI airplanes in P3D v4

Recommended Posts

Hi, with P3D v4 the various ATC addons (Radar Contct, PF3, etc.) have a problem where the controllers do not see runways designators (right, left, center) ONLY for AI airplanes and give them instructions to taxi say to runway 16 instead of 16 left or 16 right. This does not happen with my own airplane, only with AI. Can this be caused by something wrong with FSUIPC? Thanks. 

Share this post


Link to post
Share on other sites
3 hours ago, jgoggi said:

with P3D v4 the various ATC addons (Radar Contact, PF3, etc.) have a problem where the controllers do not see runways designators (right, left, center) ONLY for AI airplanes and give them instructions to taxi say to runway 16 instead of 16 left or 16 right. This does not happen with my own airplane, only with AI. Can this be caused by something wrong with FSUIPC?

FSUIPC has nothing to do with how those programs choose to operate. I didn't even know they gave AI such instruction.

TrafficLook (one of the free demo programs available in the Download Links subforum here) will show the data Radar Contact gets and uses. See if that shows the runways assigned to AI correctly.

if not it is likely to be a bug in P3Dv4 which will need to be reported so it gets fixed in an update. The way FSUIPC5 gets the information from SimConnect is no different than itwas for FSUIPC4 and P3Dv3. However, I can re-check that.

I'll see if I can make time to check this myself tomorrow. Bedtime for me here, now.

Pete

 

Share this post


Link to post
Share on other sites
49 minutes ago, jgoggi said:

I will try and check tonight with TrafficLook.

I've checked here, and checked the code. It's a P3Dv4 bug. FSUIPC can't really do it wrong, as it simply asks for "AI Traffic Assigned Runway", receives a character string result, and supplies that, as is.

I'm reporting it to L-M now and hope it will get fixed by the next release.

Pete

 

  • Upvote 1

Share this post


Link to post
Share on other sites

Thank you Pete. I had picked your suggestion and already reported it in the P3D forum, but your comment would be taken much more into account by LM...

Share this post


Link to post
Share on other sites
58 minutes ago, jgoggi said:

I had picked your suggestion and already reported it in the P3D forum, but your comment would be taken much more into account by LM...

I posted in the private Developer's forum, and identified the precise variable which is lacking: "AI Traffic Assigned Runway".

If they fix it in the next update, I probably won't be able to test it then, though. I'm away this Thursday till September 12th, so it's inevitable they'll do a release whilst I'm away! ;-)

Pete

  • Upvote 1

Share this post


Link to post
Share on other sites
10 hours ago, jgoggi said:

Wow, great, with this message you are telling us that the P3D update will be before Sep 12 ;-)

NO, I'm not! I have no idea WHEN it will be released. It is never decided till it is ready, and even then it goes out for Beta testing before user release. I was only repeating the joke about new releases always appearing when I'm on holiday!

Pete

 

Share this post


Link to post
Share on other sites

Thanks for confirming this is a P3Dv4 error Pete. James had posted the problem in the RC Forum but everything was fine with P3D v3.4 and I couldn't reproduce it.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.