Jump to content
The simFlight Network Forums
Alhard Horstmann

Rotary Encoder decoded by FSUIPC with strange results

Recommended Posts

Hi Pete,

I coded a rotary encoder for trim wheel purpose with FSUIPC like this:

---------------------------------

[Buttons]
!2=;Änderung wegen TrimWheel 170728
ButtonRepeat=20,10
PollInterval=10
3=CP(+0,6)0,7,Cx43000BC0,xC0010100 ; ELEV_TRIM Sword Decr
4=CP(+0,6)0,7,Cx43000BC0,xC0010100 ; ELEV_TRIM Sword Decr
1=CP(+0,7)0,6,Cx33000BC0,x3FFF0100 ; ELEV_TRIM Sword Incr
2=CP(+0,7)0,6,Cx33000BC0,x3FFF0100 ; ELEV_TRIM Sword Incr

--------------------------------

It worked for some days perfect. I could move the trim wheel, sitting on a rotary encoder, and the plane followed the control.

Now , when I move the trim wheel, the throttle move back to a 50% position. I am not aware, that I changed anything relevant to this problem.

The standard controller assignment in FSX is NOT used.

I reloaded my FSX and the C172, and always the same effect: moving trim wheel , moving thottle axis.

Here is the log file, see attachment and remarks below:

Remarks to the LOG files. From line 97189 on I move the throttle and mixture.

Then in line 127032 I connected the USB encoder trim wheel. I moved the trime wheel and suddenly in line 127203 the AXIS_THROTTLE_SET was moved.

I disconnected and connected the USB encoder just for test purpose. The behaviour is still there with USB encoder permanent connected.

What did I  do wrong? What shall I check additionally?

Thanks

 Alhard

FSUIPC4.log

Share this post


Link to post
Share on other sites
13 hours ago, shortspecialbus said:

Use Joystick Letters as described in the user manual.  It sounds like they're being renumbered, which is pretty common.

-stefan

Thanks Stefan,  I will try

Alhard

Share this post


Link to post
Share on other sites
On 8/23/2017 at 4:36 PM, alihor said:

Here is the log file, see attachment and remarks below:

Your log shows you are using FSUIPC version 4.921f. I cannot support such old versions. Please update to 4.971.

On 8/23/2017 at 4:36 PM, alihor said:

when I move the trim wheel, the throttle move back to a 50% position.

If your Trim Wheel is only writing to offset 0BC0 then it cannot possibly change the throttle unless something is wrong in the aircraft modelling or the sim.

I think it is more likely that you didn't actually disable controllers in the Sim, and it has picked up your trim wheel axis and automatically assigned it. This is a danger unless you actually disable controllers in the sim -- it is thinking it is being helpful!

These log entries do indicate that your Throttle is ittering, BTW.  Correct calibration should fix that, and in fact for jitters less than the Delta (default 256) it would be eliminated by assignment in FSUIPC.

   127203 ***  AXIS: Cntrl= 65765 (0x000100e5), Param= 0 (0x00000000) AXIS_THROTTLE_SET
   128264 ***  AXIS: Cntrl= 65765 (0x000100e5), Param= 63 (0x0000003f) AXIS_THROTTLE_SET
   128264 ***  AXIS: Cntrl= 65765 (0x000100e5), Param= 0 (0x00000000) AXIS_THROTTLE_SET
   128373 ***  AXIS: Cntrl= 65765 (0x000100e5), Param= 63 (0x0000003f) AXIS_THROTTLE_SET
   128389 ***  AXIS: Cntrl= 65765 (0x000100e5), Param= 0 (0x00000000) AXIS_THROTTLE_SET
   132289 ***  AXIS: Cntrl= 65765 (0x000100e5), Param= 63 (0x0000003f) AXIS_THROTTLE_SET
   132304 ***  AXIS: Cntrl= 65765 (0x000100e5), Param= 0 (0x00000000) AXIS_THROTTLE_SET
   133131 ***  AXIS: Cntrl= 65765 (0x000100e5), Param= 63 (0x0000003f) AXIS_THROTTLE_SET
   133131 ***  AXIS: Cntrl= 65765 (0x000100e5), Param= 0 (0x00000000) AXIS_THROTTLE_SET
   133225 ***  AXIS: Cntrl= 65765 (0x000100e5), Param= 63 (0x0000003f) AXIS_THROTTLE_SET
   133256 ***  AXIS: Cntrl= 65765 (0x000100e5), Param= 0 (0x00000000) AXIS_THROTTLE_SET
   135471 ***  AXIS: Cntrl= 65765 (0x000100e5), Param= 63 (0x0000003f) AXIS_THROTTLE_SET
   135502 ***  AXIS: Cntrl= 65765 (0x000100e5), Param= 0 (0x00000000) AXIS_THROTTLE_SET
   136735 ***  AXIS: Cntrl= 65765 (0x000100e5), Param= 63 (0x0000003f) AXIS_THROTTLE_SET
   136766 ***  AXIS: Cntrl= 65765 (0x000100e5), Param= 0 (0x00000000) AXIS_THROTTLE_SET
   137016 ***  AXIS: Cntrl= 65765 (0x000100e5), Param= 63 (0x0000003f) AXIS_THROTTLE_SET
   137031 ***  AXIS: Cntrl= 65765 (0x000100e5), Param= 0 (0x00000000) AXIS_THROTTLE_SET
   137125 ***  AXIS: Cntrl= 65765 (0x000100e5), Param= 63 (0x0000003f) AXIS_THROTTLE_SET
   137140 ***  AXIS: Cntrl= 65765 (0x000100e5), Param= 0 (0x00000000) AXIS_THROTTLE_SET

Pete

 

Share this post


Link to post
Share on other sites

Hello Pete, good to have you back. How was the trip to the US?

Thanks for your advises. Normally I check the versions. Sorry.

I think disabling controllers in the sim could solve the problem. Normally I never disable the controllers in the controller disable box. I delete all assignments in the standard FSX controller assignments.

I will follow your advises and report again.

Alhard

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.