Jump to content
The simFlight Network Forums
Sign in to follow this  
Scotfleiger

Multiple Lua Files crashing P3D on Aircraft Change

Recommended Posts

Hi Pete

One of my users has been reporting issues with FSUIPC5 when changing aircraft when multiple LUA files are in use. The user is using the Lua file multiaxis.lua which allows axes to be swapped when a joystick button is pressed. The command is communicated via the offset 0x66C0). There appears to be a conflict with LINDA when called, normally, via ipcready.lua and the [auto] section loading Lua  multiaxis. Renaming ipcready.ipc prevents the crash but this means that LINDA LUA modules not being loaded.


[auto]
1=lua multiaxis

[LuaFiles]
1=ipcReady
2=linda
3=AirbusX_Thr1
4=AirbusX_Thr2
5=FSUIPC5_test
6=Multiaxis

[Axes]
0=JX256,F,L5:V,0,0,0 -{TO SIM: luaValue Multiaxis }-


[Buttons]
PollInterval=25
ButtonRepeat=20,10
1=R2,4,Cx42000BC0,xC0010100     -{offset sword decrement, offset 0BC0 (Decr=256, Limit=-16383)}-
2=R2,5,Cx32000BC0,x3FFF0100     -{offset sword increment, offset 0BC0 (Incr=256, Limit=16383)}-
3=P3,3,Cx030066C0,x0000FA88     -{offset dword set, offset 66C0}-
4=U3,3,Cx030066C0,x000100E3     -{offset dword set, offset 66C0}-

With P3Dv4, LINDA 3.0.2 and Multiaxis.lua running, P3Dv4 crashes on aircraft change with the Event Viewer (see attached) showing a crash in FSUIPC5.dll. I am not sure whether this problem is associated with the LUA thread management changes you made earlier.

These tests were carried out with FSUIPC 5.112.

The user also reported the same crash with FSUIPC4 4.971 (log attached).

FSUIPC5.ini

FSUIPC5-crashOnAircraftChange.log

Multiaxis.lua

MULTIAXIS_crash.txt

FSUIPC4_Crash_LINDA_302_FSUIPC_471.log

Share this post


Link to post
Share on other sites
21 minutes ago, Scotfleiger said:

With P3Dv4, LINDA 3.0.2 and Multiaxis.lua running, P3Dv4 crashes on aircraft change with the Event Viewer (see attached) showing a crash in FSUIPC5.dll.

I could look to see where in FSUIPC the crash is occurring (though if, like last time, it is really deep inside the Lua interpreter I'm not sure whether I can do much about it), but I need a crash log when using the currently released version of FSUPC. Otherwise the compilation map doesn't match. The current version on full release is 5.121a.

21 minutes ago, Scotfleiger said:

I am not sure whether this problem is associated with the LUA thread management changes you made earlier.

Remind me. What were those?

Are you saying this was not a problem in some preceding version of FSUIPC?

21 minutes ago, Scotfleiger said:

The user also reported the same crash with FSUIPC4 4.971 (log attached).

But unfortunately with no Event Viewer details . I do of course have the correct map for 4.971 as that is a current version and it might be easier tob track it down in the 32-bit version.

Have LINDA users never changed aircraft before, or is this a new problem? Or some other development in LINDA use? Is it something you cvan reproduce? Is there only one user with this problem?

Pete

 

Share this post


Link to post
Share on other sites
1 minute ago, Pete Dowson said:

The current version on full release is 5.121a.

You were too quick for me. I was aiming to submit report on your return but other things got in the way. One user has just reported that 5.121a does not exhibit the crash. I will seek more information.

3 minutes ago, Pete Dowson said:
24 minutes ago, Scotfleiger said:

I am not sure whether this problem is associated with the LUA thread management changes you made earlier.

Remind me. What were those?

Are you saying this was not a problem in some preceding version of FSUIPC?

My memory is not good but you made some changes when we were working on the LUA issues in the summer. 

4 minutes ago, Pete Dowson said:

But unfortunately with no Event Viewer details . I do of course have the correct map for 4.971 as that is a current version and it might be easier tob track it down in the 32-bit version.

Sorry the user did not capture the event logs and I only set up a test with 5.113.

5 minutes ago, Pete Dowson said:

Have LINDA users never changed aircraft before, or is this a new problem? Or some other development in LINDA use?

LINDA are always changing aircraft as that's what LINDA is for. I have not had the problem reported before and there have been not updates to LINDA since July when we were finalising the FSUIPC5 issues.

Share this post


Link to post
Share on other sites

Update: The original user with the multiaxis.lua crashing problems reports that it is not fixed by 5.121a. Of note is that the multiaxis.lua is started within the [auto] block and not using normal LUA procedures or via ipcReady.lua. He reports that if he disables ipcReady.lua by renaming it then the crash does not occur on changing the aircraft. Doing disables the LINDA LUA core code by failing to start it. I have pointed him to this thread as LINDA itself is operating normally.  

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.