Jump to content
The simFlight Network Forums

Network delay problems


Recommended Posts

Hi Peter,

I have a problems between the FS main PC and other PM program client PC network delay problems.

I use TCP/IP and switching/HUB.

the usually case are Captain side and First officer PM-PFD/ND side will be delay,some time very serious,some times not.

I have 5 PC for run the FS.

Server PC-FS scenery only,Aerosoft MCP driver program.and two USB PFC yoke and padle,and USB two throttle Quadrant.

Client PC-PM FMS/CDU,EICAS

Client PC-PM PFD/ND,PM MCP program.

Client PC-PM PFD/ND

Client PC-PM RCDU and EICAS

Thanks for your help.

Best Regards

Tony YAo

Link to comment
Share on other sites

the usually case are Captain side and First officer PM-PFD/ND side will be delay,some time very serious,some times not.

What do the WideClient and WideServer logs show?

Do you have the FS frame rate limiter to to provide a sensible refresh rate for each client?

Client PC-PM FMS/CDU,EICAS

Client PC-PM PFD/ND,PM MCP program.

Client PC-PM PFD/ND

Client PC-PM RCDU and EICAS

Which of these is First Officer's PFD and which Captain's? When you say "serious" delay, what do you mean?

There may be issues when running the MCP on the same PC as a PFD. It looks like the MCP changes values in the lower memory area of FSUIPC (04E0-0537) which may be needed by the PFD, but these, being in the FS "globals" area, are not updated locally, only in the FS PC and there sent to the other clients.

I cannot reproduce any problem here with such an arrangement, but I think it may be possible. However, it would not be the explanation if, for instance, your PC with only the PFD/ND running suffered serious delays. That would almost certainly be some sort of queuing or block loss on the Network -- the logs should show something in that case.

I have a test version of WideClient here which treats the 04E0-0537 area as 'special', like the FSUIPC application areas above 4000. I prepared it for someone else here who mentioned a problem, but he hasn't got back to me about it yet. I'll try to attach it here for you to try -- but if it isn't attached to this message, check your email instead.

Regards,

Pete

WideClient6101.zip

Link to comment
Share on other sites

Hi Pete,

Today I installed your test version of wideclient and no more delays here until now, I flew about 1 hour and no problems, very smooth with aerosoft and magenta running in the same client !!!

Looks like you are correct again about the 04E0-0537 area.

Thanks so much, I keep you informed about any change

Link to comment
Share on other sites

Hi,

I still have PFD/ND delay problem for both CA and F/O side.

just like when aircraft climing,the PFD/ND display will be "stop" for one or two second,then keep running.this happend usually on clim,descend or turning.I use TCP/IP.

I install Aerosoft MCP panel and driver on FS main PC,and PFD/ND,PM MCP run same client PC.

Do you think if I move PM MCP softwrae to CDU client PC will be better?

I had already install Beta version wideclient.

Could you send a wideFS sever and client .INI file to me?

Best Regards

Tony Yao

Link to comment
Share on other sites

just like when aircraft climing,the PFD/ND display will be "stop" for one or two second,then keep running.this happend usually on clim,descend or turning.

Are you sure FS itself is not stuttering at the same time? The PFD may simply be reflecting what FS is doing. I notice that, especially with clouds, FS2004 will stutter more noticeably on turns, for instance. Also I get noticeable stutters near the ground which I think are associated with autogen objects appearing. This is on a 3.2GHz Pentium, but I do have everything turned up to maximum so I cannot complain! :wink:

I install Aerosoft MCP panel and driver on FS main PC,and PFD/ND,PM MCP run same client PC.

I wonder if the two parts of PM are competing for WideClient's attention and sometimes getting into conflict? You might want to try setting "UseTimer=on" in the PFD.INI, or possible setting it "Off" if you already have it on. Also I think there's some cycle time setting you can adjust in the MCP.INI file -- try different values there to see if there's any improvement.

Do you think if I move PM MCP softwrae to CDU client PC will be better?

Ah, if you have a separate PC for the CDU I certainly think the MCP would be better there than with the PFD.

Could you send a wideFS sever and client .INI file to me?

I don't think there will be much in those which you should need to or want to change. Defaults for everything should be fine (it took me months of experimenting to get them that way, so if you start playing it could take you months too! :) ). But there are some things you can do in the PM INI files. Probably these are best discussed in the PM group where there are more knowledgeable folks on this subject than I.

Certainly, though, experimentation is the key. I'm sure you can find a happy arrangement.

Regards,

Pete

Link to comment
Share on other sites

Hi,

here is my experience:

My magenta MCP and aerosoft MCP were running minimized in a client that had

magenta PFD/ND installed.

I was getting some stutters in PFD and I found that the data flow was:

User touch a button in aerosoft MCP ->

aerosoft sends command to FS computer -> through network

FS sends command to magenta MCP in client -> through network

MCP to FS computer -> through network

FS computer to magenta PFD/ND (display changes mode) -> through network

So a network traffic for a button press, than I tried to install aerosoft

MCP hard+soft in FS computer (server) and it started to work very fast, but

after 30 seconds the aerosoft EFIS stopped working and only the Baro knob

was working...

Today I did an additional test and installed magenta MCP in FS computer as

well. Now the display updates and commands are very fast, PFD/ND is running

smoother and I'm happy (until now :), now I believe the data flow is:

User touch a button in aerosoft MCP ->

aerosoft sends command to FS -> direct (same machine)

FS sends command to magenta MCP -> direct (same machine)

MCP to FS -> direct (same machine)

FS computer to magenta PFD/ND (display changes mode) -> through network

My network is 100T using a linksys switcher, the FS computer is a

AthlonXP2400+, 1gbRAM, winXP Pro, TCP/IP, Radeon 9800pro.

I suggest you to leave the PFD/ND client running alone and move the magenta MCP to FS (as me) or CDU computer.

I hope this helps,

Link to comment
Share on other sites

Hi

Thanks a lot,I just change a new PC P4 3.0G and 1G Ram,seems faster than before and both Captain and F/O EIFS working normal.

But CA and FO side PFD some time still delay(same time).so I think that's is the network connecting HUB to hot,I'm not sure,I'll change another HUB for test.hoped it help.

Thansk guy.

Regards

Tony

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.