Jump to content
The simFlight Network Forums
lupa2

WideFS not connecting when run as admin

Recommended Posts

Hello everyone

The issue I've run into is fairly simple. I'm running WideFS server registered on my sim PC and wideFS client on my Surface. When I run the wideFS client normally it connects to the server just fine but it won't produce GPS output (which I need for Jepp FliteDeck), and when I run it as admin it does generate GPS data (can be monitored in VSPE, the client is writing data to the connector), but the client won't connect to the server anymore.

I'm pulling my hair out over this one, maaybe you can help

Cheers

Luca

Edit: Just for additional info, seems like WideFS Client is running version 6.999z4, WideFS Server is on 7.971 and FSUIPC is on version 5.121b, same behaviour with version 4.971 though

Edited by lupa2

Share this post


Link to post
Share on other sites

Hi,

user privilegs are locally on that PC and don't effect PC's over the network. If the Client doesn't connect when running with administrator privilegs it will be most likely a firewall serttingthat isolates WideClient.

Thomas

Share this post


Link to post
Share on other sites

I have both ports 8002 and 9002 excluded from the firewall on both TCP and UDP both in and out, shouldn't be an issue I don't think, I also don't kow how that would be affected by user privileges

Share this post


Link to post
Share on other sites
2 hours ago, lupa2 said:

Edit: Just for additional info, seems like WideFS Client is running version 6.999z4, WideFS Server is on 7.971 and FSUIPC is on version 5.121b, same behaviour with version 4.971 though

There's no separate "WideFS server", it is part of FSUIPC. The number 7.971 just indicates it is running in FSUIPC5 but is at the same level and FSUIPC 4's 4.971 version.

When you have a communication problem betwen Server and Client you should provide the loags -- wideserver.log and wideclient.log.

1 hour ago, lupa2 said:

I have both ports 8002 and 9002 excluded from the firewall on both TCP and UDP both in and out, shouldn't be an issue I don't think, I also don't kow how that would be affected by user privileges

Nothing to do with network exchanges should be affected by process privilage levels. 

2 hours ago, lupa2 said:

when I run it as admin it does generate GPS data (can be monitored in VSPE, the client is writing data to the connector), but the client won't connect to the server anymore.

How is it producing data if it isn't receiving any? It only pases on what it receives.

I have never needed to run WideClient in elevated privilage mode for any application, so something is odd in that Client system somewhere. VSPE presents a virtual port, which is at system level, nothing user or admin level at all, so those are really irrelevant.

Pete

 

Share this post


Link to post
Share on other sites
1 hour ago, lupa2 said:

Anyways, logs attached below,

Ah, now it is clearer. The elevated session appears not to receive broadcasts, so it doesn't know the name of IP addressof the Server. See, the successful connection in the "regular" log:

      156 Attempting to connect now
      156 Trying to locate server: Need details from Server Broadcast
      156 Failed to connect: waiting to try again
     1172 Attempting to connect now
     2188 Server = LUCAPC
     2203 Trying TCP/IP host "LUCAPC" port 8002 ...
     2203 ... Okay, IP Address = 192.168.1.10
     2203 Connection made okay!


compared with this for the elevated log:

      156 Attempting to connect now
      188 Trying to locate server: Protocol not yet decided
      188 Failed to connect: waiting to try again
     1219 Attempting to connect now
    22531 Trying to locate server: Protocol not yet decided


Try putting the ServerIPAddr parameter into the WideClient.INI file, and Protocol=TCP or UDP, as you wish. 

This is the first thing to try when connections aren't being made -- it is documented in the WideFS User Guide, in the part imploring readers to read at least part of it!

Pete

 

Share this post


Link to post
Share on other sites

I should have attached my WideFS.ini, sorry for that. Adding the serverIPAddr parameter was the first thing I did when this issue came up, read the docs back and forth trying to figure it out. I might try the protocol =TCP setting, didn't think it'd have an impact as it works on regular user privileges

 

; PLEASE SEE WideFS documentation for parameter details
; =====================================================

[Config]
ServerIPAddr=192.168.1.10
Port=8002
Window=924,452,886,589
Visible=Yes
ButtonScanInterval=20
ClassInstance=0
NetworkTiming=5,1
MailslotTiming=1000,1000
PollInterval=2000
Port2=9002
ReconnectMinutes=0
ResponseTime=18
ApplicationDelay=0
TCPcoalesce=No
WaitForNewData=500
MaxSendQ=100
OnMaxSendQ=Log
NewSendScanTime=50
Priority=3,1,2

; -----------------------------------------------
[User]
Log=Errors+

[GPSout]
Port=COM1
Speed=19200

; ===============================================
[Sounds]
Path=C:\Program Files (x86)\WideFS\Sound\
Device1=Primary Sound Driver
Device2=Speakers (Realtek High Definition Audio(SST))

 

Share this post


Link to post
Share on other sites
4 minutes ago, lupa2 said:

I should have attached my WideFS.ini, sorry for that. Adding the serverIPAddr parameter was the first thing I did when this issue came up, read the docs back and forth trying to figure it out. I might try the protocol =TCP setting,

You need the Protocol parameter as well -- with broadcasting it gets told the protocol by the Server (which can be overridden by the local parameter). But without broadcasts it definitely needs both IP Address (or Name) AND Protocol. It won't work with just one of those. (This too is as per documentation).

7 minutes ago, lupa2 said:

didn't think it'd have an impact as it works on regular user privileges

I don't know why elevating it stops it receiving broadcasts. That seems a bit strange.

Pete

 

 

Share this post


Link to post
Share on other sites

Specifying the protocol seems to have worked, the client now connects to the server. Why it worked with regular privileges and not with elevated ones I'm still wondering. Anyways, that far it works, now to make FliteDeck see my GPS position, because currently it does not :D

Thanks for the help

Luca

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.