Jump to content
The simFlight Network Forums
Sign in to follow this  
BullRot

I found a Voice Recognition problem / solution - software dependant

Recommended Posts

Hi, 

I found an issue with Voice Recognition problem with Tower 3D! Pro but also with many other voice recognition softwares where a VR doesn't work etc ....
I found a solution that may help someone.

This can help someone with similar hardware or software in troubleshooting.

Motherboard MSI Z170A Gaming 5 is eqquipied with Realtek HD Audio codec supporting natively "Nahimic" technology, software (hardware also?) for equalizing sound, processing input/output signals.
The problem is that Nahimic take the signal input from the microphone but doesn't send it to VR module.
Windows get the speech recognition correctly, but external softwares like Tower 3D! Pro, FS2Crew and similar seems that voice recognition module starts correctly but don't receive any input from microphone. Some external different modules for VR works well like in ATCPro (but recognition is so baaaad).

The solution is to close Nahimic program (blue icon with N) and with newest Realtek driver to check in task manager (alt+ctr+del / processes tab) if all Nahimic processes are stopped, provided by sound driver.
Then EUREKA ... It works again flawlessly .... 


Hope this can help someone with MSI MB or with Nahimic software.

  • Thanks 1
  • Upvote 2

Share this post


Link to post
Share on other sites

A friend of mine installed Windows 10 twice because he couldn't get voice to work in game. (rtf1970). We couldn't solve the problem why voice recognition wasn't working in game but it did work in Windows itself.

Thanks to your post we disabled Nahimic (he also has a MSI board).... and guess what??? It's working. I never heard someone so happy as Ron is at this moment.

We could never find out how to fix this problem by ourselves. So much luck you posted this post just a couple of hours ago!

(MSI 370 gaming PRO)

Thank you from Ron Valk with lots!!

Share this post


Link to post
Share on other sites

Yes, thnx for the solution

Finally running now on coffeelake, everything was working fine, voice etc, but no voice in the game.

To bad you posted this just for 5 hours ago, because i uninstalled evrything and installed it back again, hoping to solve that problem, haha

But thnx for this advice, works great.

 

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.