Jump to content
The simFlight Network Forums
maukro_1990

FSUIPC is not showing up in Prepar3d 4.1

Recommended Posts

12 hours ago, paulavny said:
No previous FSUIPC5 entry found, so adding it now ...
Cannot edit the DLL.XML file to activate FSUIPC.

When you manage to get the DLL.XML to show me (t to attach it I think, it won't format well otherwise), I certainly need to see it as it appears, from the above entry in the Install log, to be corrupt.

Didn't you get a message from the Installer asking you to delete the DLL.XML file and re-running the Installer?

Pete

 

Share this post


Link to post
Share on other sites

Pete,

Here’s the DLL. :

 
 
<?xml version="1.0" encoding="Windows-1252"?>
 
<SimBase.Document Type="Launch" version="1,0">
  <Descr>Launch</Descr>
  <Filename>dll.xml</Filename>
  <Disabled>False</Disabled>
  <Launch.ManualLoad>False</Launch.ManualLoad>
  <Launch.Addon>
    <Name>FSUIPC 5</Name>
    <Disabled>False</Disabled>
    <Path>                                                                                                                                                                                                                                                                   \Modules\FSUIPC5.dll</Path>
   </Launch.Addon>
</SimBase.Document>
 
PAUL
 
 
 

Share this post


Link to post
Share on other sites
14 hours ago, paulavny said:

Here’s the DLL

That looks like the problem one, produced by the faulty uploaded Install package. Please as I thought I'd advised, re-download the ZIP and re-run the Installer.

Pete

 

Share this post


Link to post
Share on other sites
1 hour ago, paulavny said:

 “re-download the ZIP and re-run the Installer.”

It is from a fresh download .

Thanks

Paul

Sorry, but i do think it is definitely the older one. The date and time on the Installer EXE inside should show as 20th Nov, 11:08.

I think you are merely re-downloading the same one from a cache, probably on your IP server. You either need to clear the cache (press F5 I think), or, possibly easier, download from a different place. If you downloaded from the Schiratti site, try the Download Links subforum here, or vice versa.

Pete

 

Share this post


Link to post
Share on other sites

Pete ,

Sorry to report : no luck 

 tried everything .

here are 2 files for you :

1️⃣
<?xml version="1.0" encoding="Windows-1252"?> 

<SimBase.Document Type="Launch" version="1,0"> 
<Descr>Launch</Descr> 
<Filename>dll.xml</Filename> 
<Disabled>False</Disabled> 
<Launch.ManualLoad>False</Launch.ManualLoad> 
<Launch.Addon> 
<Name>FSUIPC 5</Name> 
<Disabled>False</Disabled> 
<Path>                                                                                                                                                                                                                                                                   \Modules\FSUIPC5.dll</Path> 
</Launch.Addon> 
</SimBase.Document>

2️⃣ And this one :

Installer for FSUIPC5.DLL version 5.122
 
 
Looking in registry for Prepar3D v4 install path:
     HKEY_CURRENT_USER\SOFTWARE\Lockheed Martin\Prepar3D v4
     Parameter"AppPath"
... >>>  OK! FOUND Prepar3D v4!  <<< ...
     AppPath=C:\Program Files\Lockheed Martin\Prepar3D v4\
===========================================================
 
INSTALLATION FOR Prepar3D v4:
AppPath="C:\Program Files\Lockheed Martin\Prepar3D v4\"
Checking version of the Prepar3D v4 EXE:
... Version 4.1.7.22841  (Need at least 4.0.20.21316)
Checking if there's already a version of FSUIPC5 installed as:
       C:\Program Files\Lockheed Martin\Prepar3D v4\Modules\FSUIPC5.DLL
... Version 5.122 found.
Prepar3D v4 Modules Modules folder already exists.
Okay -- installed FSUIPC5 into "C:\Program Files\Lockheed Martin\Prepar3D v4\Modules\FSUIPC5.DLL"
Looking for the current user's Application Data path: 
... found as "C:\Users\Paul\AppData\Roaming"
Now finding \Lockheed Martin\Prepar3D v4\Prepar3D.CFG for all users, including this one
Looking in "C:\Users\All Users\AppData\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Default\AppData\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Default User\AppData\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Paul\AppData\Roaming"
Found Prepar3D.CFG in "C:\Users\Paul\AppData\Roaming\Lockheed Martin\Prepar3D v4\Prepar3D.CFG"
Now checking DLL.XML ...
... There is a previous DLL.XML, checking for FSUIPC5 section.
No previous FSUIPC5 entry found, so adding it now ...
Cannot edit the DLL.XML file to activate FSUIPC.            👨‍✈️ Looks a bit strange 
"Modules\FSUIPC Documents" folder already exists.
Now installing additional files into the "Modules\FSUIPC Documents" folder:
   Installed "FSUIPC5 User Guide.pdf" okay
   Installed "FSUIPC5 for Advanced Users.pdf" okay
   Installed "The 2016 List of FSX and P3D Controls.pdf" okay
   Installed "FSUIPC Lua Library.pdf" okay
   Installed "FSUIPC Lua Plug-Ins.pdf" okay
   Installed "Lua License.pdf" okay
Installer for FSUIPC5.DLL version 5.122
 
 
Looking in registry for Prepar3D v4 install path:
     HKEY_CURRENT_USER\SOFTWARE\Lockheed Martin\Prepar3D v4
     Parameter"AppPath"
... >>>  OK! FOUND Prepar3D v4!  <<< ...
     AppPath=C:\Program Files\Lockheed Martin\Prepar3D v4\
===========================================================
 
INSTALLATION FOR Prepar3D v4:
AppPath="C:\Program Files\Lockheed Martin\Prepar3D v4\"
Checking version of the Prepar3D v4 EXE:
... Version 4.1.7.22841  (Need at least 4.0.20.21316)
Checking if there's already a version of FSUIPC5 installed as:
       C:\Program Files\Lockheed Martin\Prepar3D v4\Modules\FSUIPC5.DLL
... Version 5.122 found.
Prepar3D v4 Modules Modules folder already exists.
Okay -- installed FSUIPC5 into "C:\Program Files\Lockheed Martin\Prepar3D v4\Modules\FSUIPC5.DLL"
Looking for the current user's Application Data path: 
... found as "C:\Users\Paul\AppData\Roaming"
Now finding \Lockheed Martin\Prepar3D v4\Prepar3D.CFG for all users, including this one
Looking in "C:\Users\All Users\AppData\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Default\AppData\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Default User\AppData\Roaming"
 ... No Prepar3D.CFG there
Looking in "C:\Users\Paul\AppData\Roaming"
Found Prepar3D.CFG in "C:\Users\Paul\AppData\Roaming\Lockheed Martin\Prepar3D v4\Prepar3D.CFG"
Now checking DLL.XML ...
... There is a previous DLL.XML, checking for FSUIPC5 section.
No previous FSUIPC5 entry found, so adding it now ...
Cannot edit the DLL.XML file to activate FSUIPC.
"Modules\FSUIPC Documents" folder already exists.
Now installing additional files into the "Modules\FSUIPC Documents" folder:
   Installed "FSUIPC5 User Guide.pdf" okay
   Installed "FSUIPC5 for Advanced Users.pdf" okay
   Installed "The 2016 List of FSX and P3D Controls.pdf" okay
   Installed "FSUIPC Lua Library.pdf" okay
   Installed "FSUIPC Lua Plug-Ins.pdf" okay
   Installed "Lua License.pdf" okay
   Installed "LuaFileSystem.pdf" okay
   Installed "Example LUA plugins.zip" okay
   Installed "FSUIPC4 Offsets Status.pdf" okay
   Installed "Profiles in Separate Files.pdf" okay
   Installed "FSUIPC5 History.pdf" okay
   Installed "Lua Plugins for VRInsight Devices.pdf" okay
   Installed "ASN WX Radar facilities in FSUIPC4.pdf" okay
   Installed "Offset Mapping for PMDG 737NGX.pdf" okay
   Installed "Offset Mapping for PMDG 777X.pdf" okay
   Installed "Offset Mapping for PMDG 747QOTSII.pdf" okay
===========================================================
 
All installer tasks completed.
Registration dialog exit: selected  FSUIPC CHECK
Checking FSUIPC registration ...
Registration check for FSUIPC5 was successful! (result code 00)
 
*************** End of Install Log ***************
 
 
icon-envelope-tick-round-orange-animated Virus-free. www.avast.com
   Installed "LuaFileSystem.pdf" okay
   Installed "Example LUA plugins.zip" okay
   Installed "FSUIPC4 Offsets Status.pdf" okay
   Installed "Profiles in Separate Files.pdf" okay
   Installed "FSUIPC5 History.pdf" okay
   Installed "Lua Plugins for VRInsight Devices.pdf" okay
   Installed "ASN WX Radar facilities in FSUIPC4.pdf" okay
   Installed "Offset Mapping for PMDG 737NGX.pdf" okay
   Installed "Offset Mapping for PMDG 777X.pdf" okay
   Installed "Offset Mapping for PMDG 747QOTSII.pdf" okay
===========================================================
 
All installer tasks completed.
Registration dialog exit: selected  FSUIPC CHECK
Checking FSUIPC registration ...
Registration check for FSUIPC5 was successful! (result code 00)
 
*************** End of Install Log ***************
 
 
Thanks 
 
 
icon-envelope-tick-round-orange-animated Virus-free. www.avast.com

Paul

Share this post


Link to post
Share on other sites
6 hours ago, paulavny said:

Cannot edit the DLL.XML file to activate FSUIPC.            👨‍✈️ Looks a bit strange 

This is the SAME as two days ago!

When that message is logged, you also would have had a message box telling you that the DLL.XML file is bad. You need to delete it THEN re-run the Installer!

Pete

 

 

Share this post


Link to post
Share on other sites

Hello Pete ,

that’s exactly the point . It’s exactly the same .Everything was deleted .

Maybe I need to reinstall the P3D and then run the DLL till I will not see that line again .How is the correct line should read ?

 In any event , leaving town today for a few days. Will try it ( unless you have any

 other advise)in a few days .

Regards

Paul

Share this post


Link to post
Share on other sites
45 minutes ago, paulavny said:

That’s exactly the point . It’s exactly the same .Everything was deleted .

What "everything"?  Obviously the DLL.XML file had NOT been deleted, as you can see from the log you posted:

9 hours ago, paulavny said:
Now checking DLL.XML ...
... There is a previous DLL.XML, checking for FSUIPC5 section.

The DLL.XML file is in C:\Users\Paul\AppData\Roaming\Lockheed Martin\Prepar3D v4
That's where you need to delete it!

Pete

 

Share this post


Link to post
Share on other sites
On 11/23/2017 at 7:10 AM, Pete Dowson said:

The DLL.XML file is in C:\Users\Paul\AppData\Roaming\Lockheed Martin\Prepar3D v4
That's where you need to delete it!

Pete

Yes ,Yes .....

Deleted there , and reinstalled the correct one - and it’s working perfectly .

 Pete , many thanks for your help

Paul

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.