Jump to content
The simFlight Network Forums

Lua Sockets with FSUIPC5/6/7


Recommended Posts

**** Updated on 21st May 2021 ****

To use the Lua Socket library om FSUIPC5/6/7, first download the luasocket-2.0.2 library from:
     http://files.luaforge.net/releases/luasocket/luasocket/luasocket-2.0.2/luasocket-2.0.2-lua-5.1.2-Win32-vc8.zip
Extract and copy the file lua/socket.lua to your FSUIPC installation folder.

Then, to use in lua scripts, use
    local socket=require("socket")
 

There should be no need to copy the core.dll as explained below, but I will leave this thread for reference.

Thanks to @Djeez for reporting this.

**********************************

You an get lua sockets under Fsuipc5 by loading the 32-bit luasocket library from
http://files.luaforge.net/releases/luasocket/luasocket/luasocket-2.0.2/luasocket-2.0.2-lua-5.1.2-Win32-vc8.zip

Unpack it into "modules/Lua", but then replace "socket/core.dll" with the one from  https://download.zerobrane.com/luasocket-win64.zip.

 

[This is from a post by Luis Damas, with thanks!]

Pete

 

Edited by John Dowson
Updated for 2021
Link to post
Share on other sites
  • Pete Dowson pinned this topic
  • 10 months later...
On 10/17/2018 at 1:00 PM, manuelthomi said:

The download link to luasocket-win64.zip is dead. Could you please provide the core.dll?

I'm afraid I don't have it. The link was provided by Luis Damas, as it says.  However you'll find the 2.0.2 package eaily with Google or another search app. For example, try http://luaforge.net/projects/luasocket/

Pete

 

Link to post
Share on other sites
18 hours ago, manuelthomi said:

I found that too but I think this is the 32bit version. Don't I need the 64bit version?

Yes, but I did think it included both. If not, I'm sorry, I think more searching is needed. Maybe some good user will post a better link, or even supply the actual file(s). I'd then see if could host them here to make things easier in future. Getting in touch with Luis Damas would be a good idea -- I've sent him a PM.

Pete

 

Link to post
Share on other sites
35 minutes ago, Frédéric-O DUCHEMIN said:

I have P3V4 (X64) and need Lua socket for Throttle Manager works.
Seems working but I don't find files to give you.
So Have you found version X64 ?

Not yet. But if you have it working there will be other DLL's (as well as FSUIPC5) either in Modules or in a subfolder in Modules, like Modules\Lua or similar.

Pete

 

 

Link to post
Share on other sites
  • John Dowson changed the title to Lua Sockets with FSUIPC5/6/7

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.