Jump to content
The simFlight Network Forums
hannik

Weird problem with keysend feature

Recommended Posts

Hi Pete and guys!

I have 2 pc's connected in a homegroup. Both pc's are using WIN10.

The "server" pc is running FSX:SE and has a Thrustmaster Joystik attached. It also has a full version of FSUIPC4 V 4.972 with WideFS enabled.

The "client" pc is running WideFS / WideClient V 6.999z4 and among several utilities I use Pilot2ATC (P2A).

Now, everything has been working perfectly for about 1½ years. The P2A reads the information from FSX (position, radio freq's, Xponder setting etc.) and P2A sets the new frequencies when new one are assigned from ATC.

I have also defined a "Keysend" function on the server for one of the buttons on the Thrustmaster, so that pressing this button is sent to the client and is "converted" there to simulate pressing the F12 button. P2A is then set up to recognize the F12 as a "push-to-talk" (PTT) button.

Now to the problem.

In start december there was an update to WIN10. After installing and repairing all the bad things that update did (Microsoft is creating jobs all over the world!) there was a couple of weeks ago also an update to P2A. This update was a complete new installation and was the first 64-bit version of the product.
After reconfiguring the P2A everythig is now working very fine except for one, simple thing - the Keysend function simulating the pressing of F12 key on the client keyboard.
I have now tried the last week to get it to work but without success. I can use the mouse on the client to press the PTT button - that works. I can press the F12 key on the client to activate the PTT button - that works also. But pressing the button on the Thrustmaster will not work.

Now to the weird thing.

During the last week, where I have tried almost everything to make it work, I have experienced that 2 days ago during a 5 minutes period and 3 days ago during 10 minutes the keysend function DID WORK! Very strange.

Have you or anybody else experienced this kind of problem and are you able to help me with a solution?

Unfortunately english is not my native language, but I hope you are able to understand my bad english better than good danish!

Kind regards
Jannik

Share this post


Link to post
Share on other sites
1 hour ago, hannik said:

After reconfiguring the P2A everythig is now working very fine except for one, simple thing - the Keysend function simulating the pressing of F12 key on the client keyboard.

The only thing I can think of, and probably the most likely thing, is that the way the 32-bit program, WideClient, is sending the Keystroke does not work with a 64-bit program. You might need to try changing the way it works. There are a couple of different ways documented in the WideClient docs.

Pete

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.