Jump to content
The simFlight Network Forums
mickwilliams36

FSUIPC Window not visible

Recommended Posts

Hi,

I'm having a strange issue with the latest version of FSUIPC (5.123c). I can see it in the Add-ons list in P3D v4.1, but when I select it no GUI window appears. I've tried re loading the P3D client and also re installing FSUIPC, but this has made no difference.

Any help on this would be greatly appreciated?

Regards,

Mick

FSUIPC5.log

Edited by mickwilliams36
added log file

Share this post


Link to post
Share on other sites

Hi,

On 10/02/2018 at 12:33 PM, mickwilliams36 said:

Hi,

I'm having a strange issue with the latest version of FSUIPC (5.123c). I can see it in the Add-ons list in P3D v4.1, but when I select it no GUI window appears. I've tried re loading the P3D client and also re installing FSUIPC, but this has made no difference.

Any help on this would be greatly appreciated?

Regards,

Mick

as there is already a problem please the complete FSUIPC5.log file after FS was fully closed the log file complete written.

Quote

      344 SimConnect_Open succeeded: waiting to check version okay
      344 Opened separate AI Traffic client okay
      375 VRI port 1 "com6" opened
     9953 Running in "Lockheed Martin® Prepar3D® v4", Version: 4.1.7.22841 (SimConnect: 4.1.0.0)
     9953 Initialising SimConnect data requests now
     9953 FSUIPC Menu entry added
     9969 ... Using Prepar3D with Academic License

    10000 \\SERVER\Users\The Williams Family\AppData\Local\Lockheed Martin\Prepar3D v4\Prepar3D_Default.fxml
    10000 \\SERVER\Lockheed Martin\Prepar3D v4\SimObjects\Airplanes\IRIS Raptor Driver\Raptor.air
    10297 VRI MCP2A ("MCP2 Airbus") detected on port com6
   107344 \\SERVER\Users\The Williams Family\Documents\Prepar3D v4 Add-ons\ProSim-AR\SimObjects\Airplanes\ProSim737-800 Professional\Prosim738_pro.air
   252297 Aircraft loaded: running normally now ...
   252344 User Aircraft ID 1 supplied, now being used
   252937 System time = 10/02/2018 12:25:20, Simulator time = 12:21:19 (11:21Z)
   252953 Aircraft="Prosim_AR_737_800_Easyjet"
   259906 -------------------- Starting everything now ----------------------
   259906 Using "D:\Lockheed Martin\Prepar3D v4\Modules\GFDEV64.DLL", version 2.2.8.0
   259937 ASN active function link set
   259937 Ready for ActiveSky WX radar with additional data
   259969 LUA.0: beginning "D:\Lockheed Martin\Prepar3D v4\Modules\ipcReady.lua"
   260078 LUA.1: [START] *********************** STARTING LINDA ***********************
   260094 LUA.1: LINDA:: [START] Loading System Configuration files
   260109 LUA.1: LINDA:: *********************************************************************
   260109 LUA.1: LINDA:: [START] WARNING - All LUA logging switched off !!!
   260109 LUA.1: LINDA:: [START] Go to Setup LINDA to switch on (if required)
   260109 LUA.1: LINDA:: *********************************************************************
   260140 LUA.1: LINDA:: [START] System Configuration files loaded
   263281 Advanced Weather Interface Enabled
   426281 --------------------------------------------------------------------
 . . .

. . .
   427656 -------------------------------------------------------------------
   436281 **** No SimConnect events or states being received! Re-connecting now ... ****
   436640 SimConnect_Open succeeded: waiting to check version okay
   436640 Opened separate AI Traffic client okay
   437734 Running in "Lockheed Martin® Prepar3D® v4", Version: 4.1.7.22841 (SimConnect: 4.1.0.0)
   437734 Initialising SimConnect data requests now
   437734 FSUIPC Menu entry added
   437750 ... Using Prepar3D with Academic License
   437750 User Aircraft ID 1 supplied, now being used

   437750 Exception 3 "UNRECOGNIZED_ID", Ref 20, Index param 1 on write SetData for "GENERAL ENG THROTTLE LEVER POSITION:1"

In case the rest of the log file is missing it doesn't tell much. Does FS fully close?

Thomas

Share this post


Link to post
Share on other sites

Same problem here if with 5.123c - the FSUIPC window will only open once, subsequent attempts to open it are unsuccessful and I have to restart P3DV4.1 in order to be able to open FSUIPC one more time.  

Share this post


Link to post
Share on other sites

I have hit the same problem with 5.123c. The FSUIPC add-on dialog randomly appears initially but once closed it can not be reopened unless P3D is restarted. I have also tried 5.121c and 5.122 with the same issue.

Share this post


Link to post
Share on other sites

Hi,

but in case that was never reported before FSUIPC5.123c, at least not that I remember, it cannot really have to do with FSUIPC5.123c when you have the same effect with 5.121c and 5.122 (I guess). Which Windows is used, maybe another nice MS update?

Btw - No problem here, but I don't have any Add-ons installed at all.

Thomas

Share this post


Link to post
Share on other sites

I use 5.122 at the moment with no problems. Updated to 5.123c and had the issue mentioned here with the dialog not showing. Went back to 5.122 and all is OK again. 

Share this post


Link to post
Share on other sites

I previously had no problems with 5.121 or 5.122 but you do not always need to open the FSUIPC dialog once you have your axes and any buttons set up. I have GSX and FSLabs in my add-on menu. I also use LINDA 3.0.5 as my primary interface through FSUIPC5. FSUIPC5 continues to work fine but you can not changes anything without the Add-on menu selected dialog.

Share this post


Link to post
Share on other sites

Hello,

I have just tried 5.123d and I'm afraid I am still having the same problem of no window when I select FSUIPC from the add-on menu.

Here's my log file:

********* FSUIPC5, Version 5.123d (20th February 2018) by Pete Dowson *********
Running inside Prepar3D v4
Module base=7FFED0620000
Windows 10 Home 64 Bit reported as Build 16299, Release ID: 1709 (OS 10.0)
Prepar3D.exe version = 4.2.21.24048
Reading options from "D:\Lockheed Martin\Prepar3D v4\Modules\FSUIPC5.ini"
Checking the Registrations now ...
User Name="michael williams"
User Addr="mickwilliams36@hotmail.com"
FSUIPC5 Key is provided
WideFS7 Key is provided
       16 System time = 20/02/2018 16:57:26
       63 FLT UNC path = "\\SERVER\Users\The Williams Family\Documents\Prepar3D v4 Files\"
       63 ------ Module Version Check ------
       63        acontain.dll: 4.2.21.24048
       63             api.dll: 4.2.21.24048
       63        controls.dll: 4.2.21.24048
       63      fs-traffic.dll: 4.2.21.24048
       63             G3D.dll: 4.2.21.24048
       63        language.dll: 4.2.21.24048
       63            sim1.dll: 4.2.21.24048
       63        visualfx.dll: 4.2.21.24048
       63         weather.dll: 4.2.21.24048
       63          window.dll: 4.2.21.24048
       63 ----------------------------------
       94 FS UNC path = "\\SERVER\Lockheed Martin\Prepar3D v4\"
      250 ---------------------- Joystick Device Scan -----------------------
      266 Product= Joystick - HOTAS Warthog
      266    Manufacturer= Thustmaster
      266    Vendor=044F, Product=0402 (Version 1.0)
      281    GUIDs returned for product: VID_044F&PID_0402:
      281       GUID= {741A0E10-C376-11E5-8006-444553540000}
      281       Details: Btns=19, POVs=(0, 0, 0, 0), Cal=x00000000, Max=R0,U0,V0,X65535,Y65535,Z0
      281 Product= Virtual joystick
      281    Manufacturer= PoLabs
      281    Serial Number= 2.35564
      281    Vendor=1DC3, Product=1001 (Version 16.0)
      281    GUIDs returned for product: VID_1DC3&PID_1001:
      281       GUID= {3BA9A1B0-D1B4-11E6-8001-444553540000}
      281       Details: Btns=32, POVs=(0, 0, 0, 0), Cal=x00000000, Max=R0,U4095,V4095,X4095,Y4095,Z4095
      281       GUID= {3BAADA30-D1B4-11E6-8002-444553540000}
      281       Details: Btns=32, POVs=(0, 0, 0, 0), Cal=x00000000, Max=R0,U4095,V4095,X4095,Y4095,Z4095
      281       GUID= {A97310F0-DB3C-11E6-8001-444553540000}
      281       Details: Btns=0, POVs=(0, 0, 0, 0), Cal=x00000000, Max=R0,U0,V0,X0,Y0,Z0
      281 Product= Virtual joystick
      281    Manufacturer= PoLabs
      281    Serial Number= 2.35590
      281    Vendor=1DC3, Product=1001 (Version 16.0)
      281 Product= Throttle - HOTAS Warthog
      281    Manufacturer= Thrustmaster
      281    Vendor=044F, Product=0404 (Version 1.0)
      281    GUIDs returned for product: VID_044F&PID_0404:
      281       GUID= {741BBBC0-C376-11E5-800B-444553540000}
      281       Details: Btns=32, POVs=(0, 0, 0, 0), Cal=x00000000, Max=R16383,U1023,V0,X1023,Y1023,Z16383
      281 Product= Saitek Pro Flight Combat Rudder Pedals
      281    Manufacturer= Saitek
      281    Vendor=06A3, Product=0764 (Version 2.1)
      281    GUIDs returned for product: VID_06A3&PID_0764:
      281       GUID= {74091E20-C376-11E5-8001-444553540000}
      281       Details: Btns=0, POVs=(0, 0, 0, 0), Cal=x00000000, Max=R1023,U0,V0,X127,Y127,Z0
      281 Product= Logitech Extreme 3D Pro
      281    Manufacturer= Logitech
      281    Vendor=046D, Product=C215 (Version 53.0)
      281    GUIDs returned for product: VID_046D&PID_C215:
      281       GUID= {5A06BC10-E8DF-11E5-8001-444553540000}
      281       Details: Btns=12, POVs=(0, 0, 0, 0), Cal=x00000000, Max=R255,U0,V0,X1023,Y1023,Z255
      281 -------------------------------------------------------------------
      297 Device acquired for use:
      297    Joystick ID = 2 (Registry okay)
      297    2=Joystick - HOTAS Warthog
      297    2.GUID={741A0E10-C376-11E5-8006-444553540000}
      297 Device acquired for use:
      297    Joystick ID = 1 (Registry okay)
      297    1=Virtual Joystick
      297    1.GUID={3BA9A1B0-D1B4-11E6-8001-444553540000}
      297 Device acquired for use:
      297    Joystick ID = 3 (Registry okay)
      297    3=Virtual Joystick
      297    3.GUID={3BAADA30-D1B4-11E6-8002-444553540000}
      297 Device acquired for use:
      297    Joystick ID = 4 (Registry okay)
      297    4=Throttle - HOTAS Warthog
      297    4.GUID={741BBBC0-C376-11E5-800B-444553540000}
      297 Device acquired for use:
      297    Joystick ID = 0 (Registry okay)
      297    0=Saitek Pro Flight Combat Rudder Pedals
      297    0.GUID={74091E20-C376-11E5-8001-444553540000}
      297 Device acquired for use:
      297    Joystick ID = 6 (Registry okay)
      297    6=Logitech Extreme 3D Pro
      297    6.GUID={5A06BC10-E8DF-11E5-8001-444553540000}
      297 -------------------------------------------------------------------
      313 LogOptions=00000000 00000001
      328 -------------------------------------------------------------------
      328 SimConnect_Open succeeded: waiting to check version okay
      328 Opened separate AI Traffic client okay
      328 VRI port 1 "com6" failed to open
    12672 Running in "Lockheed Martin® Prepar3D® v4", Version: 4.2.21.24048 (SimConnect: 4.2.0.0)
    12672 Initialising SimConnect data requests now
    12672 FSUIPC Menu entry added
    12688 ... Using Prepar3D with Academic License
    12750 \\SERVER\Users\The Williams Family\AppData\Local\Lockheed Martin\Prepar3D v4\Prepar3D_Default.fxml
    12750 \\SERVER\Lockheed Martin\Prepar3D v4\SimObjects\Airplanes\IRIS Raptor Driver\Raptor.air
    59766 \\SERVER\Users\The Williams Family\Documents\Prepar3D v4 Add-ons\ProSim-AR\SimObjects\Airplanes\ProSim737-800 Professional\Prosim738_pro.air
   205375 Aircraft loaded: running normally now ...
   205375 User Aircraft ID 1 supplied, now being used
   205813 System time = 20/02/2018 17:00:52, Simulator time = 16:57:40 (16:57Z)
   205813 Aircraft="Prosim_AR_737_800_British Airways"
   212610 -------------------- Starting everything now ----------------------
   212625 Using "D:\Lockheed Martin\Prepar3D v4\Modules\GFDEV64.DLL", version 2.2.8.0
   212672 LUA.0: beginning "D:\Lockheed Martin\Prepar3D v4\Modules\ipcReady.lua"
   212688 ASN active function link set
   212688 Ready for ActiveSky WX radar with additional data
   212688 ... Creating WxRadar binary file as:
   212688 N:\Prosim737\ProSim737\radar.bin
   212781 LUA.1: [START] *********************** STARTING LINDA ***********************
   212797 LUA.1: LINDA:: [START] Loading System Configuration files
   212813 LUA.1: LINDA:: *********************************************************************
   212813 LUA.1: LINDA:: [START] WARNING - All LUA logging switched off !!!
   212813 LUA.1: LINDA:: [START] Go to Setup LINDA to switch on (if required)
   212813 LUA.1: LINDA:: *********************************************************************
   212844 LUA.1: LINDA:: [START] System Configuration files loaded
   213391 Weather Mode now = Theme
   215781 Advanced Weather Interface Enabled
   359578 Sim stopped: average frame rate for last 154 secs = 29.0 fps
   359578    Max AI traffic was 66 aircraft (Deleted 0)
   494406 Sim stopped: average frame rate for last 129 secs = 29.0 fps
   494406    Max AI traffic was 66 aircraft (Deleted 0)
  1270141 LUA: "linda.lua": killed
  1270719 LUA.1: [START] *********************** STARTING LINDA ***********************
  1270735 LUA.1: LINDA:: [START] Loading System Configuration files
  1270750 LUA.1: LINDA:: *********************************************************************
  1270750 LUA.1: LINDA:: [START] WARNING - All LUA logging switched off !!!
  1270750 LUA.1: LINDA:: [START] Go to Setup LINDA to switch on (if required)
  1270750 LUA.1: LINDA:: *********************************************************************
  1270781 LUA.1: LINDA:: [START] System Configuration files loaded
  1272500 LUA: "D:\Lockheed Martin\Prepar3D v4\Modules\linda/system/init.lua": killed
  1280516 ### Blocked: attempt made to change LogOptions via 3400, data 0x0000
  1280516 LUA.0: LINDA:: FSUIPC logging bit cleared: 2
  1280703 ### Blocked: attempt made to change LogOptions via 3400, data 0x0001
  1280703 LUA.0: LINDA:: FSUIPC logging bit cleared: 10
  1280813 ### Blocked: attempt made to change LogOptions via 3400, data 0x0001
  1280813 LUA.0: LINDA:: FSUIPC logging bit cleared: 6
  1299719 LUA.0: LINDA:: LVars watching list cleared...
  2150875 Sim stopped: average frame rate for last 1651 secs = 27.7 fps
  2150875    Max AI traffic was 74 aircraft (Deleted 0)
  2152110 === Closing session: waiting for DLLStop to be called ...
  2175453 === DLLStop called ...
  2175453 === Getting Lua plug-ins to close ...
  2175453 === Closing external processes we started ...
  2176453 === About to kill any Lua plug-ins still running ...
  2176594 Lua threads being terminated:
  2176594       0 = "D:\Lockheed Martin\Prepar3D v4\Modules\linda/system/init.lua"
  2176781 LUA: "D:\Lockheed Martin\Prepar3D v4\Modules\linda/system/init.lua": killed
  2179047       1 = "D:\Lockheed Martin\Prepar3D v4\Modules\linda.lua"
  2179203 LUA: "D:\Lockheed Martin\Prepar3D v4\Modules\linda.lua": killed
  2179203 === Closing global Lua thread
  2180219 === About to kill my timers ...
  2180422 === Restoring window procs ...
  2180422 === Unloading libraries ...
  2180422 === stopping other threads ...
  2180422 === ... Button scanning ...
  2180516 === ... Axis scanning ...
  2180625 === Releasing joystick devices ...
  2180625 === Freeing macro memory
  2180625 === Removing any offset overrides
  2180625 === Closing all WideFS threads
  2180656 TransmitClientEvent failed!
  2180656 TransmitClientEvent failed!
  2180656 TransmitClientEvent failed!
  2180781 TransmitClientEvent failed!
  2180781 TransmitClientEvent failed!
  2180781 TransmitClientEvent failed!
  2181188 TransmitClientEvent failed!
  2181188 TransmitClientEvent failed!
  2181188 TransmitClientEvent failed!
  2181688 TransmitClientEvent failed!
  2181688 TransmitClientEvent failed!
  2181688 TransmitClientEvent failed!
  2182094 TransmitClientEvent failed!
  2182094 TransmitClientEvent failed!
  2182094 TransmitClientEvent failed!
  2182500 TransmitClientEvent failed!
  2182500 TransmitClientEvent failed!
  2182500 TransmitClientEvent failed!
  2182906 TransmitClientEvent failed!
  2182906 TransmitClientEvent failed!
  2182906 TransmitClientEvent failed!
  2183406 TransmitClientEvent failed!
  2183406 TransmitClientEvent failed!
  2183406 TransmitClientEvent failed!
  2183906 TransmitClientEvent failed!
  2183906 TransmitClientEvent failed!
  2183906 TransmitClientEvent failed!
  2184313 TransmitClientEvent failed!
  2184313 TransmitClientEvent failed!
  2184313 TransmitClientEvent failed!
  2184922 TransmitClientEvent failed!
  2184922 TransmitClientEvent failed!
  2184922 TransmitClientEvent failed!
  2185328 TransmitClientEvent failed!
  2185328 TransmitClientEvent failed!
  2185328 TransmitClientEvent failed!
  2188500 === Clearing any displays left
  2188500 === NOTE: not calling SimConnect_Close ...
  2188500 === AI slots deleted!
  2188500 === Freeing button memory ...
  2188500 === Closing my Windows ...
  2188500 === Freeing FS libraries ...
  2189500 === Closing devices ...
  2190500 === Closing the Log ... Bye Bye! ...
  2190500 System time = 20/02/2018 17:33:57, Simulator time = 17:29:48 (17:29Z)
  2190500 *** FSUIPC log file being closed
Minimum frame rate was 16.8 fps, Maximum was 29.6 fps
Average frame rate for running time of 1935 secs = 27.9 fps
Maximum AI traffic for session was 74 aircraft
Memory managed: 1127 Allocs, 1126 Freed
********* FSUIPC Log file closed ***********


Regards,

Mick

Share this post


Link to post
Share on other sites
1 hour ago, mickwilliams36 said:

I have just tried 5.123d and I'm afraid I am still having the same problem of no window when I select FSUIPC from the add-on menu.

Why are half the lines in your log crossed out?

5.123d is effectively now identical to 5.122 as far as Simconnect is concerned, and i already have several confirmations that it is fine. Can you try without Linda please?

Also, there is a logging option to show me whether it is FSUIPC of SimConnect. Enable this by adding these two lines to the [General] section of the INI file:

Debug=Please
LogExtras=x8000

Pete

 

Share this post


Link to post
Share on other sites
11 hours ago, Pete Dowson said:

Why are half the lines in your log crossed out?

5.123d is effectively now identical to 5.122 as far as Simconnect is concerned, and i already have several confirmations that it is fine. Can you try without Linda please?

Also, there is a logging option to show me whether it is FSUIPC of SimConnect. Enable this by adding these two lines to the [General] section of the INI file:

Debug=Please
LogExtras=x8000

Pete

 

Hi Pete,

Thanks for your reply. I'm not really sure what happened with the crossed out bit, as it was not intentional.

I'll try what you suggest over the next couple of days and post again with my results.

Regards,

Mick

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.