Jump to content
The simFlight Network Forums
fredkura

Possible Installer Issue with Latest Windows Update

Recommended Posts

I just wanted to report this....

Yesterday I attempted to update FSUIPC5 to 5.124 from an earlier version using the .exe installer.  I received a message that "This app is not compatible with your PC.  Contact software supplier for a version that is".

I am using a WideView arrangement (4 computers), and this was the same message on each.  I have WIN 10 version 1709 loaded on each.  The issue might have to do with the most recent updates KB4088785/KB4088776 dated 27Mar.  Since this is a dedicated system I am using no security software other than the native Defender.

I was able to get around this by transferring the DLL from another computer other then these recently updated.

Fred K

 

Share this post


Link to post
Share on other sites
1 hour ago, fredkura said:

I attempted to update FSUIPC5 to 5.124 from an earlier version using the .exe installer.  I received a message that "This app is not compatible with your PC.  Contact software supplier for a version that is".

I've never seen such a message!  How strange.  I've no idea how it is deciding that!

1 hour ago, fredkura said:

I have WIN 10 version 1709 loaded on each.  The issue might have to do with the most recent updates KB4088785/KB4088776 dated 27Mar.  Since this is a dedicated system I am using no security software other than the native Defender.

Well, it must be a new bug they've introduced. I only have one Win10 PC (staying resolutely on the better system, Win 7, for my 8 satellites), but that was subjected to Windows Updates a couple of days ago.

Without knowing how they could decide such a thing I've no way of changing anything to suit MS's whims like this. Both the Installer and the DLL are compiled with Visual Studio 2015, the same version used and recommended by L-M to match their P3D4.

Please report it to MS as a bug. I'm sure they need to fix this in yet another of thir automatic updates.

Pete

 

Share this post


Link to post
Share on other sites

Hello,

 

I'm not sure it's a bug. THe KB updates KB4088785/KB4088776 are dated 13 March and not on 27 March.

I've two PC already working under W10 PRO latest updated version and my P3Dv4.2 works perfectly with FSUIPC 5.124.

For your information the latest W10 KB is just installed and it's the KB 4089848 dated 22th of March.

 

Improvements and fixes

This update includes quality improvements. No new operating system features are being introduced in this update. Key changes include:

Addresses issue with a GDI handle leak in the Windows Ribbon control.
Addresses issue where users can’t select OK after entering credentials in command line on Windows Server version 1709.
Addresses issues where Bluetooth devices fail to receive data after a restart.
Addresses issue where, during BitLocker decryption or encryption of a drive, files protected with the Encrypting File System (EFS) may become corrupted.
Addresses issue where the server may occasionally encounter an error during file transfer. The error is “Stop D1 in tcpip!TcpSegmentTcbSend”.
Addresses issue where an iSCSI RESET might trigger a cluster failover.
Addresses issue in MPIO where pass-through SCSI requests might lead to a stop error if the disk is pending removal.
Addresses issue where processing of group policies may fail, and policies may be removed as a result. This occurs if the length of the Windows Defender Firewall policy rule exceeds 260 characters.
Addresses issue caused by a new privilege in Windows Server 2016 and Windows 10 version 1709 named « Obtain an impersonation token for another user in the same session”. When applied using Group Policy to those computers, gpresult /h fails to generate reporting data for any setting configured by the Security Configuration Engine (SCE) extension. The error message is “Requested value ‘SeDelegateSessionUserImpersonatePrivilege’ was not found”. The Group Policy Management Console fails to show the privilege in the Settings tab for a GPO where the setting has been configured.
Addresses issue where errors may occur when accessing WebDAV files or folders on a SharePoint site if the file or folder name contains multibyte characters.
Addresses issue where the Remote Desktop License report gets corrupted when it exceeds the 4 KB size limit.
Addresses issue where an Azure point-to-site VPN connection that uses IKEv2 may fail when the user’s device contains a large number of trusted root certificates.
Addresses rendering issue in Microsoft Edge for PDF documents with backgrounds created using various third-party publishing tools.
Addresses issue where a media platform stops responding when changing cameras rapidly on a device.
Addresses issue where a media platform stops responding, which affects media playback in Microsoft Edge, Internet Explorer, and Microsoft PowerPoint.
Addresses issue with spatial audio when used in connection to Dolby Atmos for Headphones.
Addresses issue where a credential prompt that requires administrative privileges appears when a standard user account performs the first logon to a Windows 10 device that has been deployed using Windows Autopilot.
Addresses issue where tiles in the Start menu aren’t preserved when upgrading from Windows 10 version 1607 to Windows 10 version 1709.
Addresses issue with Spell Check and custom dictionaries.
Addresses issue with the press and hold feature when using a pen in Tablet mode.
Addresses issue with editing web password fields using a touch keyboard.
Addresses issue where some Bluetooth card readers don’t work after a restart.

If you installed earlier updates, only the new fixes in this package will be downloaded and installed on your device.

 

And I don't use Windows Defender

 

Hope this help

Best Regards

Marc

Share this post


Link to post
Share on other sites
3 hours ago, Timonier said:

I'm not sure it's a bug. THe KB updates KB4088785/KB4088776 are dated 13 March and not on 27 March.

Well, there's still nothing I can do about it. Without knowing WHY it suddenly thinks my program, compiled with the same compiler, libraries, and so on, as FSUIPC5 itself, and with the same tools as P3D4 itself, is "not compatible" with your computer, I cannot do anything. And it IS compatible with all my 8 computers!

If it isn't a difference in your Windows installation, it must be something else specific to your PC. I Would add some extra logging, if the program actually started but it sounds lke it is just looking at it!?

Pete

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.