Jump to content
The simFlight Network Forums

FSUIPC4 Problem with FSX and FSX-SE

Recommended Posts

FSX and FSX SE are crashing since a while with following message:


Since the problem occurred, it could always be solved with system recovery. Now for unknown reason I have no restore point anymore, so I cannot execute recovery and have found so far no solution.

Crash does not happen, when FSUIPC4.key is deleted, thus unregistered version is running. Reinstallation did not help. FSX Exception for Virus scanner did not help.

Problem occurred first time after I started working with ADE 1.70 and 1.75 but I cannot see any regulary scheme - it just happened once in a while.

Any idea for help would be appreciated.

Event Viewer:

Protokollname: Application
Quelle:        Application Error
Datum:         27.04.2018 12:03:59
Ereignis-ID:   1000
Ebene:         Fehler
Benutzer:      Nicht zutreffend
Computer:      Flusi-II
Name der fehlerhaften Anwendung: fsx.exe, Version: 10.0.62615.0, Zeitstempel: 0x559f9a9a
Name des fehlerhaften Moduls: FSUIPC4.dll, Version:, Zeitstempel: 0x5aa8e286
Ausnahmecode: 0xc0000417
Fehleroffset: 0x000cd993
ID des fehlerhaften Prozesses: 0xba0
Startzeit der fehlerhaften Anwendung: 0x01d3de0f0359fe32
Pfad der fehlerhaften Anwendung: C:\Program Files (x86)\Steam\steamapps\common\FSX\fsx.exe
Pfad des fehlerhaften Moduls: C:\Program Files (x86)\Steam\steamapps\common\FSX\Modules\FSUIPC4.dll
Berichtskennung: 4d2f093e-4a02-11e8-872f-086266355c36
Vollständiger Name des fehlerhaften Pakets: 
Anwendungs-ID, die relativ zum fehlerhaften Paket ist: 
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <TimeCreated SystemTime="2018-04-27T10:03:59.000000000Z" />
    <Security />
    <Data>C:\Program Files (x86)\Steam\steamapps\common\FSX\fsx.exe</Data>
    <Data>C:\Program Files (x86)\Steam\steamapps\common\FSX\Modules\FSUIPC4.dll</Data>



Link to comment
Share on other sites

Since it doesn't happen when unregistered, I suspect there's something in the settings (FSUIPC4.INI file) which it is processing which is doing this, so I need to see that file.

Please also show me the log resulting from your test with it unregistered.

The Event Viewer crash data you provided shows a module offset of xCD993, which places it in a portion of a standard library, and doesn't help directly. The error x417 is a bit amorphous -- either a buffer overflow or sivalid parameter to a library function.

Have you made any changes since you last ran it successfully?




Link to comment
Share on other sites

9 minutes ago, Kochfix said:

attached are the FSUIPC4.ini from the failure and from the unregistered test and the logfile from unregistered test.

The one you say is the INI from the failure is bereft of any user settings at all. Do you delete the INI file each time you start? There's no need to delete anything!

Even the "unregistered" INI (which would be identical to a registered one if you didn't delete them every time) seems incomplete.

Don't you use FSUIPC for anything? Without any settings it seems it wasn't worth purchasing!?

The log for the failure finishes after the Saitek Pro Pedals are discovered and logged, but before the part where it should log the acquisition for use. This suggests there's some sort of problem in the software installed for those pedals. Could you see what happens if you load up with them disconnected?

If you have Saitek software installed for them it would be best to uninstall that.

Don't you have any yoke? Throttle? Seems odd to only see pedals listed.






Link to comment
Share on other sites

Hi Pete,

last year I started building a homecockpit in my Basement. Due to an accident I had not worked much on that so far. Only activity is testing selfconstucted Hardware wich will be connected with Leo Bodnars BU0836X Joystick board. These test are done on my main Computer upstairs (the new one is still waiting for various Software installations).

Momentarely, my main use of FSUIPC4 is to get back to previous flight when checking my ADE Airports and scenery. This works without the key.

I'm running FSX here upstairs with Saitec Pro Flight Yoke System with rudder pedals and Pro Flight Radio panel. I will check the Software - I'm a bit suspicious about the logitech Drivers which replaced the saitek Drivers some time ago.


Link to comment
Share on other sites

Hi Steve,

Problem has obviously something to do with Saitek Pro Flight Yokes: I pulled the USB and reconnected. This procedure I have to do  - I do not know why -  everytime I started FSX or FSX SE the first time. Otherwise the Yoke won't work.  I just did so and thereafter copied the Keyfile into Modules - and suddenly it works again.

Thanks for yor help - I will let you know, when I figured out something regarding the driver or probably the USB port.


Link to comment
Share on other sites

  • 1 year later...

Many thanks for your answer.

In fact it is not this type of problem, i don'nt find in the register what is described in this topic.

I solved my problem by reinstalling  5 time fsuipc with fsuipc4loader.dll for the last time


So I don'tn know exactly what happened ?


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.