Jump to content
The simFlight Network Forums
Mr_LoL

Some planes that "Arrive now" disappear from game

Recommended Posts

Hi Simon

When a plane arrives now because if traffic conflict, sometimes they disappear from the game completely. STB will tell me they have arrived but they are not at any gates. This mainly happens to Jetblue planes at JFK and Southwest at LAX and a whole host of other airlines at various airports.

There is plenty of space for the planes at the Jetblue terminal at JFK.

I have attached a screeny

Jetblue 662, 454 and 2601 are no longer in the game.

Thanks

STB problems.jpg

Share this post


Link to post
Share on other sites

There isn't enough to go on from the screenshot. One possibility is STB sends requests to the simulator to create the replacement flights, but for some reason the simulator does not do so.  There's not a lot of "error feedback" from the simulator in such situations.  Anyway, set up a trace as per Appendix C of the user guide, reproduce the problem and send me the trace file.

 

Thanks

Simon

Share this post


Link to post
Share on other sites

FWIW I counted 3 failures in the trace, they are all SimConnect exception:

SIMCONNECT_EXCEPTION_OBJECT_CONTAINER

SDK Description of this exception: "Specifies that an attempt to create an AI object failed because of an error with the container system for the object."

The aircraft involved are:

FAIB Airbus A321-100 IAE Jetblue  Prism (x2)

FAIB Airbus A320-200 IAE Jetblue  Retro (x1)

Other aircraft going through the same scenario work fine, such as "Delta Connection Opb ExpressJet CRJ-700", which suggests there's something wrong with the JetBlue aircraft configuration.  I can't fix this as it isn't an STB problem, but you might want to check the aircraft.cfg files to see what the differences are for those AI that work and those that do not.  You might also consider contacting the makers of the repaint and the aircraft.  They may say all is fine since the aircraft show up in the simulator when generated from a traffic BGL.  I don't disagree with that, but there's something amiss in SimConnect either in the aircraft configuration or the way SimConnect is handling it.

Simon

Share this post


Link to post
Share on other sites

Hey Simon

I've figured it out. All my Jetblue paints are like this  texture.Jetblue 'Barcode'. Ive removed the apostrophes from the barcode and everythings working. Thanks

Share this post


Link to post
Share on other sites

That's great to hear.  Clearly the simulator is more tolerant with these AI aircraft when created through the traffic BGL rather than SimConnect.  

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.