Jump to content
The simFlight Network Forums
JackRiordan

ERJ 145XR Becomes Unresponsive

Recommended Posts

I attempted the same flight twice today from KSEA Seattle to CYYJ Victoria in the ERJ 145XR and had issues. Departure went according to plan, and I was well on my way direct to my first fmc entry, DIGGN. Once reaching DIGGN, the aircraft began to bank hard to the right. I noticed that the fmc hadn't automatically switched to the next entry, so I attempted to press the DIR key and the next entry, which should've taken me to the I27 approach to runway 27 at Victoria.

The problem is that the fmc was completely unresponsive. It only maintained direct to DIGGN. None of the buttons would work, so I attempted to set HDG hold until I figured out what was going on, but the button wouldn't work. Throttle levers and ailerons seemed to work ok, but the elevators wouldn't. The avionics also seemed to work fine, as well as the vertical speed dial and hold button.

No other switches or buttons in the cockpit would work.

I decided to restart the flight and try again. During the second flight, the exact same thing happened.

Installation was done as administrator, and I'm using P3Dv4.2. Any help with this is appreciated.

Edited by JackRiordan

Share this post


Link to post
Share on other sites

Ariel,

I just finished the KSEA to CYYJ flight after a full uninstall and reinstall. That seemed to fix the issue. Everything worked as intended this time around. Very enjoyable. Thank you for the assistance.

Furthermore, I appreciate Feelthere for updating their Embraer Regional Jets for P3Dv4 and continuing to offer support for their products.

Have a great day.

Share this post


Link to post
Share on other sites

Well, I thought it was fixed, but during today's Twitch live stream, it did it again. This time, sitting at KSEA, after completing the cold/dark checklist, the FMC becomes unresponsive, stuck on the page 1 of perf. The altitude dial also stops working.

The only other thing I noticed is, when I click the next page button on the FMC,  dsply appears at the top left of the FMC. Other than that, it's completely unresponsive.

I tried running P3Dv4.2 as administrator, but the result was the same. Just after clearing the cold/dark checklist, the FMC becomes unresponsive.

I'll accept if I'm doing something wrong here, but I've flown this aircraft a large number of times in FSX and have never had this issue.

Here is a link to today's live stream...

Maybe this will shed some light on this issue and if it is something I'm doing wrong or if it's an issue with the aircraft itself.

Share this post


Link to post
Share on other sites
3 hours ago, JackRiordan said:

FYI I have the current Navigraph AIRAC 1806 installed for this aircraft.

Have you tried with the included (yes old) database?  Sometime Navigraph data isn't perfect and a bad bit gets into the file.  Please test with default.

Share this post


Link to post
Share on other sites
7 hours ago, scoobflight said:

Have you tried with the included (yes old) database?  Sometime Navigraph data isn't perfect and a bad bit gets into the file.  Please test with default.

I haven't. If I get time this week, I'll try another reinstall of the aircraft, attempt the flight with the default AIRAC, and report back.

Share this post


Link to post
Share on other sites

I downloaded and tried your files.

They are saved on ground and not inflight shortly before problematic place so it took longer to investigate.

Navdata is irrelevant here as it was not in the middle of terminal procedure

I've noticed that you have discontinuity after DIGGN, nevertheless I flew through it and LNAV mode got disconnected as expected and plane kept flying straight. After direct to the next waypoint and enabling LNAV again the plane smoothly proceeded to it. So probably your controls added some noise.

 

I've found a bug in FMC code related to conversion from FSX to P3D, probably it was responsible for erratic behavior in your case. I didn't manage to load your files before I actually fixed it, so I can only guess. Releasing update will take a while and for now please try to remove the discontinuity after DIGGN.

 

Hope it helps.

Share this post


Link to post
Share on other sites

Thank you for taking the time to do that flight. If you made it to departure, than it seems the issue hasn't been reproduced. As you can see from my video, everything in the cockpit seems to stop responding.

I was short on time when I set up the flight again in order to save it for you, and I didn't realize I had left the discontinuity there. It was removed in previous attempts.

I will continue with a full reinstall of the aircraft with admin privileges without updating the navigraph, just to see if the problem persists. I will report back.

In any case, I eagerly await the update.

Share this post


Link to post
Share on other sites

I did a complete uninstall of the ERJ, made sure to remove the feelthere folder and uninstaller file from the P3D directory, restarted my computer, and reinstalled the ERJ with admin privileges. I did not update the AIRAC cycle.

I just attempted the same flight, and once again the aircraft became completely unresponsive as originally posted.

Share this post


Link to post
Share on other sites

The file(s) I sent in a previous reply were saved just before the aircraft became unresponsive. It's unfortunate that you haven't been able to reproduce it on your end. However, I do believe that a solution can eventually be found.

I will include more information that may or may not be helpful in determining the cause of the issue...

 

- I have P3Dv4 installed on another harddrive rather than C: .

- I use the current version of EZDOK. I will try disabling it and attempt the flight again later. Will report back.

- I have assigned my user full admin privileges for the entire P3Dv4 folder.

- I have the registered version of FSUIPC5 installed. Would you recommend I try disabling this?

- I have made sure all SimConnect clients from the P3Dv4 redist folder have been installed.

- I use REX Essentials w/Overdrive. I have attempted the flight with and without it enabled.

- I was able to complete the flight once after reinstalling with admin privileges. However, the problem now persists even when reinstalling with admin privileges.

- Problems persists with and without the current AIRAC installed.

 

Is there any way I can send you a log of the aircraft data before and after the problem occurs?

 

Thank you again for the ongoing support.

Share this post


Link to post
Share on other sites

But the content of attached ERJ 145XR KSEA to CYYJ.fxml suggests that the situation was saved when the plane was standing still on ground

 

<Section Name="SimVars.0">
            <Property Name="Latitude" Value="N47&#xB0; 26&apos; 17.85&quot;" />
            <Property Name="Longitude" Value="W122&#xB0; 17&apos; 54.39&quot;" />
            <Property Name="Altitude" Value="+000436.96" />
            <Property Name="Pitch" Value="1.3216412842323499444" />
            <Property Name="Bank" Value="-0" />
            <Property Name="Heading" Value="74.500004266480289061" />
            <Property Name="PVelBodyAxis" Value="0" />
            <Property Name="BVelBodyAxis" Value="0" />
            <Property Name="HVelBodyAxis" Value="0" />
            <Property Name="XVelBodyAxis" Value="0" />
            <Property Name="YVelBodyAxis" Value="0" />
            <Property Name="ZVelBodyAxis" Value="0" />

            <Property Name="SimOnGround" Value="True" />
            <Property Name="OnPlatformHeight" Value="-9999999999" />
            <Property Name="AssociationID" Value="0" />
            <Property Name="HealthPoints" Value="1" />
        </Section>

Share this post


Link to post
Share on other sites

You are correct. It was saved on the ground, right before the fmc and all buttons in the cockpit become unresponsive.

My original post about the aircraft not responding mid-flight. That was my original experience, and reinstalling with admin privileges seemed to allow me to complete the flight once. This led me to believe I no longer had an issue. However, I had tried the flight again many times after that, and it always became unresponsive after programming the fmc while on the ground at KSEA.

I apologize for the confusion.

Share this post


Link to post
Share on other sites

Thanks for the clarification.

I have reproduced this freeze and fixed it. Hotfix release will take a while, I guess we can offer you to test prerelease fix if you are interested

 

Share this post


Link to post
Share on other sites

Alex,

After downloading and moving the file to the D:\Lockheed Martin\Prepar3D v4\SimObjects\Airplanes\FeelThere ERJ145XR v2\panel folder (overwriting the old one), I'm happy to report that I was able to complete the flight from KSEA Seattle to CYYJ Victoria with no issues.

I will do a few more flights and report back on them as well, but I'm confident that the issue has been resolved.

I haven't tried any flights in the ERJ 135 yet. Do you think the problem will persist with that aircraft, or do you plan on updating it as well?

 

Thank you for your hard work and excellent support :D

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.