Jump to content
The simFlight Network Forums
Sign in to follow this  
Peabody

Tower 3d Pro, readback problem after update

Recommended Posts

I just installed the newest updates for Tower 3d Pro and Real Traffic and JFK and now I have a read back problem.  The game works ok but the readback is messed up. I did not have any speech problems before except taxiways with a one or a ten, C1, B1 etc would not work but  all other two letter or two number taxiways worked fine. Now the two number taxiways work fine but the two letter taxiways get spelled.  MC will read back as M-I-K-E-C-H-A-R-L-I-E.  I did several test at KLAS and all numbered taxiways worked fine.  But at JFK, two letter taxiways get spelled, K4 worked fine. From the log file I noticed this:

PARSE CMD:  PUSHBACK APPROVED, EXPECT RUNWAY 4L VIA A KE K4 K

Readback=SAY: GROUND,  FOUR LEFT  VIA ALFA KILOECHO KILO,FOUR KILO PUSHBACK APPROVED.

I noticed there is a comma between Kilo,Four; but on KE it its all one word and the computer spells it. 

Another one with MC and NA: ONE THREE RIGHT  VIA ALFA NOVEMBERALFA BRAVO MIKECHARLIE PAPA

I have watched a video by ATControl-Joe and it worked fine, mine does not.  Any ideas? Game log attached.  Also noticed a problem with 22L reads doodoooolo.  (no kidding, I put game speech at slowest speed and I can just make out it is trying to say 22L but at high speed.  No sure where to go from here.

Thanks in advance for any assistance.  Peabody

Edit: I should add I am on Win7, if someone using Win7 could try this out it would be appreciated. Also the game works fine the planes go to the right place it is just the readback that is a problem.

 

game.log

Share this post


Link to post
Share on other sites

@FeelThere,

If possible could I get a response to this?   Is this working the way it was intended?  In other words is this a problem with Window 7 readback, or is it a problem for maybe a reinstall.

@anyone with Windows 7:

Since I had no responses, I would like to request anyone using Windows 7 to try a two letter taxiway to see what happens. 

@anyone with Windows 10 willing to help:

Could you try JFK with two letter taxiways and see if the log file shows them written as one word, so I can assume the issue is Win7 and I will have to live with it?

Share this post


Link to post
Share on other sites

Don't give "directions" on push back.  You're forcing the system to try to do something that is not 'realistic' nor technically built into the game (and it's for a reason).  Planes are not given taxi instructions when they are told to push back from the gate.  They are told to push, and what direction their tail should be so that they are pointed in the right direction for taxiing.  It would be useless to give a 'path' for the plane to take on pushback, because who knows what is going to be on that path by the time the plane is ready to taxi.  In my gameplays, i NEVER give instructions to taxi until it's time to taxi.  That is why the system works.

  • Like 1

Share this post


Link to post
Share on other sites

By default, the sim does not allow taxi instructions on pushback.  You can add the following commands to the tower3d.rec file:

#airplane1; PUSHBACK APPROVED EXPECT RUNWAY ;#runway1; TAXI VIA ;#taxiway1;#taxiway2;#taxiway3;#taxiway4;#taxiway5;#taxiway6
#airplane1; PUSHBACK APPROVED EXPECT RUNWAY ;#runway1; VIA ;#taxiway1;#taxiway2;#taxiway3;#taxiway4;#taxiway5;#taxiway6
#airplane1; PUSHBACK APPROVED EXPECT RUNWAY ;#runway1; AT ;#taxiway1; VIA ;#taxiway2;#taxiway3;#taxiway4;#taxiway5;#taxiway6
 

Once again these are not officially supported but I have not had any issues using them.

Share this post


Link to post
Share on other sites
1 hour ago, ATControl -- Joe said:

Don't give "directions" on push back.  You're forcing the system to try to do something that is not 'realistic' nor technically built into the game (and it's for a reason).  Planes are not given taxi instructions when they are told to push back from the gate.  They are told to push, and what direction their tail should be so that they are pointed in the right direction for taxiing.  It would be useless to give a 'path' for the plane to take on pushback, because who knows what is going to be on that path by the time the plane is ready to taxi.  In my gameplays, i NEVER give instructions to taxi until it's time to taxi.  That is why the system works.

I understand that Joe, but I am not as good a player as you, I am now trying to play the "proper way" after watching your videos. Which is the reason I knew that you did not have my problem of the two letter taxiways being spelled instead of spoken like they were before I installed the update.  I am just trying to find out if this is a change or maybe an error during install. My log files before the update to SP3.3c listed MC as Mike Charlie and said "Mike Charlie" now the log shows MC as MikeCharlie and it spells it.

As for not playing the right way, I am taking one step at a time, I'll get there.

This is from the log with no changes to the rec file:

PARSE CMD:  PUSHBACK APPROVED, EXPECT RUNWAY 13R

 

COMMAND: EDV4029 RUNWAY 13R TAXI VIA A MC P
16:02:34 alt: 0 takeoff: False/False/-1 OWNER_GROUND r: 13R * EDV4029 =>   PARSE CMD:  RUNWAY 13R TAXI VIA A MC P
16:02:34 alt: 0 takeoff: False/False/-1 OWNER_GROUND r: 13R * EDV4029 =>  VIA roadcut: RUNWAY 13R TAXI VIA ALFA MIKECHARLIE PAPA
16:02:34 alt: 0 takeoff: False/False/-1 OWNER_GROUND r: 13R * EDV4029 => RUNWAY roadcut: RUNWAY ONE THREE RIGHT  TAXI VIA ALFA MIKECHARLIE PAPA  
16:02:34 alt: 0 takeoff: False/False/-1 OWNER_GROUND r: 13R * EDV4029 => SAY: RUNWAY ONE THREE RIGHT  TAXI VIA ALFA MIKECHARLIE PAPA   ENDEAVOR FOUR ZERO TWO NINER

That is what I am asking help about, MIKECHARLIE is now one word and gets spelled.  It still goes on MC but it won't say it.  This only happens with two letters, not two numgers.  K4 is still spoken as Kilo Four.  NA is Spelled as Novemberalpha.

That is why I was asking someone to look at a log file and see if their log file has "MIKE CHARLIE" or "MIKECHARLIE".  Before the update my log had MIKE CHARLIE.

Your response leads me to believe I didn't get any responses because they misunderstand what I am asking.  The game works fine, the planes go to the runway, they take off, they land. They speech recognitions works, it is only the readback.  As I pointed out in the original post K4 is written as KILO , 4.  There is a comma with the  letter and number but with two letters there is not.  Since I did not get any response, I still don't know if it is a problem with my install or Win7 won't read it correctly. 

Share this post


Link to post
Share on other sites

Peabody, 

What KJFK update did you use? (we have not had KJFK updates for a long while) 

Please make a clean Tower install, try it, then add KJFK, try it and then add real traffic. It's hard to see what is causing it.

Ariel

Share this post


Link to post
Share on other sites
1 hour ago, FeelThere Ariel said:

Peabody, 

What KJFK update did you use? (we have not had KJFK updates for a long while) 

Please make a clean Tower install, try it, then add KJFK, try it and then add real traffic. It's hard to see what is causing it.

Ariel

I updated Tower 3d Pro to SP3.3c,  RT sp6v7 and  KJFK_for_Tower3D_4.2a

One question, is  MIKECHARLIE suppose to be two words for taxiway MC?  That is what I was trying to find out, if it was changed or if there is a problem. If it was changed to one word then the problem may be Win7 not being able to read it.

Share this post


Link to post
Share on other sites

I uninstalled everything, reinstalled ONLY Tower 3D Pro SP3.3c

1. This is the problem:

COMMAND: TAB2361 RUNWAY 9L TAXI VIA J TA K
09:00:48 alt: 0 takeoff: False/False/-1 OWNER_GROUND r: 9L * TAB2361 =>   PARSE CMD:  RUNWAY 9L TAXI VIA J TA K
09:00:48 alt: 0 takeoff: False/False/-1 OWNER_GROUND r: 9L * TAB2361 =>  VIA roadcut: RUNWAY 9L TAXI VIA JULIET TANGOALFA KILO
09:00:48 alt: 0 takeoff: False/False/-1 OWNER_GROUND r: 9L * TAB2361 => RUNWAY roadcut: RUNWAY NINER LEFT  TAXI VIA JULIET TANGOALFA KILO  
09:00:48 alt: 0 takeoff: False/False/-1 OWNER_GROUND r: 9L * TAB2361 => SAY: RUNWAY NINER LEFT  TAXI VIA JULIET TANGOALFA KILO   LESLIE TWO THREE SIX ONE

It will not readback TANGOALPHA, it spells it.  It works, the planes goes to the taxiway fine, but it will NOT read it as Tango Alpha, it spells T_A_N_G_O_A_L_P_H_A

2. At the same airport I send it via K3:

COMMAND: TGB4311 RUNWAY 9L TAXI VIA J K3 K
08:59:51 alt: 0 takeoff: False/False/-1 OWNER_GROUND r: 9L * TGB4311 =>   PARSE CMD:  RUNWAY 9L TAXI VIA J K3 K
08:59:51 alt: 0 takeoff: False/False/-1 OWNER_GROUND r: 9L * TGB4311 =>  VIA roadcut: RUNWAY 9L TAXI VIA JULIET KILO,THREE KILO
08:59:51 alt: 0 takeoff: False/False/-1 OWNER_GROUND r: 9L * TGB4311 => RUNWAY roadcut: RUNWAY NINER LEFT  TAXI VIA JULIET KILO,THREE KILO  
08:59:51 alt: 0 takeoff: False/False/-1 OWNER_GROUND r: 9L * TGB4311 => SAY: RUNWAY NINER LEFT  TAXI VIA JULIET KILO,THREE KILO   GLOBE FOUR THREE ONE ONE

Notice in this case which is a letter and a number K3, there is a comma KILO,THREE.  This reads back properly as Kilo Three.  If the taxiway is two letters NA, MC SB it spells the word, if the taxiway is a letter and a number K3, G2 it reads properly.

__________________________________________________________________________________________________

Now to show the difference, I uninstalled SP3.3c and installed the original program I bought "Tower 3D Pro SP2":

COMMAND: TGB4311 RUNWAY 9L TAXI VIA J TA K
09:00:24 alt: 0 takeoff: False/False/-1 OWNER_GROUND r: 9L * TGB4311 =>   PARSE CMD:  RUNWAY 9L TAXI VIA J TA K
09:00:24 alt: 0 takeoff: False/False/-1 OWNER_GROUND r: 9L * TGB4311 =>  VIA roadcut: RUNWAY 9L TAXI VIA JULIET  TANGO ALFA  KILO  
09:00:24 alt: 0 takeoff: False/False/-1 OWNER_GROUND r: 9L * TGB4311 => RUNWAY roadcut: RUNWAY NINER LEFT  TAXI VIA JULIET  TANGO ALFA  KILO   
09:00:24 alt: 0 takeoff: False/False/-1 OWNER_GROUND r: 9L * TGB4311 => SAY: RUNWAY NINER LEFT  TAXI VIA JULIET  TANGO ALFA  KILO    GLOBE FOUR THREE ONE ONE
09:00:24 * TGB4311 => ADD HISTORY: TGB4311: RUNWAY 9L TAXI VIA J TA K TGB4311

Notice is SP2 the TA is written as two words, TANGO ALPHA and it reads back properly, it does no spell it

In both versions the plane still follow the assigned route to the runway and works, it is ONLY the read back that is a problem. One especially annoying is NA at JFK. It spells N-O-V-E-M-B-E-R-A-L-P-H-A. 

Thank you for looking into this. I appreciate the help.

I am including gamelog from SP2.  The file named "game.log" is from the update SP3.3c

game.log

SP2game.log

Share this post


Link to post
Share on other sites

I assume you are talking about Philadelphia, as there is no 9L at JFK?

I just loaded it up and sent an aircraft by TA and it says it perfectly.

Possibly Windows 7 TTS is at fault?

I am running windows 10.

My log below

Edit: Just tried MC and NA at JFK and also reading back without spelling out 🤔

 

Ben

 

game.log

Share this post


Link to post
Share on other sites

Thank you Hexzed !!!!   I appreciate the help.  Yes the last post was Philly, I had tried KJFK and KLAS to show it was not specific to one airport.  Your log file confirms what I was afraid was the problem.  They changed the two letter taxiways to one word and it no longer works for me.  From your log:

SAY: RUNWAY NINER LEFT  TAXI VIA TANGOALFA KILO   AMERICAN ONE TWO NINER

On the taxiways with a letter and number like "K3" they put a comma: KILO,THREE and it reads right, but the two letters don't have a comma, so I think you are right: Win7 can't read it.

Before the update it used to be "VIA TANGO ALPHA  KILO" 

Again Thank you, at least I know it's not an install problem or corrupt file.

Share this post


Link to post
Share on other sites

It seems the Windows 10 speech is a lot better then!

The only way it seems is to, as you say, split the words up for Windows 7 users.

If the devs will do that, is a different story 😁

 

Ben

Share this post


Link to post
Share on other sites
1 hour ago, hexzed said:

It seems the Windows 10 speech is a lot better then!

The only way it seems is to, as you say, split the words up for Windows 7 users.

If the devs will do that, is a different story 😁

 

Ben

Win7 only has one voice too, so yes 10 speech is better.  Not sure how the taxiways got combined into one word.  I know some people had problems with numbered runways, but I didn't know there was a problem with the letters.  So I'm not sure why it got changed. The only number I ever had trouble was 1, anything with a 1, 10, 16 so on. I noticed the numbered have a comma now, maybe they can do that with the letters, but maybe they won't do anything, nobody with Win10 has a problem.

Share this post


Link to post
Share on other sites
On 6/22/2018 at 8:50 AM, FeelThere Ariel said:

Peabody, 

What KJFK update did you use? (we have not had KJFK updates for a long while) 

Please make a clean Tower install, try it, then add KJFK, try it and then add real traffic. It's hard to see what is causing it.

Ariel

I supplied what you asked for, no comments?

Share this post


Link to post
Share on other sites
On 6/27/2018 at 9:52 AM, FeelThere said:

No comment yet, because we can't re-create the issue. We all run Win 10 by now and we try to check it on Win 7.

 

Vic

 

 

Well, as for testing, I did show in the logfile that the two letter taxiways are now one word, they used to be two words before the SP.  And the letter and number taxiway which is what people were having problems with were two words and now are now separated with a comma.  I am not a programmer but I don't know why that was changed since it worked fine before with the two letter taxiways.  Thank you for listening.

Peabody

Share this post


Link to post
Share on other sites
7 hours ago, FeelThere said:

It was changed to improve the voice recognition on double letter taxiways especially on KJFK. 

 

Vic

Thank you Vic for the response.  I must have missed that, I didn't realize there was a problem with double letter taxiways at JFK. 

Peabody

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.