Jump to content
The simFlight Network Forums
flying-w

STB Client and Data Server OFFICIAL Update V4.2.2018.20200 for Prepar3D-V4.2 and V4.3

Recommended Posts

208366914_Prepar3DV4Tiny.png.27379ef2120de003792023284898f34b.png

Here's the next official update for STB for Prepar3D V4, major changes in bold:

·         Further content updates (airline logos, aircraft and airline configuration files) for Just Flight TrafficGlobal.

·         Major upgrade of the STB Date-Time architecture to support 64bit values and multiweek schedules. The latter provide schedule repeat periods of TWO, FIVE and EIGHT WEEKS in addition to the default.

·         Dates now presented in US format (e.g. Month Day) when the local Windows culture is set to US (or any other culture that uses the same convention).

·         Added the schedule repeat period value to flight details dialogue and show both local and Zulu schedule times when tracing is set to verbose level.

·         STB is compiling all traffic files starting with ".BGL", rather than those that are ".BGL” exactly.

·         Bug fix: When determining the width of the airline logo column, the AirlineLogoWidth setting is always used rather than column properties saved to the settings file.

·         Bug Fix: Null exception caused by STB AI Observer

·         Add a small margin to the airline logo width column to ensure it displays correctly.

·         Added exception handling to the methods that handle callbacks from Simconnect that would otherwise fail silently.

·         Force integer division to double precision where the result can be -1 > 0 < 1, to avoid underrun.

The multi week schedule support turned out to be a huge piece of work, essentially requiring a new approach to the concept of time in STB which took quite some time to get done.  We need a more flexible approach when displaying date/times, so here's an example of what you'll see with a multi week schedule:

image.png.011a09277559994869e5e337f52300e8.png

Flights that occur a week or more away include the full date and time, while those from tomorrow up to a week just include the day name.

The other big change is support for the US style date format, and any other cultures that present the month before the day name.  In other words, looking at the screen shot you will now see "Sun Jun 25 06:24" instead of "Sun 25 Jun 06:24".  The format is automatically set by the culture your Windows PC is using.

Given the amount of change, I'd like to run this update as an open beta.  Please download and install, and please share your experiences whether "good", "bad" or "everything's fine"

 

Many thanks
Simon

Share this post


Link to post
Share on other sites

Thanks Simon...…...one quick question..on the data server..I keep configuring to not start when p3dv4.3 launches and it keeps launching regardless...Any advice or can you look into it for the next edition.

Thanks,

Bob M.

Share this post


Link to post
Share on other sites

I'll look into it, as I need to update STB-DS with the latest changes anyway.  Other than that, how is STB & STB-DS working with 4.3?

Simon

Share this post


Link to post
Share on other sites

Updated the first post above with the details for the STB Data Server (STB-DS) V4.2.2018.20200 installer/updater.

Here it is again to save you scrolling up: http://bit.ly/2Ocw6aj

This is required on your Prepar3D PC when running Prepar3D on a separate computer to the STB client, and you must have upgraded both STB client and STB-DS to the same level.  Both of these updates are for Prepar3D V4.2 and V4.3 only.

Simon

Share this post


Link to post
Share on other sites
5 hours ago, unc1rlm said:

Thanks Simon...…...one quick question..on the data server..I keep configuring to not start when p3dv4.3 launches and it keeps launching regardless...Any advice or can you look into it for the next edition.

Thanks,

Bob M.

Bob - Can you tell me exactlymhow youmtry to disable STB-DS from being autostarted with Prepar3D please?  Can't reproduce the problem at present.

Thanks
Simon

Share this post


Link to post
Share on other sites

Simon-update...didn't see it..downloading new data server...let me run it and see if it does the same stuff. 420pm prob 920pm where you are.

Installed new DS and it did not autolaunch....good. I think we're ok...stb connected with no problem to server.....Sorry for any false information.....Now I am using UTLive again since Traffic Global is still so incomplete...If we can just get rid of those question marks etc..lol  I know you can't🙂

Thanks Bob M.

Share this post


Link to post
Share on other sites
9 hours ago, unc1rlm said:

Simon-update...didn't see it..downloading new data server...let me run it and see if it does the same stuff. 420pm prob 920pm where you are.

Installed new DS and it did not autolaunch....good. I think we're ok...stb connected with no problem to server.....Sorry for any false information.....Now I am using UTLive again since Traffic Global is still so incomplete...If we can just get rid of those question marks etc..lol  I know you can't🙂

Thanks Bob M.

Yes, I am 5h ahead of US East coast right now.  Just a note about the install wizard, it's really just a "deployment tool" rather than a "removal tool".  If a box is checked the corresponding action is taken.  If the box is not checked, nothing is done.  We don't go and try deconfiguring whatever the action might have do if it was checked.  The only time we do go deconfiguring or "undeploying" is during product uninstall.

Specifically about the autostart.  If you really do want that turned off, the way to do it is in Prepar3D itself.

image.thumb.png.59b0fa239cfd4759d9767bf490785e2c.png

Share this post


Link to post
Share on other sites

Hi, just downloaded and installed. Since then STB isn't starting: Any idea?? Many thanks.

System.ArgumentException: Requested value 'WOAI' was not found.

   at System.Enum.TryParseEnum(Type enumType, String value, Boolean ignoreCase, EnumResult& parseResult)

   at System.Enum.Parse(Type enumType, String value, Boolean ignoreCase)

   at FLW.STB.Client.StbSettings.ReadFromTextFile(IWin32Window parent) in C:\Users\simon\OneDrive\Flight Simulator\STB\STB V4 for Prepar3D\STB V4.0 P3D V4\Client\Traffic Board\StbSettings.cs:line 1533

   at FLW.STB.Client.STBClient.LoadSettings() in C:\Users\simon\OneDrive\Flight Simulator\STB\STB V4 for Prepar3D\STB V4.0 P3D V4\Client\Traffic Board\STBClient.cs:line 1577

   at FLW.STB.Client.STBClient..ctor() in C:\Users\simon\OneDrive\Flight Simulator\STB\STB V4 for Prepar3D\STB V4.0 P3D V4\Client\Traffic Board\STBClient.cs:line 1449

   at FLW.STB.SimConnectWrapper.SimConnectWrapper_P3D_V4..ctor() in C:\Users\simon\OneDrive\Flight Simulator\STB\STB V4 for Prepar3D\STB V4.0 P3D V4\Client\SimConnectWrapperP3D\SimConnectWrapper_P3D_V4.cs:line 95

   at STB.Launcher.Program.LoadClient(ClientExceptionHandler eh) in C:\Users\simon\OneDrive\Flight Simulator\STB\STB V4 for Prepar3D\STB V4.0 P3D V4\Client\Front End\TBLauncher.cs:line 28

   at STB.Launcher.Program.Main(String[] args) in C:\Users\simon\OneDrive\Flight Simulator\STB\STB V4 for Prepar3D\STB V4.0 P3D V4\Client\Front End\TBLauncher.cs:line 164



Exception Handler Type: UnHandledExceeption

 

Share this post


Link to post
Share on other sites

Not sure...probably something with your WOAI aircraft....did you add them to the simobject cfg in Program data......Are you networked?

Bob M.

Share this post


Link to post
Share on other sites

I'm not back full time yet, but can in the meantime....  I'm pretty sure I removed the support for WOAI in Prepar3D V4 as they are mostly FS9 models which do not work at all well in Prepar3D V4.  It's likely to be your saved settings from a previous installation of STB for an older simulator.  What's been your upgrade path?

 

Thanks
Simon

Share this post


Link to post
Share on other sites
3 hours ago, flying-w said:

I'm not back full time yet, but can in the meantime....  I'm pretty sure I removed the support for WOAI in Prepar3D V4 as they are mostly FS9 models which do not work at all well in Prepar3D V4.  It's likely to be your saved settings from a previous installation of STB for an older simulator.  What's been your upgrade path?

 

Thanks
Simon

Hi Simon,
thank you for reply.
I last updated STB around summer 2017 (maybe Juli or August) and STB V4 worked well - still with WOAI. (I know about the FS9 incompability and that's more than okay for me as I tried to delete FS9 models)
Maybe you removed the support in the present version?
What can I do to make it run again? Or do I need to switch to UTL?

Many thanks.

Edit:
I uninstalled all WOAI packages. But the error still occurs. Hmm. 😞

 

System.ArgumentException: Requested value 'WOAI' was not found.

   at System.Enum.TryParseEnum(Type enumType, String value, Boolean ignoreCase, EnumResult& parseResult)

   at System.Enum.Parse(Type enumType, String value, Boolean ignoreCase)

   at FLW.STB.Client.StbSettings.ReadFromTextFile(IWin32Window parent) in C:\Users\simon\OneDrive\Flight Simulator\STB\STB V4 for Prepar3D\STB V4.0 P3D V4\Client\Traffic Board\StbSettings.cs:line 1533

   at FLW.STB.Client.STBClient.LoadSettings() in C:\Users\simon\OneDrive\Flight Simulator\STB\STB V4 for Prepar3D\STB V4.0 P3D V4\Client\Traffic Board\STBClient.cs:line 1577

   at FLW.STB.Client.STBClient..ctor() in C:\Users\simon\OneDrive\Flight Simulator\STB\STB V4 for Prepar3D\STB V4.0 P3D V4\Client\Traffic Board\STBClient.cs:line 1449

   at FLW.STB.SimConnectWrapper.SimConnectWrapper_P3D_V4..ctor() in C:\Users\simon\OneDrive\Flight Simulator\STB\STB V4 for Prepar3D\STB V4.0 P3D V4\Client\SimConnectWrapperP3D\SimConnectWrapper_P3D_V4.cs:line 95

   at STB.Launcher.Program.LoadClient(ClientExceptionHandler eh) in C:\Users\simon\OneDrive\Flight Simulator\STB\STB V4 for Prepar3D\STB V4.0 P3D V4\Client\Front End\TBLauncher.cs:line 28

   at STB.Launcher.Program.Main(String[] args) in C:\Users\simon\OneDrive\Flight Simulator\STB\STB V4 for Prepar3D\STB V4.0 P3D V4\Client\Front End\TBLauncher.cs:line 164



Exception Handler Type: UnHandledExceeption

 

Edited by MagicTigger

Share this post


Link to post
Share on other sites

Most likely I removed the support when Traffic Global came along.  In any case I can't recommend UTLive if you like the way WOAI does things.  I suspect there will be better offerings down the line from the likes of AIG which could fill the "gap" we have now in AI freeware.

To fix your problem, you'll need to delete or edit the STB saved settings file (settings.txxt) and remove the reference to WOAI.  You'll find it in the STB application data folder, i.e.

 

image.png.e0ffb2cad831016682699edabb278c3d.png

You can send it to me for editing if you prefer.

 

Thanks
Simon

Share this post


Link to post
Share on other sites
7 minutes ago, flying-w said:

Most likely I removed the support when Traffic Global came along.  In any case I can't recommend UTLive if you like the way WOAI does things.  I suspect there will be better offerings down the line from the likes of AIG which could fill the "gap" we have now in AI freeware.

To fix your problem, you'll need to delete or edit the STB saved settings file (settings.txxt) and remove the reference to WOAI.  You'll find it in the STB application data folder, i.e.

 

image.png.e0ffb2cad831016682699edabb278c3d.png

You can send it to me for editing if you prefer.

 

Thanks
Simon

Thank you Simon, after deleting the settings file STB is starting like a charm.
And I bought Traffic Global. 🙂

Cheers!

Edited by MagicTigger

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.