Jump to content
The simFlight Network Forums
String

PFC C2 Pro - Fuel Selector Marco PFCHID

Recommended Posts

14 minutes ago, String said:

Pete,

Looks like an issue does exist with the KohlsmaBarometeric scale adjustment knob that was difficult to identify. 

ISSUE: Barometeric scale adjustment knob fails to send the Kohlsman commands when "AltAir" is added to the marco file. When "AltAir" is removed from the macro file, the Barometeric scale adjustment knob resumes to send commands and functions normally.

[Macros]
1=TankSelect1/0=C65957
2=TankSelect1/1=C65956
3=TankSelect1/3=C65958
4=AltAir=C66317

This also addresses your question why I added the "ALT" macros in an attempt to get it to function.

Logs provided with the "AltAir" macro and without.

Once the simulator was running I switched the "AltAir" on and off (4) times and then rotated the Barometeric scale adjustment knob both CW and CCW

Chris

 

PFChid64 - with AltAir mcro.log

FSUIPC5 - with AltAir mcro.log

FSUIPC5 - without AltAir mcro.log

PFChid64 - without AltAir mcro.log

I won't have time to look at this before next week. Can you remind me on monday, say?

Pete

 

Share this post


Link to post
Share on other sites
23 minutes ago, Pete Dowson said:

I won't have time to look at this before next week. Can you remind me on Monday, say?

No rush at all. Your time is appreciated!

Chris

Share this post


Link to post
Share on other sites

I just had a quick look at the files you appended, but there's not enough information. Oddly, in the PFChid64 log "without Altair mcro", there appear to be no Alt macros either! No macros in fact -- or at least none invoked! (The Alt inputs received are operating normally, via the P3D4 offsets).

Pete

 

 

 

Share this post


Link to post
Share on other sites
On 9/27/2018 at 2:07 AM, Pete Dowson said:

Oddly, in the PFChid64 log "without Altair mcro", there appear to be no Alt macros either! No macros in fact -- or at least none invoked! (The Alt inputs received are operating normally, via the P3D4 offsets).

Pete,

Following up with you on this issue of the Barometeric scale adjustment knob failing to send the Kohlsman commands when "4=AltAir=C66317" is added to the marco file. When "4=AltAir=C66317" is removed from the macro file, the Barometeric scale adjustment knob resumes to send commands and functions normally.

Do you need any additional information from me?

Chris

Share this post


Link to post
Share on other sites
5 minutes ago, String said:

Do you need any additional information from me

Yes. you've just only told me what you reported before. I still need a comparative log as i said. I did build a revised version for you to test, but I've held it over waiting for the confirmation i need from that -- i.e a log with ALT used without AltAir.

Please do re-read my previous message.

Pete

 

Share this post


Link to post
Share on other sites
3 minutes ago, Pete Dowson said:

I still need a comparative log as i said. I did build a revised version for you to test, but I've held it over waiting for the confirmation i need from that -- i.e a log with ALT used without AltAir.

Pete,

Attached is a log with "4=AltAir=C66317" removed from the macro file.

Below is what wasin the marco file during the test

[Macros]
1=TankSelect1/0=C65957
2=TankSelect1/1=C65956
3=TankSelect1/3=C65958

As before, once the simulator was running I switched the "AltAir" on and off (4) times and then rotated the Barometeric scale adjustment knob both CW and CCW. The AltAir did not function in the cockpit and Kohlsman Barometeric scale change the altimeter perfectly.

 

Chris

PFChid64.log

Share this post


Link to post
Share on other sites
1 hour ago, String said:

Attached is a log with "4=AltAir=C66317" removed from the macro file.

Below is what wasin the marco file during the test

[Macros]
1=TankSelect1/0=C65957
2=TankSelect1/1=C65956
3=TankSelect1/3=C65958

As before, once the simulator was running I switched the "AltAir" on and off (4) times and then rotated the Barometeric scale adjustment knob both CW and CCW. The AltAir did not function in the cockpit and Kohlsman Barometeric scale change the altimeter perfectly.

You provided exactly the same again. I thought your complaint was surely that the Alt macro didn't work when there was an Altair macro present?  As here:
 

Quote

 

2. Kohlsman
Barometeric scale adjustment knob not functioning; Added macros "Alt+" and "Alt-"; The barometeric increase now functions, but the barometeric decrease does not.

 

Or have I misunderstood? That's what iwas looking at!

Reading again your more recent replies, was that a red herring (as we say here -- a false lead)? There's no sign of an Alt masro in the log, as before, and that's what I asked about!

Anyway, just in case, please try this version and let me know. This is the one i had ready a week agao, help awaiting the Log I requested.

Let's try and get the right story between us this time.

http://fsuipc.simflight.com/beta/PFChid64_5126_TEST.zip

Pete

 

Share this post


Link to post
Share on other sites
1 hour ago, Pete Dowson said:

I thought your complaint was surely that the Alt macro didn't work when there was an Altair macro present? 

This is correct and that was the original issue I posted.

...but it is important to note; the only reason I added the ALT+ and ALT- lines to the macro was because when I added 4=AltAir=C66317 to the macro, the Barometeric scale adjustment knob stopped functioning. Somehow the 4=AltAir=C66317 is causing this failure. 

1 hour ago, Pete Dowson said:

please try this version and let me know.

I have tested the new dll with and without the AltAir=C66317 line added to the macroand had the following results:

The Barometeric scale adjustment knob now works with or without the 4=AltAir=C66317 line in the macro.

The Alt Air pull knob no longer works with the 4=AltAir=C66317 line in the macro and continues not to work with without the 4=AltAir=C66317 line in the macro

1 hour ago, Pete Dowson said:

Let's try and get the right story between us this time.

I hope I have clearly described the issues.

Many Thanks,

Chris

 

 

 

PFChid64 - with AltAir mcro.log

PFChid64 - without AltAir mcro.log

Edited by String
Verified correct logs

Share this post


Link to post
Share on other sites
46 minutes ago, String said:

I hope I have clearly described the issues.

I think so.

This is going to take some serious addittional logging.  That's the trouble with not having any way to reproduce it here. At least the last change did make a difference, though not a good one. But perhaps it points to the area needing more examination. 

The problem now is that I have really run out of sufficient time before my next trip away with my good wife. I might not get to it now till possibly the 19th October. Perhaps you could remind me then by another posting on this thread.

Pete

 

Share this post


Link to post
Share on other sites
5 minutes ago, Pete Dowson said:

Perhaps you could remind me then by another posting on this thread.

Pete,

That works perfect. I hope you enjoy your trip and I will reach out to you on your return.

Chris

Share this post


Link to post
Share on other sites
9 hours ago, String said:

The Alt Air pull knob no longer works with the 4=AltAir=C66317 line in the macro and continues not to work with without the 4=AltAir=C66317 line in the macro

I couldn't sleep, so I am up early and have an hour or so to look at this problem. But I realise i do need some clarification of the above.

Looking at the Log, this is the ALTair switch action in your "without macro" log:

    16297: Device #1 received: AltAir[0] = 0
    16297: Full macroname for decoded switch = "PFC:AltAir", mask = X00000000
    16297: ... IPCwrite 3800[8] = 0.000000
    16297: ... IPCwrite 3740[8] = 0.000000
    16297: ... IPCwrite 3680[8] = 0.000000
    16297: ... IPCwrite 35C0[8] = 0.000000
and
    17875: Device #1 received: AltAir[0] = 1
    17875: Full macroname for decoded switch = "PFC:AltAir", mask = X00000000
    17875: ... IPCwrite 3800[8] = 1.000000
    17875: ... IPCwrite 3740[8] = 1.000000
    17875: ... IPCwrite 3680[8] = 1.000000
    17875: ... IPCwrite 35C0[8] = 1.000000

And it is identical with the Macro present. So the macro is being ignored. Do I take it the macro isn't optional for your aaircraft, that the offsets above don't work for it? I don't remember any statement that Altair as also a problem on this aircraft, but I assume that must be the case? So you weren't actually expecting it to work without the Altair nacro in any case?

Pete

 

Share this post


Link to post
Share on other sites
6 hours ago, Pete Dowson said:

And it is identical with the Macro present. So the macro is being ignored.

I agree and I also just realized that the lines added for the fuel select in the macro are also being ignored. It appears that the all macros in the .mcro file are ignored.

6 hours ago, Pete Dowson said:

Do I take it the macro isn't optional for your aircraft, that the offsets above don't work for it?

Correct

6 hours ago, Pete Dowson said:

Altair as also a problem on this aircraft, but I assume that must be the case?

True

6 hours ago, Pete Dowson said:

So you weren't actually expecting it to work without the Altair macro in any case?

True

Thank you

Chris

Share this post


Link to post
Share on other sites

I have had time to add code to allow me to test here without the requisite hardware, but having tested that this code works, i've run out of time to use it on this problem. I might find time on Sunday or Monday, though this is looking unlikely, otherwise it will be the 18th or later as I said.

Pete

 

Share this post


Link to post
Share on other sites
38 minutes ago, Pete Dowson said:

I might find time on Sunday or Monday, though this is looking unlikely, otherwise it will be the 18th or later as I said

Pete,

Sounds good...

Chris

Share this post


Link to post
Share on other sites
On 10/7/2018 at 4:32 AM, Pete Dowson said:

I have got it working okay here, with no hardware but some routines added to try to simulate what would be received.

Please test it on the actual hardware and let me know:

Pete,

Just got back into town and tested v5.127

AltAir and the Barometeric scale adjustment knob are now both working perfectly.

The TankSelect1 is now not working and appears to not be using the macro file.

Current Macro File

[Macros]
1=TankSelect1/0=C65957
2=TankSelect1/1=C65956
3=TankSelect1/3=C65958
4=AltAir=C66317

I have attached logs for your review.

Chris

FSUIPC5.log

PFChid64.log

Share this post


Link to post
Share on other sites
On 10/13/2018 at 7:27 PM, String said:

AltAir and the Barometeric scale adjustment knob are now both working perfectly.

The TankSelect1 is now not working and appears to not be using the macro file.

Strange. I've not touched that part of the code since it last worked ok!

I've got a lot of catching up to do over the next few days. i'll try to get to it next week.

Pete

 

Share this post


Link to post
Share on other sites

Please try PFChid64_5128_TEST.zip.

I'm worried that I'm messing up the other macro forms and  can't test here without the hardware. So, if this version works with your existing macro needs, could you possibly also test the encoder forms with + - < >, with and without the encoder number (1,2, etc) and the simpler button or switch form like landing gear with + and -?

Also, I noticed that the form with /1 to /4 appended to denote different switch positions isn't actually documented for some reason. At least I couldn't find it. Could you tell me where you learned this from please?

Pete

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.