Jump to content
The simFlight Network Forums
SemyuelShekh

Embraer 195 is not capturing the localizer

Recommended Posts

Hi,

After the purchase through Steam, the DLC Embraer EJets 175 195 https://store.steampowered.com/app/364324/FSX_Steam_Edition__Embraer_EJets_175__195_AddOn/ I have a pleasure to fly these amazing regional jets.

*

There is a problem thought. For some reason, capturing localizer is not working when I do a vector approach. The only one case, when autopilot captures a localizer and glideslope - is when following strictly the defined FMS flightplan. In my flights, I prefer as much realizm as possible, that's why mostly I do vector approaches, following ATC guidance and than capturing the localizer vs glideslope on final. I've checked different manual documents, tried turning on NAV and / or APP when on final. But the airplane is not capable to capture and follow localizer unless it is flying all the flightplan waypoints. 
The problem description in a few words: 
During the landing phase, in case of a vector approach, the airplane fails to capture the localizer and glideslope making it impossible to land. 
At the moment I see only two ways to land: 
1) Completely manual landing, without autopilot engaged - not realistic scenario, 
2) Strictly following all the flightplan waypoints, without traffic controller - not realistic scenario.

When capturing the localizer during vector approach with ATC (traffic control) guidance - the PREV mode is turned ON, ILS frequency - set on MCDU, landing runway course - set accordingly. The loc ils markers are shown correctly on the PFD, however it fails to capture the LOC and GS, just passing through.

Could you please take a look at this problem? Maybe I'm missing something? As I said, the documentation was checked, different configurations were used ( PREV, APP on, ILS heading and frequency set for both sides, NAV1 and NAV2) to attempt vector approach, but never succeed.

The most disgusting thing is that I've spend hundreds of hours for learning documentation, flight tutorial videos and introduction flights but the airplane model appears to have critical glitches (((

Please, take a look at the attached screen captures. It looks like the co-pilot PFD is showing something related to the localizer, but the approach mode is never engaged, the airplane is just passing through the localizer ignoring it entirely.

AUTOLAND is enabled in the MCDU. MCDU page / MISC MENU / SETUP

NAV1 and NAV2 both are set to the runway ILS frequency.

Runway course is set for the pilot and co-pilot sides.

Flaps were set to 5 ( I've tried different FULL, 5, 4, 3, 2, - it doesn't work at all).

The only ONE thing that matters is exactly following the flight plan route waypoints. That's not how it's supposed to work.

obj2DENHlDAwm1BUbL3KLXCwxROI9oxWOXdsMD9b

IwCqYJluPv4afMB3NzXFE8r-gPswlOq2OSaoOymN

fKfaIlUd6dHagFjgVIYIOicSZ2oA6vV6jIZNQ9xq

nW5YuRhlmzUCj4UgDGgBLgulqM_iIVV19_LQNnnc

PzW2GtqTe1FFFsv4vBo7HcpgToCQ8EXX2YppKvwo

Kind regards, 
Sem

 

*Edit: emoved purchase information as.that can be used by hackers - mods

Share this post


Link to post
Share on other sites

Please reconfirm your image links - only the first is showing band.

A vector approach will work and does.  Done FS's 'ATC' and using vatsim and 100s hours when writing the manual.

Have you found the YouTube tutorials that show the above working?  They cover all requirements (just duplicates the manual).

Also, from the Ejet FAQ -

confirm you have set the primary navigation source as the navigation rados by pressing the NAV button on the GP/DCP. if the navigation source is the radios the indications on the PFD compass rose will be GREEN.

Share this post


Link to post
Share on other sites

when landing the aircraft, I've set the ILS frequency to the destination runway for NAV1 and NAV2, also set heading course for pilot and copilot, pressed the PREV button and than pressed the APP button, slowed down the aircraft and deployed flaps 5. The LOC and ILS indicators became visible on the PFD. In these conditions the systems are supposed to capture the localizer and switch to the AUTOLEND mode automatically. There is NO NEED to set manually another navigation source. It has to trigger the AUTOLAND mode when the localizer is alive or captured (according to the documentation - Ejets v2 Manual, page 54). Following the standard, the AUTOLAND system, same as localizer capturing should work independently from the MCDU programmed flight path.

Currently, it only engages the autolend in case if the aircraft is strictly following all the flightplan route waypoints. Otherwise, the autoland is never ON, thats a glitch that has to be fixed. Is it possible to fix that?

In general, after learning tutorials and manuals, I'm happy playing the Embraer 195, the only problem that makes me upset is the AUTOLEND system glitch.

Like I've said above, the autolend system should work independently from the MCDU programmed flight plan. Is should not be based on the route waypoints. At the moment the AUTOLEND is engaged normally if the route waypoints are passed one by one, which is wrong. 

Please let me know if this can be fixed or not. If not, I just lost my money.

p.s.

for some reason I couldn't find any vector approach tutorial on youtube. There are only manual landings or MCDU - flightplan based ( without traffic controller guidance ). I read the description of the autoland engaging in the Ejets manual only.

-- Sem

Share this post


Link to post
Share on other sites

I'm assuming you are following the manual for the steps required - the game's, not a real one.

I've autolanded this plane not following the flightplan.  Done it with no flightplan in the MCDU.  Done it vectored by a vatsim controller.

The sim is close to 10th years old and never received your complaint.

Share this post


Link to post
Share on other sites

Didn't I write that in my first post?

15 hours ago, scoobflight said:

Also, from the Ejet FAQ -

confirm you have set the primary navigation source as the navigation rados by pressing the NAV button on the GP/DCP. if the navigation source is the radios the indications on the PFD compass rose will be GREEN.

Glad it is now working for you 🙂

Share this post


Link to post
Share on other sites

right, the navigation source has to be set to radios, not the FMS, but instead of NAV, it needs to push the V/L button.

-- Sem

Edited by SemyuelShekh

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.