Jump to content
The simFlight Network Forums

Simconnect error


Recommended Posts

Hi

I installed STB and it has crashed my simconnect. I have P3DV4 and a number of other addons which worked perfectly up to today. Now when I start I receive the following message "cant init simconnect - error code 0x80004005. I have reinstalled the simconnect packs, and even removed and reinstalled P3D and all addons. However, the same issues remain. The addon menu has disappeared from my P3D too on the toolbar. No network and all locally installed.

 

Hope someone can help.

 

Rgds

 

Paul

Link to post
Share on other sites
9 hours ago, paul007 said:

I installed STB and it has crashed my simconnect. I have P3DV4 and a number of other addons which worked perfectly up to today.

It's unlikely an add-on by itself could cause this kind of behaviour in Prepar3D.  If it can, Lockheed Martin has a problem to fix here.  

 

9 hours ago, paul007 said:

Now when I start I receive the following message "cant init simconnect - error code 0x80004005.

You'll see plenty of these errors if you google, and mostly do to with other add-ons.  The actual error code is coming from Windows, and SimConnect relies heavily on Windows network services (even when everything is self contained on a single computer) to deliver it's work.

 

9 hours ago, paul007 said:

. I have reinstalled the simconnect packs, and even removed and reinstalled P3D and all addons. However, the same issues remain. The

Not sure reinstalling simconnect is going to help.  Unlike a lot of apps out there, STB uses the native Prepar3D v4.2 simconnect client which does not require installing in any event.

 

9 hours ago, paul007 said:

The addon menu has disappeared from my P3D too on the toolbar. No network and all locally installed. 
 

That's most likely a side effect of the simconnect issue described above.

 

All that said I will try to help, as I've never seen this error in the 10 years since I've been doing this.  First of all, please check for the following files and send them over to me if you have them

1) My Documents/simconnect.cfg

2) simconnect.xml from the Prepar3D Program Data Folder. (check the application data folder also)

Thanks

Simon

Link to post
Share on other sites

Hi Paul

Glad to hear it's resolved as I know reinstalling windows onwards is quite a task.  I've not tried PSXseecon, however I expect it will work like the other traffic injectors out there such as UTLive as far as it's interface with the simulator is concerned.  For traffic injectors we do not get as detailed information from the simulator as we do for traditional schedules, so there are some limitations.  Please see here for details:

http://www.supertrafficboard.com/ExternalSchedulingEngineSupport.html

 

Thanks
Simon

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.