Jump to content
The simFlight Network Forums
peterk54

2 simulators in 1 network

Recommended Posts

Hello

I have 2 simulators running in one network. One P3D v3, the other P3D v4. Both SDK's installed. Each latest versions.
Each simulator uses the Server and some PC's as client to show (non P3D) instruments and performing aircarft system task.
Data sent thru FSUIPC and WideCLients, each newest versions.

Each sim does run by itself in an excellent way. Each sim-system is setup that after WideClients is connected, our programms start automatically.
No issues to connect with other appllications i.e. Sim Commander.

Issues starts when both sims run together. FIrst starts with no issues. The second one however we need to stop and restart the Wideclients before they connect. Once done, everything seems to be perfect.

- Do we need to configure SimConnect on the servers and the respective clients manually ?
- FSUIPC is configured with the servers name, not the IP ? Do we need to change ?
- All computers using WideClients on the same IP ports. Do we need to change ?
- Any comments where we shall start to search ?

Thanks and greetings from Switzerland
Peter

Share this post


Link to post
Share on other sites
1 hour ago, peterk54 said:

Issues starts when both sims run together. FIrst starts with no issues. The second one however we need to stop and restart the Wideclients before they connect.

Are the WideClients set to interface specifically to the separate PCs running the sims (i.e. ia ServerName or ServerIPAddr, and Protocol parameters)? If not then natuarally they'll all attach to the one already running.

1 hour ago, peterk54 said:

Do we need to configure SimConnect on the servers and the respective clients manually ?

WideFS does not use SimConnect.

1 hour ago, peterk54 said:

FSUIPC is configured with the servers name, not the IP ?

FSUIPC has no provision for Server name or IP. It runs on the server. Do you mean WideClient?

If you specificy Name or IP address (and it should not matter which unless your PCs have multiple network lnks), then you must also specify the Protocol, as these parameters make WideClient ignore the broadcasts from the Servers and those include the protocol to be used ("ProtocolPreferred").

However, it might be worth trying ServerIPAddr and Protocol parameters, rather than ServerName and Protocol, as it does save a step in Windows which might get into a state (depending on routers, usually).

1 hour ago, peterk54 said:

All computers using WideClients on the same IP ports. Do we need to change ?

It shouldn't really matter if you are specifiying the target PC fully, but it could be worth trying ot avoid and clashes.

Pete

 

Share this post


Link to post
Share on other sites

Dear Pete

Thanks for your fast reaction and advise as ever !
I will check carefully all our settings and introduce IP adresses rather names.

Yes, they should be defined to each sim.
Yes, we mean WideClients.
Cool, I do not need to check SimConnect.

As many of our hardware is running over TCP/IP with have quite some mebers in the network.

We will advise results in the next days.
Best regards
Peter

Share this post


Link to post
Share on other sites
44 minutes ago, peterk54 said:

As many of our hardware is running over TCP/IP with have quite some mebers in the network.

If it is a good reliable network try using UDP protocol for WideFS instead of TCP. It is more efficient, but has less error checking and doesn't guarantee order of frames being maintained. Just have Protocol=UDP in the WideClient.INI files instead of Protocol=TCP.

Pete

 

 

Share this post


Link to post
Share on other sites

Dear Pete

Happy X-Mas and New Year ! I know you are away from the computer until 7th January. No hurry on this matter please.

We tried Protocol=UDP and IP-Adress ratherTCP and server-names. No changes of the symptoms.
Each simulator starts and runs perfectly, if the other is not running.

But: the first of the sims starts perfectly. We start the second: on the second sims client computer we need to stop the WideClient run by Windows Autostart and manuall restart with the desktop icon. Then they runs as well.

We checked Administrator rights, programm run by administartor, Windwos compatibilty and such stuff.

No idea anymore were to search.

Best regards
Peter

Share this post


Link to post
Share on other sites
On 11/26/2018 at 7:54 AM, peterk54 said:

The second one however we need to stop and restart the Wideclients before they connect. Once done, everything seems to be perfect.

and

On 12/23/2018 at 3:08 PM, peterk54 said:

We start the second: on the second sims client computer we need to stop the WideClient run by Windows Autostart and manuall restart with the desktop icon. Then they runs as well.

Are all these WideClients running on the same PCs, or separate PCs for separate simulators?

I think you need to show me the WideClient and WideServer LOG files for the occasion where yo need to restart, and maybe after you restart, so I can see the difference. Because wideClient won't know if it's the first, second, or nth startup.

Pete

 

Share this post


Link to post
Share on other sites

Hello Pete
WideClients are all running on different PC's. 1 FSServer + 7 WideClients for one sim, 1 FSServer + 6 WideClients for another sim.

Thanks for the lead. I will write protocolls and have a look myself first.
We get all data and very fast. So once all connected everything is perfect.

I'll come back to you,
Peter

Share this post


Link to post
Share on other sites

Dear Pete

These are attached  the logfiles from the B737-222-FS Server (FSUIPC running) and of one WideClient running.
I saw nothing bad, except that WideClients try to connect with the "B737-222-FS" server rather than 192.169.x.x.

When I start all clients with WideClient, and only than P3D v4, they connect.

With best regards
Peter

B737-222-FS 20180115 FSUIPC5_prev.log

B737-222-01 20180115 WideClient.log

B737-222-FS 20180115 FSUIPC5.log

Share this post


Link to post
Share on other sites
3 hours ago, peterk54 said:

These are attached  the logfiles from the B737-222-FS Server (FSUIPC running) and of one WideClient running.
I saw nothing bad, except that WideClients try to connect with the "B737-222-FS" server rather than 192.169.x.x.

The FSUIPC log files aren't relevant.  But this part of the WideClient.log file shows that you haven't put the correct parameters into your INI file:

     141 Attempting to connect now
      141 Trying to locate server: Protocol not yet decided
      141 Failed to connect: waiting to try again
     2200 Attempting to connect now
     4259 Server = B737-222-FS


When you give the ServerName or ServerIPAddr you MUST also specify the Protocol tp be used. It does tell you this clearly in the part of the WideFS document it urges you to read.

Pete

 

Share this post


Link to post
Share on other sites

Dear Pete

See attached WideCLient.ini files from 2 different stations. We checked the others stations, I believe all are the same:

[Config]
ProtocolPreferred=UDP
BroadCastMode=Yes
//ServerName=B737-222-FS
ServerIPAddr=192.168.0.150

To my opinion they are according the document we have read
Best regards

Peter

WideClient - 02.ini

WideClient - 01.ini

Share this post


Link to post
Share on other sites
1 hour ago, peterk54 said:

To my opinion they are according the document we have read

No. ProtocolPreferred parameter is a SERVER option. You've not read the importasnt bits properly! Please read this part in the second paragraph of the "Configure your Network" section:

The Server automatically operates with any clients that connect, whether they be using TCP, UDP or SPX. You can mix them, to suit the specific individual client PCs. Better, leave the protocol choice out of the Client INI file altogether and just use ―ProtocolPreferred= …‖ in the Server INI to select your choice.

The part you should have read was this bit later on:

... However, if you find the connection is still not happening, or you have more than one Server and it is connecting to the wrong one, then you will need to add these lines to the [Config] section of the WideClient.ini file (add the [Config] section too if your ini file hasn‘t even got one!):

ServerName=NameOfServer
Protocol=TCP

Pete

 

Share this post


Link to post
Share on other sites

Hello Pete

Thanks for fast response.
Swiss German as mother-language is slightly different from English ...

Server = FS station with FSUIPC.INI, Section [WideServer], ProtocolPreferred=TCP
Clients = My stations with WideClient.INI, Section [Config], ServerName=B737-222-FS, Protocol=TCP

Thats it ? Anyway I will restudy the paper, sorry
Peter

Share this post


Link to post
Share on other sites
2 hours ago, peterk54 said:

Server = FS station with FSUIPC.INI, Section [WideServer], ProtocolPreferred=TCP
Clients = My stations with WideClient.INI, Section [Config], ServerName=B737-222-FS, Protocol=TCP

Thats it ?

Yes, though the ProtocolPreferred parameter in the server will only apply to clients which you let connect to a server automatically, not to those where the Client is fixed in its connection as in your case, as then there's no choice in the Protocol used -- the Client has already decided by the Protocol parameter..

And you can use ServerIPaddr instead of ServerName if that works better.

 

Share this post


Link to post
Share on other sites

Hello Pete
We configured according above advise from you, thank you for this support.

At the same time we are considering the following:
Both our sims are in the same SubNet. Going thru UDP specs we found:
"... The broadcast address for a LAN is either the highest address in the local subnetwork or the universal broadcast address: 255.255.255.255. ..."
To our understanding broadcast messages have no source identifier who sent the message.
Are both FSUIPC's sending to same broadcast adress ?
If so we shall divide up into two subnets each with one router, soubnet-mask would than be 255.255.0.0 rather 255.255.255.0.

Question to you: does WideServer know who sent (=IP address) broadcast messages ?
With best regards
Peter

Share this post


Link to post
Share on other sites
21 minutes ago, peterk54 said:

Both our sims are in the same SubNet. Going thru UDP specs we found:
"... The broadcast address for a LAN is either the highest address in the local subnetwork or the universal broadcast address: 255.255.255.255. ..."
To our understanding broadcast messages have no source identifier who sent the message.
Are both FSUIPC's sending to same broadcast adress ?

Using ServerName+Protocol or ServerIPAddr+Protocol parameters in each WideClient instance, the Broadcasts for Server identification, though still being sent, are not being used. Use TCP protocol and you are guaranteed correct addressing and retained order of frames, as well as error checking. Whilst UDP can be faster it really isn't significant unless there are truly large anounts of data on a less capable network.

21 minutes ago, peterk54 said:

Question to you: does WideServer know who sent (=IP address) broadcast messages ?

The clients do not "broadcast", so WideServer doesn't receive any. And using only TCP and the identication parmeters in WideClient, nothing is using broadcasts.

Pete

 

 

Share this post


Link to post
Share on other sites
2 hours ago, peterk54 said:

Question to you: does WideServer know who sent (=IP address) broadcast messages ?

Sorry, WideClients was meant.

 

2 hours ago, Pete Dowson said:

TCP and the identication parmeters in WideClient

OK, got it.

We will give the two Subnets a try as we want to remove our issues.

Peter

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.