Jump to content
The simFlight Network Forums
Stevan

CCP and some button controls not working using FSUIPC

Recommended Posts

Hi Paul,

Sorry for the delay. i believe that they are still around but contacting them is another matter.  Finding the best way to get help from them is on going process. But thank you for helping to see if CCP is rerouting the commands. If you need the FSUPC4.ini log,  I can't send it. the website won't let me upload it.

FSUIPC4.ini

FSUIPC4.JoyScan.csv

FSUIPC4.1 - Copy.log

Share this post


Link to post
Share on other sites

Hi,

That's not the correct log file. Can you try again, or find the one that's just called FSUIPC4.log.

If you can't upload it just open it in notepad and copy and paste the text directly into your reply. (You can use the <> icon on the editor menu bar to make it easier to read).

Thanks,

Paul

Share this post


Link to post
Share on other sites

Here's the FSUIPC4.log:

********* FSUIPC4, Version 4.971 (16th August 2017) by Pete Dowson *********
Windows 8.1 Pro 64 Bit reported as Build 9600 (OS 6.3)
fsx.exe version = 10.0.62615.0
Reading options from "D:\Games\Microsoft Flight Simulator X - Steam Edition\Modules\FSUIPC4.ini"
Running inside FSX Steam Edition on Windows 8.1 or later
Module base=5DB30000
User Name="Steve"
User Addr="m"
FSUIPC4 Key is provided
WIDEFS7 not user registered, or expired
        0 System time = 13/12/2018 13:11:06
        0 FLT path = "C:\Users\Steve\Documents\Flight Simulator X Files\"
        0 ------ Module Version Check ------
        0        acontain.dll: 10.0.62615.0
        0             api.dll: 10.0.62615.0
        0        controls.dll: 10.0.62615.0
        0      fs-traffic.dll: 10.0.62615.0
        0             G3D.dll: 10.0.62615.0
        0        language.dll: 10.0.62615.0
        0            sim1.dll: 10.0.62615.0
        0        visualfx.dll: 10.0.62615.0
        0         weather.dll: 10.0.62615.0
        0          window.dll: 10.0.62615.0
        0 ----------------------------------
       31 NOTE: SimConnect Steam is supported, but it isn't installed.
       62 Trying to connect to SimConnect Acc/SP2 Oct07 ...
       78 FS path = "D:\Games\Microsoft Flight Simulator X - Steam Edition\"
      359 ---------------------- Joystick Device Scan -----------------------
      359 Product= T-Rudder
      359    Manufacturer= Thrustmaster
      359    Vendor=044F, Product=B679 (Version 1.16)
      359    GUIDs returned for product: VID_044F&PID_B679:
      359       GUID= {F9916D60-DC63-11E7-8001-444553540000}
      359       Details: Btns=0, POVs=(0, 0, 0, 0), Cal=x00000000, Max=R0,U0,V0,X1023,Y1023,Z1023
      359 Product= Saitek Pro Flight X-56 Rhino Throttle
      359    Manufacturer= Mad Catz
      359    Serial Number= k0003507
      359    Vendor=0738, Product=A221 (Version 1.0)
      359    GUIDs returned for product: VID_0738&PID_A221:
      359       GUID= {104AC2B0-CFD8-11E7-8001-444553540000}
      359       Details: Btns=36, POVs=(0, 0, 0, 0), Cal=x00000000, Max=R255,U255,V255,X1023,Y1023,Z255
      359 Product= Saitek Pro Flight X-56 Rhino Stick
      359    Manufacturer= Mad Catz
      359    Serial Number= k0023297
      359    Vendor=0738, Product=2221 (Version 1.0)
      359    GUIDs returned for product: VID_0738&PID_2221:
      359       GUID= {104D33B0-CFD8-11E7-8005-444553540000}
      359       Details: Btns=17, POVs=(0, 0, 0, 0), Cal=x00000000, Max=R4095,U255,V255,X65535,Y65535,Z0
      359 -------------------------------------------------------------------
      375 Device acquired for use:
      375    Joystick ID = 2 (Registry okay)
      375    2=T-Rudder
      375    2.GUID={F9916D60-DC63-11E7-8001-444553540000}
      375 Device acquired for use:
      375    Joystick ID = 1 (Registry okay)
      375    1=X56 H.O.T.A.S. Throttle
      375    1.GUID={104AC2B0-CFD8-11E7-8001-444553540000}
      375 Device acquired for use:
      375    Joystick ID = 0 (Registry okay)
      375    0=X56 H.O.T.A.S. Stick
      375    0.GUID={104D33B0-CFD8-11E7-8005-444553540000}
      375 -------------------------------------------------------------------
      406 LogOptions=00000000 00000001
      406 -------------------------------------------------------------------
      406 ------ Setting the hooks and direct calls into the simulator ------
      406 --- CONTROLS timer memory location obtained ok
      406 --- SIM1 Frictions access gained
      406 --- FS Controls Table located ok
      406 --- Installed Mouse Macro hooks ok.
      406 --- Wind smoothing fix is fully installed
      406 --- SimConnect intercept for texts and menus option is off
      406 --- All links checked okay
      406 -------------------------------------------------------------------
      406 SimConnect_Open succeeded: waiting to check version okay
      406 Trying to use SimConnect Acc/SP2 Oct07
      406 Opened separate AI Traffic client okay
    22422 Running in "Microsoft Flight Simulator X", Version: 10.0.62615.0 (SimConnect: 10.0.62615.0)
    22422 Initialising SimConnect data requests now
    22422 FSUIPC Menu entry added
    22453 C:\Users\Steve\Documents\Flight Simulator X Files\T-33A Takeoff Deklab Preachtree Airport.FLT
    22453 D:\Games\Microsoft Flight Simulator X - Steam Edition\SimObjects\Airplanes\T-33A_fsx_2010\T-33A.air
    27812 Weather Mode now = Real World
    44390 D:\Games\Microsoft Flight Simulator X - Steam Edition\SimObjects\Airplanes\Grumman_F14D\F14D.air
    44390 c:\users\steve\documents\flight simulator x files\Carrier Takeoff.FLT
    45625 Aircraft loaded: running normally now ...
    46953 User Aircraft ID 1 supplied, now being used
    47172 Aircraft="F-14D Tomcat 163904"
    47187 System time = 13/12/2018 13:11:53, Simulator time = 09:33:01 (13:33Z)
    65953 Starting everything now ...
    67281 Advanced Weather Interface Enabled
[Log closed by user request, and continued in new file]
   121031 System time = 13/12/2018 13:13:07, Simulator time = 09:33:13 (13:33Z)
   121031 *** FSUIPC log file being closed
Minimum frame rate was 45.3 fps, Maximum was 50.7 fps
Minimum available memory recorded was 2456Mb
Average frame rate for running time of 12 secs = 40.5 fps
Maximum AI traffic for session was 20 aircraft
Memory managed: 9 Allocs, 7 Freed
********* FSUIPC Log file closed ***********

 

 

Share this post


Link to post
Share on other sites

That's the same log as you attached in your first post.

The logging options aren't enabled.

I think the best thing to do would be to delete all the .log files in the modules folder, then try again.

  • Start FSX
  • Open the FSUIPC interface
  • Enable the logging options
  • Recreate the problem with the landing gear/hud
  • Close FSX

Paul

Share this post


Link to post
Share on other sites

Hi Paul,

Thank  you for trying to help.  I finally working with the developer of CCP,  He has given me a new version and I'm testing it out. I know the issue is with the software.  Hopefully we can figure it out. Thank you for your support and have a great winter holiday season.

 

 

  • Like 1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.