Jump to content
The simFlight Network Forums

Mach number output


Recommended Posts

Hi

I have now completed my flight simulator and most of the things work really great. But there is a problem that I have found with the output values from FSUIPC.
Am using PMDG 737 NGX and when I am setting the MCP speed to a specific Mach setting most of the values work fine, but sometime FSUIPC sends an output that is 0.739999999999999 instead of 0.74, and that generates a problem on my display since it tries to set the 0.739999999999 value instead of 0.74. This is a problem for several settings on the higher values for the Mach settings. .74, .75 .76 and some more are not setting correct output value.

How to correct this problem?

Have been looking for a solution pretty long time now but need to ask about this. This is actually the only problem I have with my simulator at this point everything else works great.
Am using the Mobiflight solution for my displays and an Arduino Mega 2560 card for my 7 segment displays I use.

Anyone know what might cauise a problem here with the incorrect FSUIPC output?

Link to comment
Share on other sites

And the problem is solved.

Made a mistake in programming Mobiflight which is pretty easy to do.
In Compare I had written at first only:   ($/10.0)
and then it worked to run Mobiflight but with display error.
Now it is changed to:   Round($/10,0)
And everything works great!

Just made a test flight as well and no problems any more.
 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.