Jump to content
The simFlight Network Forums
Sign in to follow this  
airforce2

Problem with cmd line params using external program facility in FSUIPC4

Recommended Posts

Hi Pete/John;

I've been trying to get OpusFSI to run using the FSUIPC Run= facility, and I kept getting an error=2 when I tried to run it with a command line parameter per the documentation. 

The advanced user doc says: "If the program needs command-line parameters these can be included by enclosing the whole value in quotes, so that the space(s) needed don't cause problems."  It appears that guidance is in error...if the space and command line param are placed inside the quotes, it appears to be trying to use the parameter as part of the file name.

If I use:

Run1=READY,KILL,AM=XC0,"X:\OpusFSI_v5\FSISERVER.EXE" 

the program runs, but in its default (P3D) mode.  To run it in FSX:SE mode, it needs the command line parameter " STEAM" appended to the command line.  But if I try to run it with this line:

Run1=READY,KILL,AM=XC0,"X:\OpusFSI_v5\FSISERVER.EXE STEAM"

I get an unable to run line in the log with error=2, which I understand is a file not found error.  If I add the command line param after the quotes, as below, it loads as intended, in FSX:SE mode:

Run1=READY,KILL,AM=XC0,"X:\OpusFSI_v5\FSISERVER.EXE" STEAM

Cheers

Bob Scott

 

Share this post


Link to post
Share on other sites

I would hazard to guess this may work, similar to batch or lua ext.shell(path, options) -

Run1=READY,KILL,AM=XC0,"X:\OpusFSI_v5\FSISERVER.EXE" "STEAM"

Roman

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.