Jump to content
The simFlight Network Forums
dano

Prosim737 wideclient crashing when trying to connect

Recommended Posts

Hello Everyone first time posting a problem so bare with me.

Having problems with running prosim737 with wideclient on second PC.

this is what happens.

start both machines start P3D V4.5 on main machine.

start prosim737 and wideclient on client machine.

Soon as wideclient starts it says waiting for connection normal right!

Soon as i start prosim737 main program with wide client open as well it crashes prosim after a few seconds.

Try to reopen prosim and crashes again.

close wideclient and open prosim up not a problem?

Wide client then established a connection with FSUIPC on main computer.All good!

start prosim up and after the 5th time i finally get prosim to say on line with connection to main pc with wide client.

It is really a pain in the ass.

Never changed any settings over the pass 3 years but noticed it when i updated to p3d 4.5 and prosim version 2.0+.

I have the latest registered fsuipc and wideclient .

what am i missing here?

cheers in advance....

 

Share this post


Link to post
Share on other sites

Hi,

in WideClient in [Config] secrion try the setting

ButtonScanInterval=0

as ProSim uses DirectX controls for their input.

Also please provide the log files, what ever crashes will have some usefull information why and when . . .

Thomas

Share this post


Link to post
Share on other sites

Is Prosim running on the Client, or on the main sim PC?

If the latter then Prosim has a problem and your only recourse is their support forum. Not sure what you mean by ‘bare’. Rare perhaps?

Prosim v2 must be started after P3D. If you are running Prosim on the client then only start it after WideClient is connected or you will get problems, even crashes.

You can start it on the Client using RunReady in the client ini.

Pete

 

Share this post


Link to post
Share on other sites

Hi Pete 

yes prosim is on the client pc.

My main pc runs p3d only .

i have tried all plans of attack.

even when I wait for wideclient connection to p3d then start prosim I still get prosim crashing intermittently.

I have spoken to prosim about it and they say they don’t recommend prosim running on a client. Not much help I’m afraid.

I have had prosim on a client with no problems for years .

Wideclient sometimes even crashes itself when prosim.exe is launched not always but sometimes.

for some reason getting that first connection is an issue after you get everything to connect you can fly for hours.

🤔🤔🤔

Share this post


Link to post
Share on other sites
1 hour ago, Thomas Richter said:

Hi,

in WideClient in [Config] secrion try the setting

ButtonScanInterval=0

as ProSim uses DirectX controls for their input.

Also please provide the log files, what ever crashes will have some usefull information why and when . . .

Thomas

Are the log files in the modules folder Thomas?

Share this post


Link to post
Share on other sites

With ProSim v2 I would very strongly recommend you run it on the main Server PC. All other components of ProSim can be on clients, and for the displays and CDUs that is certainly best. But the v2 EXE is now so much dependent on good fast interaction with the P3D system that to have it on a client PC is robbing you of much of the benefit of moving from v1 to v2.

I also run ProsimMCP on the main PC, but that is so that it retains good aircraft control even if I, on occasion, 'cheat' and use time acceleration. It's okay on a client up to x2 but x4 and above, forget it. it loses the plot!

Pete

 

Share this post


Link to post
Share on other sites

So prosim v2  main program on main pc with p3d and all display s cdu mcp sounds ect .leave it on client .

is there anything different in settings ie. ports addresses ect I need to worry about when swapping prosim over to main p3d pc.?

or it will just connect over network?

cheers 

Share this post


Link to post
Share on other sites
2 minutes ago, dano said:

So prosim v2  main program on main pc with p3d and all display s cdu mcp sounds ect .leave it on client .

That's what I would recommend, yes. You might also want to try ProSimMCP on the main PC too -- but either way should work fine.

Make sure the Prosim EXE is started after P3D. I run it with a Run parameter in FSUIPC5's INI file, with 'READY' set too so it starts when P3D is ready to fly.  I also assign it a core afficinity mask (AM), stopping it running on core 0, which is normally the main one used by P3D.

3 minutes ago, dano said:

is there anything different in settings ie. ports addresses ect I need to worry about when swapping prosim over to main p3d pc.?

The IP address for the Server needs setting in each ProSim component's config -- if you had them all on the one PC they are probably all set to 127.0.0.1 which just means "this PC". Instead you need the IP address of your main sim PC.

Pete

 

Share this post


Link to post
Share on other sites

Right ok can you tell me how you get fsuipc to run prosim 

how is that done .

And how did you assign prosim a core besides core ‘0’ 

did you do put a Affiniy mask in p3d config to reflect what core s did what.

cheers

Share this post


Link to post
Share on other sites
31 minutes ago, dano said:

Right ok can you tell me how you get fsuipc to run prosim 

how is that done .

Check in the FSUIPC Advanced User's document in your FSUIPC Documents subfolder -- the section entittled "Programs: facilities to load and run additional programs". It is listed in the contents and starts on page 43. Best to use the reference so that you get the format and options set as you desire.

31 minutes ago, dano said:

And how did you assign prosim a core besides core ‘0’ 

The "AM=" parameter, as described in the section I just referred you to! Just assign any EVEN number -- core 0 is the odd bit. If you have HT (hyperthreading) left enabled on your PC, use any number divisible by 4 so avoiding core 0 completely including its other thread.

31 minutes ago, dano said:

did you do put a Affiniy mask in p3d config to reflect what core s did what.

No -- it is best to let P3D use whatever cores it likes.

Pete

 

Share this post


Link to post
Share on other sites

Ok I’ll have a read Pete.

So to be clear you can assign a cpu core using fsuipc for prosim to use ?

Share this post


Link to post
Share on other sites
3 minutes ago, dano said:

So to be clear you can assign a cpu core using fsuipc for prosim to use ?

Yes provided you use FSUIPC to start it. Same goes for all other programs you need for P3D. I run all these that way:

[Programs]
RunIf1=AM=x88,CLOSE,MIN,"E:\REX Sky Force 3D for Prepar3D v4\rexskyforce.exe"
RunIF2=AM=x4C,KILL,"E:\mcp\pfcmcp.exe"
RunIF3=AM=x3C,READY,CLOSE,"E:\ProSim737\prosim737.exe"
RunIF4=AM=x4C,READY,CLOSE,"E:\ProSimMCP\prosimMCP.exe"
RunIF5=AM=x48,KILL,"E:\pmsounds\pmSounds.exe"
RunIF6=AM=x24,CLOSE,"E:\ProSimAudio\ProsimAudio.exe"
RunIF7=AM=xC4,CLOSE,"C:\Program Files (x86)\HiFi\AS_P3Dv4\AS_P3Dv4.exe"
RunIF8=AM=x50,CLOSE,"C:\Program Files\AivlaSoft\EFB2\Server\AivlaSoft.Efb.Server.exe"
RunIf9=AM=xA0,READY,CLOSE,"C:\Program Files\FSPS LTD\FFTF Dynamic P3Dv4\FFTF Dynamic P3Dv4.exe"
RunIf10=AM=x48,READY,CLOSE,"E:\SimSounds\SimSounds.exe
RunIf11=CLOSE,"C:\Program Files (x86)\RivaTuner Statistics Server\RTSS.exe"


The assorted values for AM= are designed to spread the load across the 8 cores of my 9900K processor (without HT).

I use "RunIf" rather than "Run" just in case I re-reun P3D and one of those programs did not actually close from the previous session, even though i tell it to above. Where I use "KILL" instead of "CLOSE" it is because those two programs, unique to my cockpit setup, sometimes get stuck on the close down protocol with the hardware.

Pete

Share this post


Link to post
Share on other sites

Right this is all new to me so I give it a shot 

I will keep you posted

thanks Pete 

Share this post


Link to post
Share on other sites

So I noticed in some of the command lines to run a program using ‘kill ‘and ‘ready ‘on the same command line .

how does it know whether to open or close the assigned program when you have both on the same line .

if you know what I mean .

Share this post


Link to post
Share on other sites
2 minutes ago, dano said:

So I noticed in some of the command lines to run a program using ‘kill ‘and ‘ready ‘on the same command line .

how does it know whether to open or close the assigned program when you have both on the same line .

The "KILL" is like "CLOSE" and to do with what to do when P3D closes. If is different from "READY" which is to do when to start it. They are just parameters to tell FSUIPC what to do!!!

Please do read the documentation on this! Is isn't at all complicated -- much simpler in fact than ProSim and flying an airliner!

I think you should just get on with it. Neither of us should spend all day here

Pete

 

Share this post


Link to post
Share on other sites

I understand all that Pete .

my question is with this line 

RunIf1=READY,KILL,AM=82,D:\FS2002\WeatherSet.exe

you have READY and KILL on the same line .

how can you have 2 commands on the same line .

or does it act as 2 seperate commands when opening and closing P3D?

Share this post


Link to post
Share on other sites
1 hour ago, dano said:

how can you have 2 commands on the same line .

or does it act as 2 seperate commands when opening and closing P3D?

Yes! Each line is concerned with both the start and end of the specific program. I already said this! Why didn't you read what I said? I'll repeat, and with emphasis to show what you should have read!

1 hour ago, Pete Dowson said:

The "KILL" is like "CLOSE" and to do with what to do when P3D closes. If is different from "READY" which is to do when to start it. They are just parameters to tell FSUIPC what to do!!!

Also PLEASE PLEASE read the documentation section about this. It does say:

 

CLOSE closes the program tidily (if possible) when FS is terminated.
KILL forcibly terminates the program, if possible, when FS is terminated.


and

 

READY delays loading and running the program until FS is up and ready to fly

Why isn't this obvious? Is it a language problem?

Please just go and get on with it. 

Pete

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.