Jump to content
The simFlight Network Forums
regulate

Problems with FSPX AI aircraft V2

Recommended Posts

FSP has rolled out several new versions (V2) of their payware AI aircraft recently upgrading to PBR among other things for P3DV4, and once again I'm having problems with speed brakes, spoilers, flaps etc all being deployed upon taxiing for take off.   Some of the affected aircraft are the A330 series, the B777 series and the B787 series.  In the setting notebook, objects section of Super Traffic board I have all the included updates (for instance the sim aircraft column reads Boeing B772, TB aircraft column Boeing 777-200 etc).   I had this problem solved previously with the original FSP AI aircraft, but noticed it's reared it's ugly head again with the updated FSPX aircraft.   I am running version 4.2.2019.12100 of STB.   I have also tried AI Departure Flaps settings of 4, 3 and 0 to no avail within STB.   Any solutions?  Is there a box I need checked somewhere within STB that maybe I need to verify is marked? 

 

Thanks

Brian

 

 

Share this post


Link to post
Share on other sites

I'm not sure I understand the problem

1) You talk about the aircraft names in the objects section,  is that working OK?  It's quite normal to map what the AI provider calls their aircraft in the aircraft.cfg to something more consistent with other AI aircraft you may have.

2) What's the problem with the flaps settings.  You say you have tried various settings, but what exactly isn't working?  All I do is assert the flap handle settings through SimConnect, it's up to the AI aircraft whether it chooses to do something with that or not.  Most do, but some may not.

Thanks

Simon

Share this post


Link to post
Share on other sites

Attached is a screenshot of the AI FSPX B772 taxing to the runway after push back from the gate.   It remains in this configuration (reversers deployed among other visible issues) until it becomes airborne after takeoff from the runway then it works properly.   There are no issues in the air or upon landing and taxi back to the terminal, nor when the aircraft is static.   The same issue occurs with all of the FSP B772, B773, B787, A330 series aircraft that are V2.   If I run P3Dv4 without starting STB, the FSPX AI aircraft do not display this behavior.   It's only when STB is running that the FSP aircraft have the problem.   Additionally, all other aircraft (FAIB, AIA, RAI, AIM, TFS etc) do not have this problem with STB. 

 

Thanks

 

 

2019-8-25_11-39-57-608.jpg

Share this post


Link to post
Share on other sites

OK,  there's something curious about the way this aircraft is responding to SimConnect commands.  If this fails even with "flaps position 0" set in the settings notebook for the aircraft concerned, I can probably change the code not to set the flaps at all when we are configured with 0.   As it stands, we send a flaps command with whatever the configured value is.

I'll look into it.

Thanks

Simon

Share this post


Link to post
Share on other sites

Flaps handle zero should fix it.  However you've already tried that, though you don't say how.  Try setting the default value to zero:

1) Settings Notebook

2) Commands Tab

3) Default Departure Flaps Handle Setting -> 0

image.png.eff62c92dc67d354e2aabea737a0fcb0.png

4) Check you are not overriding this with a value specific to 777:

a) Objects Tab

b) Edit Aircraft radio button

c) Find any 777 entries in the list, and make sure departure flaps handle is also zero for those.

image.png.dd29ff62fc1b012fb2d10ef2fa110a99.png

5) Save Settings, restart STB

6) Observe an AI aircraft at pushback and see what happens.  It is important you start watching BEFORE TAXI.

Thanks

Simon

 

 

Share this post


Link to post
Share on other sites

Thanks Simon.   The 2nd step of changing the flaps handle to zero in the setting notebook for the specific aircraft fixed the issue.   Appreciate the support. 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.