Jump to content
The simFlight Network Forums
Sign in to follow this  
NicHer

Yoke trim switch not repeating

Recommended Posts

Dear All,

Hope you are well.

I have a problem with my home cockpit. It incorporates two yokes, both with trim switches as per the real thing. They are connected to TSR Systems (both on prority 0) on a wideclient pc "instrument 2". 

Inputs are being read by FSUIPC on the FSX "server" pc and I can successfully trim up and down without issue on both yokes.

The problem:

I cannot make either yoke's input, repeat (even though it is selected in FSUIPC) like the real trim in the real aircraft allowing for smooth trim movements by holding down the yoke switch. For example to trim down by one push on the FOs yoke moves the trim down a step at the moment.

I have studied and found that instead of using the FSUIPC dedicated options for trim dw/up you can use offsets. I have used offsets X0BCO and it increases the step size (16383 etc) but the step problem remains.

To troubleshoot I thought that the sim could be experiencing conflicts. I removed all Trim selections from FSUIPC and I confirm no FSX controls are active in the FSX GUI. However the trim still moves.  So this hypothesis seems to be correct.

In the FSUIPC file attached I see buttons that have been configured. I cannot see them in the FSUIPC GUI. So I think they have been added outside the program. Linda? LUA? I don't know. 

Could you kindly look at the file and advise what the keys translate to? ie. the name? of most importance are the trim keys - I will delete them. If you can help identify more than even better. Just to add, I know by updating these would be annotated. But I am worried updating will loose any configs and or previous programming.

If Mr. Thomas Richter is out there, I believe he did a lot of work on this sim in the past. It maybe that he in fact programmed this originally. If you could point me in the right direction as to how to make this work I would be very grateful. 

Thank you for a great program. 

KR

Nick

FSUIPC4.ini

Share this post


Link to post
Share on other sites

Hi,

as there is nothing listed in the INI file of a used or existing Lua file that means nothing is used on the FS-PC.

1. Where did you define buttons to TRIM offsets, as nothing is defined in the INI file? I put couple of defined offsets to buttons into bolt. But there is no 0BC0 offste defined in your INI fileat all.

Quote

[Buttons]
ButtonRepeat=20,10
1=R5002,0,Cx05006DB9,x01
2=U5002,0,Cx09006DB9,x01
3=R5002,1,Cx05006DB9,x02
4=U5002,1,Cx09006DB9,x02
5=R1000,5,Cx010056AE,x00
6=R1000,6,Cx010056AE,x01
7=R1000,4,Cx010056AE,x02
8=P1000,0,Cx420056AA,x0000000A
9=P1000,1,Cx320056AA,x03E8000A
10=P1000,3,Cx420056AC,x00000032
11=P1000,2,Cx320056AC,x10680032
12=R1000,28,Cx01005676,x00
13=R1000,27,Cx01005676,x01
14=R1000,25,Cx01005676,x02
15=R1000,24,Cx01005676,x03
16=R1000,31,Cx01005676,x04
17=R1000,26,Cx01005676,x05
18=R1000,29,Cx01005676,x06
19=R5002,2,Cx05006DB0,x20
20=U5002,2,Cx09006DB0,x20
21=R5001,0,Cx01007955,x00
22=R5001,1,Cx01007955,x01
23=R5001,2,Cx01007955,x02
24=R5001,3,Cx01007955,x03

Defining a button in FSUIPC to an Offset that controls something in FS if an Control already exists for that function, doesn't make sense as the offset will be translated back to the control and send to FS.

Btw - there are two (for) buttons assigned to offset 0x6DB9, they are to control ELEV TRIM via System B737 program. The 5002 in font of the definition indicates that the corresponding controller is running on a client PC, sent via WideClient. If System B737 is still in use then the corresponding checkbox for ELEV TRIM should be set. But if the controller is no longer correct recognized but the checkbox is set then it would override any other input for ELEV Trim. One or the other to use.

Quote

 I confirm no FSX controls are active in the FSX GUI.

In FSX the check for controls has to be un-checked to make sure all controller inputs are disabled.

Thomas

Share this post


Link to post
Share on other sites

Dear Thomas

Thank you, i have attached my current FSUIPC.ini it should show the offset. I tried disanbling in system 737 trim, it locked the trim so the yokes didnt work. But i dont know what the buttons for trim with the original system 737 work are. From the inforamtion above could you know what they are?

Thank you

Share this post


Link to post
Share on other sites

I mean enabling the system 737 trim function stopped all movement from the yoke trim switch, but i dont know what the "original" trim switches were configured as.

Thank you

Share this post


Link to post
Share on other sites

I disabled the buttons in the FSUIPC.ini file with // and turned off the system 737 trim funtion but still with the OBCO offset configured in FSUIPC it steps the trim, it is not smooth. 

Strange thing is, when i configure this offset for the first time sometimes it worked (total of 3 times in over 5 hours). I then restart the sim, and the old problem is back.

Thank you

Share this post


Link to post
Share on other sites

Hi,

Quote

Strange thing is, when i configure this offset for the first time sometimes it worked (total of 3 times in over 5 hours). I then restart the sim, and the old problem is back.

just make sure the changed FSUIPC4.ini file is correct saved and after restart it is still the same. Is a starter program used to start the FSX or just clicking on FSX?

Thomas

Share this post


Link to post
Share on other sites

Thank you Thomas. I managed to make it work ! Fantastic ! 

- I now am focused on the WXR SA 1.6 FSUIPC controls do you have any advice on that? 

- I also have a problem with TOGA switch on the thottles disengaging the AT.

- I am trying to connect the Fire Panel (using phidgets 0/16/16) card to FS2Phidgets to be able to control the fire panel via Project Magenta Instructor Station. Is there a more simple way to make this work? 

Many thanks 

Share this post


Link to post
Share on other sites

Hi,

Quote

- I now am focused on the WXR SA 1.6 FSUIPC controls do you have any advice on that?

Maybe someone is still using it but it should have a manual that describes usage via Offsets, if I remember correct.

 

Quote

- I also have a problem with TOGA switch on the thottles disengaging the AT.

If you use Project Magenta software please check their documentation, again the usage of their specific Offsets to control will be described. I don't think FS standard controls would work correct.

 

Quote

- I am trying to connect the Fire Panel (using phidgets 0/16/16) card to FS2Phidgets to be able to control the fire panel via Project Magenta Instructor Station. Is there a more simple way to make this work? 

I have no idea how that would work by using FS2Phidgets (I never used).

If the fire panel is connected, at the time in 2014, to INST-3 PC then the System_B737 software min. version 2.1.153.3 had that hard-coded when the following line exists in Phidgets.xml file in cards section:

Card13="330989"

The number is the Phidgets ser/ID number.

Nothing more I can do.

Thomas

Share this post


Link to post
Share on other sites

Hello Thomas

Thank you for your reply.

Regarding the fire panel, INST 3 is not in the simulátor anymore. It didnt come with it. 

INST 2 contains systém 737  and the phidgets card 0-16-16 is connected there. Funny thing is i found card 1 to hold the 330989 but i do not think its correct as the fire panel does not light or work ať all. 

How can i work out what card Number to label 330989 in the phidgets folder within the systém 737 please. Is there anything else you think could stop it working. It is great if i do not need to use FS2P even though it is nice software.

Thank you

Share this post


Link to post
Share on other sites

In addition, do you know what the offset is for the Lower Eicas to display when i press the MIP ENG and SYS buttons. I háve tried all the combinations in the PM manuál, but i think becuase i am using your TSR EICAS software the lower display uses something different. Could it bé that i need to puť a keypress in the wideclient sw. 

Right now when i open the lower ecias display the instruments are shown for 1 second then hide. I háve APU power. Thank you 

Share this post


Link to post
Share on other sites

Hi,

just use for upper and lower EICAS the PM software as you do for PFD/ND.

For the fire panel I think that it was clear enough.

Quote

If the fire panel is connected, at the time in 2014, to INST-3 PC then the System_B737 software min. version 2.1.153.3 had that hard-coded when the following line exists in Phidgets.xml file in cards section:

Card13="330989"

The number is the Phidgets ser/ID number.

The System B737 software has to be minimum version 2.1.153.3 or above (2.1.153.>3)

The location to have the card number 330989 is in Phidgets.xml file, located in Systems_B737\Config\ folder within this section ( I don't recall the other card functions)

  <Cards
    Card1="0"
    Card2="0"
    Card3="0"
    Card4="0"
    Card5="0"
    Card6="0"
    Card7="0"
    Card8="0"
    Card9="275566"
    Card10="131519"
    Card11="0"
    Card12="0"
    Card13="330989"
    Card14="0"
    Card15="0" />

 

Thomas

Share this post


Link to post
Share on other sites

Hi Thomas,

I have set the phidgets ini as you suggest - attached.

However the fire panel does not light or respond. I do not understand what information I need to put into the ini for the fire panel to respond to starting a fire in PM instructor station. The gauges in the ini work well. 

Thank you for any guidance you can provide.

KR

 

Phidgets.ini

Share this post


Link to post
Share on other sites

Just to add, the APU discharge light comes on, when I connect the Phidget card to card 7 so I think it is the right one. All others cause a problem on startup where TSR system doesn't like it.

Thank you 

Share this post


Link to post
Share on other sites

Hi,

as I said the position Card13 is hard-coded for that function, as well the layout /conection of the card is.

Quote

The System B737 software has to be minimum version 2.1.153.3 or above (2.1.153.>3)

Thomas

Share this post


Link to post
Share on other sites

Dear Thomas

I see the problem. I am using version 2.1.152.206

Is there anyway you would be kind enough to share the updated version with me?

Thank you for your help.

Best Wishes,

Nick

Share this post


Link to post
Share on other sites

Hi,

I don't have any download area to store and most email providers block attached files, special EXE or DLL files even when renamed. I can try if you send an email address that could work.

Thomas

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
Sign in to follow this  

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.