Jump to content
The simFlight Network Forums
eke_flx

problem - SLC and ACARS_lost connection with Fsuipc ??

Recommended Posts

Hi

i use Prepar 3D4.5.12.30293 and FSUIPC5, Version 5.152 registered  (Windows 7 Ultimate 64 ). Because i have many many addon scenerys and addons tools (GSX2,Chaseplane, Active Sky, Mytraffic and so on..) my simulator on a  flight  from time to time  "freeze" from a few seconds to 60 seconds, when loading Scenery, texture or weather. But that's not a big problem,  the problem is that  i can't use  such additional programs which require in-flight logging/connect with simulator, as SLC  (Self Loading Cargo), ACARS or some Cabin Crew sound program.AT this time, when simulator freezes this programs  loses connection with simulator and it will not recover on this flight .

SLC is not communicating directly with  simulator, it talks to FSUIPC which runs within the simulator. Perhaps it is FSUIPC crashing? SLC does try to reconnect automatically, so if it cannot then it suggests that FSUIPC is either no longer running, or blocking the connection so SLC cannot get data any more.

Could it be FSUIPC problem and how fix that? Otherwise I will use in FSUIPC only traffic limiter and autosave function, all others FSUIPC settings are default.

Please help!

 

regards!

Felix

 

FSUIPC5.log

Share this post


Link to post
Share on other sites

Hi,

why is the head of the Log file cutout, it contains important information? So please send a complete and not modified Log file.

As seen in the Log file you use Autosave option, i.e with PMDG or other add-on AC's which might save lots of state data you shouldn't use Autosave option as it can lead to such problems you have. FSUIPC has no control over the amount or which data will be saved, that is entirely up to P3D and the corresponding AC/ add-on Ac is used.

Thomas

Share this post


Link to post
Share on other sites

Hi

Thank you for the answer!  

I'll remove from FSUIPC Autosave function and then make new flight.  Which I should mark in FSUIPC logging options? Now I have  selected Events (non axis control) and Extras (Miscellany). What is important data  for a problem like this ?

Maybe i also need   change some settings in Fsuipc?

 

regards

 

Felix

 

Share this post


Link to post
Share on other sites

Hi

I did a test flight with a very simple plane ( ESSV-EKCH) with constant weather (no AS live as I usually use ), FSUIPC Autosave OFF.  Running Self Loading Cargo but again in the descent phase SLC loses contact with simulator.  Is that normal when simulator freezes  for a few seconds, then  communication disappears with other log programs? Does FSUIPC have any settings that should be changed?

I put FSUIPC log file here.

 

regards

 

Felix

FSUIPC5.log

Share this post


Link to post
Share on other sites
14 hours ago, eke_flx said:

Which I should mark in FSUIPC logging options? Now I have  selected Events (non axis control) and Extras (Miscellany). What is important data  for a problem like this ?

Well, you shouldn't be checking any log options at all really. Why are you? Thomas only asked that you showed the whole log, not a partial one.

However, that said, I am not sure what you are doing with your buttons or on the screen because the Event logging shows many fast repeating controls. Are these to do with your controlling of your flight? there seems a rather excessive number of repeats each time.

At this point:

  3498042 *** EVENT: Cntrl= 65584 (0x00010030), Param= 0 (0x00000000) BAROMETRIC
  3536168 **** Restarting traffic scanning due to non-reception ****
  3540334 *** EVENT: Cntrl= 65584 (0x00010030), Param= 0 (0x00000000) BAROMETRIC
  
there was a pause long enough to cause FSUIPC to restart its traffic scanning.  Looks like reception from Simconnect was stopped for 38 seconds! That's certainly long enough to cause any Simconnect-using applications to decide things had gone wrong.

The sheer nuber of consecutive "PAN VIEW" events being sent by something is astonishing. Surely that cannot be you using a hat?

Here you seem to be using another program which takes focus from P3D and may be causing other delays:

  5464902 Deactivated: culprit unknown
  5464902 Focus lost: culprit unknown
  5847604 *** EVENT: Cntrl= 65584 (0x00010030), Param= 0 (0x00000000) BAROMETRIC
  5935901 *** EVENT: Cntrl= 65584 (0x00010030), Param= 0 (0x00000000) BAROMETRIC
  5978317 Deactivated: culprit unknown
  5978317 Focus lost: culprit unknown
  6015836 *** EVENT: Cntrl= 66856 (0x00010528), Param= 1 (0x00000001) VIEW_CAMERA_SELECT_6
  6050702 *** EVENT: Cntrl= 65584 (0x00010030), Param= 0 (0x00000000) BAROMETRIC
  6051934 *** EVENT: Cntrl= 66851 (0x00010523), Param= 1 (0x00000001) VIEW_CAMERA_SELECT_1
  6056053 Deactivated: culprit unknown
  6056053 Focus lost: culprit unknown
  6258698 *** EVENT: Cntrl= 65584 (0x00010030), Param= 0 (0x00000000) BAROMETRIC
  6264938 Deactivated: culprit unknown
  6264938 Focus lost: culprit unknown

and  later this occurs again and is bad enough to cause a break in reception from Simconnect:

  6858288 Deactivated: culprit unknown
  6858288 Focus lost: culprit unknown
  6896056 **** Restarting traffic scanning due to non-reception ****
  6898864 Deactivated: culprit unknown
  6898864 Focus lost: culprit unknown
  7048937 **** Restarting traffic scanning due to non-reception ****
  7051651 Deactivated: culprit unknown
  7051651 Focus lost: culprit unknown
  7100230 *** EVENT: Cntrl= 65564 (0x0001001c), Param= 0 (0x00000000) ATC
  7103428 Deactivated: culprit unknown
  7103428 Focus lost: culprit unknown

Yet another long pause here:

  7160259 *** EVENT: Cntrl= 65880 (0x00010158), Param= 0 (0x00000000) HEADING_BUG_DEC
  7182364 **** Restarting traffic scanning due to non-reception ****
  7358911 *** EVENT: Cntrl= 66416 (0x00010370), Param= 270 (0x0000010e) PAN_VIEW
and again:

  7689087 *** EVENT: Cntrl= 65879 (0x00010157), Param= 0 (0x00000000) HEADING_BUG_INC
  7689430 **** Restarting traffic scanning due to non-reception ****
  7690974 *** EVENT: Cntrl= 65879 (0x00010157), Param= 0 (0x00000000) HEADING_BUG_INC

and

  7896365 *** EVENT: Cntrl= 65758 (0x000100de), Param= 0 (0x00000000) FLAPS_INCR
  7927472 **** Restarting traffic scanning due to non-reception ****
  7930592 *** EVENT: Cntrl= 65758 (0x000100de), Param= 0 (0x00000000) FLAPS_INCR

And on and on go the PAN View events. What could possibly be doing that?

I don't know where in all this your  "SLC" program lost contact, but I'd be very surprised if you didn't notice the pauses and/or jerks all these interventions mustsurely  have caused.

I think you might need to use a process of elimination on your add-ons to see which is responsible for each of these oddities. Check also you haven't got a button on a control which is permanently sending events, as those are very odd.

Then you can turn off the Log options you've enabled.

Pete

 

 

 

 

Share this post


Link to post
Share on other sites
7 hours ago, eke_flx said:

Now I know  that can't fix it  and the situation has to be accepted .

Well, I wouldn't accept it myself. i'd be trying to eliminate every add-on, one by one, till I nailed it.

Pete

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.