Jump to content
The simFlight Network Forums

Tower3D Multi Screen Issue


Recommended Posts

Hey guys,

I am hoping that someone might be able to help me.

I use to play Tower3D with 3 screens but one is now defunct and can't be used.  While playing with 3 screens i had my strips on a separate screen. Tried playing recently and when i open the window to have my strips on my second screen it comes up on the task bar but i can't see it anywhere. Cant even see it when i click on the strips in the taskbar.

Is there a way i can reset these views so that they go back to the default position and then i can move them to my second screen?

Thanks for the help

Link to comment
Share on other sites


i have just tried your suggestion and it hasn't worked.

when i mouse over the strips it's showing up blank. when i follow the video when i press an arrow key and move my mouse the window comes into view, however it appears to be minimized and when i left click it disappears again.

I then go through the process of clicking the strips icon again and then changing it to multi screen view and it does the same thing again.

and i start the process again but the same thing happens.  I even tried maximize but as soon as i click that the window disappears again. Restore function is not available through this method either.

It's acting like something is blocking it, however the DBRITE and ADRIS are both working fine.

Link to comment
Share on other sites

12 hours ago, mechajames said:

Just managed to fix it by snapping the ADRIS to the right hand side of the window and then selecting the strips as the second portion of that screen from the snap option. then just had to resize the window so that i could see what was on the strips.

I'm sorry my methodology didn't help, but I'm glad you were able to find another solution.

I've never had this problem with Tower3D Pro, but I have and the problem with other programs, and my methodology always worked for me. Tower3D Pro must create windows in a non-standard way when in full screen mode that render's the method I described ineffective.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.