Jump to content
The simFlight Network Forums

Terrible FPS, impossible to Fly

Riky FSX

Recommended Posts

Hello everyone,

I have terrible FPS (20-22) in the new Embraer v3 (all variants), especially in addon airports. I followed all the post in the forum but nothing helped. I also have a powerful system with rtx 2080 super and i7-8700k. 

I did:

- Disable Antivirus

- Adjust the gauge fps in the menu.

- Run the setup in W7 compatibility mode.

- Low the settings to the minimum of AA and graphic section.

- Disable joystick as i've read that people have problems with the input.

- Night and Day it is the same

- Chaseplane disable

Unfortunately nothing helped and in this condition it is impossible to fly with. Any tips?




settings 2.JPG


Link to comment
Share on other sites

What shaders add-ons are you using?  Adjust and disable for testing.

Do have chaseplane running?

You have a software/hardware issue causing conflict so.some searching wl be required.

(As a side note you have created a new thread on a existing topic. This results in reduced support across multiple threads. Be really great if you would add this to an already existing one so mods can focus on one thread on this issue.)

Link to comment
Share on other sites


Sorry i did not see the other post.

As i stated i have chaseplane, i try to disable it but nothing changed.

I don't have shaders add-ons as tomato or PTA.  I don't have any fps problem with other addon as FSLABS or PMDG.

I try everything you stated in other post, but nothinhg seems to work so far.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.