Jump to content
The simFlight Network Forums

Problem with FSUIPC 4.974 FSX-SE since 1 May 20

Recommended Posts

I acknowledge this is legacy stuff, but I'm still running FSX-SE on my 9 year old device.

All was working fine until yesterday 1/5/20. Now, when I start up FSX-SE, I get a warning message that there's an error with FSUIPC 4.974.

If I go ahead and load regardless, I get crash to desktop. Not every time, but most of the time. If I don't load the module, FSX-SE works OK (but without the various connecting programmes).

No installation changes, it just seemed to be the first of May!

Link to comment
Share on other sites

3 hours ago, AndrewWebb said:

All was working fine until yesterday 1/5/20. Now, when I start up FSX-SE, I get a warning message that there's an error with FSUIPC 4.974.

Well, something's obviously happened on your PC, because FSUIPC 4.974 certainly hasn't changed.

One of the possibilities is that either some previous crash you had corrupted a weather file, or an add-on has done so.  Please see this thread in the FAQ subforum:

If that doesn't help you need to show the FSUIPC4.LOG, up to the posint of the crash (if one is generated), and the Windows Event Viewer details showing the details of the crash (Event Viewer -- Windows Logs - Application.



Link to comment
Share on other sites

  • 1 month later...

Hello, sorry to jump in this thread. I've run FSX flawlessly for years but it all started to crash yesterday. I was doing a normal 3 hours flight but there's power blackout in my area and my PC got shut down instantly, tried running FSX again but it crashed just 1 second after it fully loaded. tried to deleted FSUIPC and it works fine, somehow got the same problem again after reinstalling.  already tried to delete wxstationlist, logbook.bin, no success.

Here's my log files 

FSVersionUsed="Microsoft Flight Simulator X",10.0.61472.0


and here's the DLL.XML :

<?xml version="1.0" encoding="Windows-1252"?>

<SimBase.Document Type="Launch" version="1,0">
    <Name>VistaMare Core</Name>
    <Name>FSUIPC 4</Name>

Also there's no error messages in event viewer, and it just crashes without any message


Link to comment
Share on other sites

Sorry, here's the log file :

********* FSUIPC4, Version 4.975a (19th May 2020) by Pete Dowson *********
Windows 10 Enterprise 64 Bit reported as Build 18363, Release ID: 1909 (OS 10.0)
fsx.exe version = 10.0.61472.0
Reading options from "F:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\Modules\FSUIPC4.ini"
Running inside FSX on Windows 10
Module base=63340000
User Name=""
User Addr=""
FSUIPC4 not user registered
WIDEFS7 not user registered, or expired
       15 System time = 11/06/2020 16:14:05
       15 FLT path = "D:\Users\Antok\Documents\Flight Simulator X Files\"
       15 NOTE: configuring for no weather reads or writes!
       15 ------ Module Version Check ------
       15        acontain.dll: 10.0.61472.0
       15             api.dll: 10.0.61472.0
       15        controls.dll: 10.0.61472.0
       15      fs-traffic.dll: 10.0.61472.0
       15             G3D.dll: 10.0.61472.0
       15        language.dll: 10.0.61472.0
       15            sim1.dll: 10.0.61472.0
       15        visualfx.dll: 10.0.61472.0
       15          window.dll: 10.0.61472.0
       15 ----------------------------------
       78 Trying to connect to SimConnect 10.0.61242.0 ...
       78     ... Okay! Connected!
      156 FS path = "F:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\"
      187 LogOptions=00000000 00000001
      187 -------------------------------------------------------------------
      187 ------ Setting the hooks and direct calls into the simulator ------
      187 --- CONTROLS timer memory location obtained ok
      187 --- SIM1 Frictions access gained
      187 --- FS Controls Table located ok
      187 --- Installed Mouse Macro hooks ok.
      187 --- Wind smoothing fix is not installed
      187 --- G3D.DLL fix attempt installed ok
      187 --- SimConnect intercept for texts and menus option is off
      187 --- All links okay (with no weather related ones)
      187 -------------------------------------------------------------------
      187 SimConnect_Open succeeded: waiting to check version okay
      203 Opened separate AI Traffic client okay
     2046 Running in "Microsoft Flight Simulator X", Version: 10.0.61472.0 (SimConnect: 10.0.61259.0)
     2046 Initialising SimConnect data requests now
     2046 FSUIPC Menu entry added
     2187 F:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\FLIGHTS\OTHER\FLTSIM.FLT
     2187 F:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X\SimObjects\Airplanes\Aircreation_582SL\Aircreation_582SL.AIR
    44734 User Aircraft ID 1 supplied, now being used
    45390 System time = 11/06/2020 16:14:50, Simulator time = 16:14:08 (23:14Z)
    45406 === DLLStop called ...
    45406 === Closing external processes we started ...
    46421 === About to kill any Lua plug-ins still running ...
    47562 === About to kill my timers ...
    47562 === Restoring window procs ...
    47562 === Unloading libraries ...
    47562 === stopping other threads ...
    47562 === ... Memory checking ...
    47562 === ... Button scanning ...
    47671 === ... Axis scanning ...
    47765 === Releasing joystick devices ...
    47765 === Freeing macro memory
    47765 === Removing any offset overrides
    47765 === Clearing any displays left
    47765 === NOTE: not calling SimConnect_Close ...
    47765 === AI slots deleted!
    47765 === Freeing button memory ...
    47765 === Closing my Windows ...
    47765 === Freeing FS libraries ...
    48765 === Closing devices ...
    48765 === Closing the Log ... Bye Bye! ...
    48765 System time = 11/06/2020 16:14:54, Simulator time = 16:14:08 (23:14Z)
    48765 *** FSUIPC log file being closed
Minimum frame rate was 32768.0 fps, Maximum was 0.0 fps
Minimum available memory recorded was 32768Mb
Average frame rate for running time of 1 sec = 51.6 fps
G3D fix: Passes 7224, Null pointers 0, Bad pointers 0, Separate instances 0
Maximum AI traffic for session was 0 aircraft
Memory managed: 4 Allocs, 4 Freed
********* FSUIPC Log file closed ***********


Tried adding "NoWeatherAtAll=Yes" No luck

Link to comment
Share on other sites

The log file shows a normal termination.  FSX didn't crash but terminated gracefully.

You need to explain exactly what happened, what you saw. I suspect your PC crash has caused some corruption somewhere which is preventing FSX working properly -- at least in the SimConnect interface if not also other places. I would strongly recommend a reinstall of FSX.



Link to comment
Share on other sites

Everything goes very well except it will CTD few seconds after loading, I was suprised too as i never experienced this after years of simming. maybe it's caused by the instant shut down of my PC during the flight yesterday and some files were corrupted.

Anyway thanks for the quick response Pete, i'll start backing up my files before reinstalling then 


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.