Jump to content
The simFlight Network Forums

Recommended Posts

Hello,

I just reinstalled Windows and when I went to install FSUIPC6 today, I received a "installer corrupted: invalid opcode" error. So far both downloads from Simmarket and here on the website have given that error. I saw another post about this but unfortunately that didn't help me. FSUIPC5 installs fine, but 6 is not working.

Edited by sho69607

Share this post


Link to post
Share on other sites

same here,  brandnew, just W10, absolute clean install (windows 10)   and not even possible to run the installer.....

Did buy just another piece of sh*t?   

I`m just keeping doing this, buy new prepar 5 does not work (airports are totaly messed up) , buy Saitek panels, don`t work....

Buy new PC just for flying; does not work; at all.......

cannot even send you the screensnip  of the error ........  (0.02MB are you ???)

Edited by frankploegmakers
angry person

Share this post


Link to post
Share on other sites

Hi,

make sure you don't run the installer in a folder that is within a secured windows folder like "Program Files" or "Program Files (x86)"

Thomas

Share this post


Link to post
Share on other sites
14 hours ago, sho69607 said:

I saw another post about this

Then why didn't you post there instead of starting a new thread for exactly the same problem?

As well as what Thomas has said, make sure that you have unzipped the downloaded package and are not trying to run the installer directly from the zip file.

You can also try running the installer as an administrator, as it looks like this error can be caused by incorrectly set permissions on your account.

Share this post


Link to post
Share on other sites

Good morning. I resume the topic as indicated by Jon, but I too, as for the first report, have the same problem after the acquisition. I reinstalled Windows, I unzipped the zip file, managed as administrator, but nothing always the same error "damaged installer: invalid operating code". At the moment I have P3D v4 and I purchased FSUIPC6 in the forecast of P3Dv5 since the indications are that they are programmed for both. I gave up and reinstalled the previous version. How can I overcome this problem? I thank and greet Pierluigi

Edited by Pircal

Share this post


Link to post
Share on other sites

Hi Pierluigi,

I currently have no idea what is causing this for a few people. It has been downloaded and used many thousands of times without issues, so this issue must be specific to certain set-ups. And people are providing little information for me to investigate.

Could you let me know the following please:
   - when do you actually get the error - is it produced as soon as you run the installer exe?
   - what windows version/patch level are you using?
   - could you provide a screenshot of the properties of the Install_FSUIPC6.exe file please - and make sure you are using the latest version (6.0.8)

Thanks,

John

Share this post


Link to post
Share on other sites

Thanks John.

As requested by you:

- Once the installer has been started as an administrator, accepted the license via the I Agree button, the program highlights the components that will be installed then I press the Next button and the path where the program will be installed is highlighted (C: \ Users \ xxxxx \ Documents \ Prepar3D v5 Add-ons \ FSUIPC6) I press the Install button and the progressive installation bar appears and towards the end it shows the error indicated in the attached screen. Going to the Documents folder the program has installed two folders one FSUIPC6 which contains pdf files and the other Prepar3D v5 Add-ons which contains two other folders and an unistaller and a ddl file. See attached screens.

The Windows version is W10 PRO version 1909

I confirm that the version of FSUIPC is 6.0.8 because there is a txt file where it is present (Changes in FSUIPCv6.0.8: - updated for compatibility with Active Sky for P3Dv5) and the program has also been downloaded from the site http: // www.fsuipc.com/

What do you need from the indicated file properties?

Hello and thanks

FSUIPC.gif

FSUPC6.gif

Share this post


Link to post
Share on other sites

Ok, thanks. So the installer IS running, but it's failing with that message towards the end of the installation process (and before registration).

15 hours ago, Pircal said:

What do you need from the indicated file properties?

I just wanted to check the size of the installer exe, to verify it is the same as expected. Not needed now though  as the installer runs.

What happens when you click the 'Ok' - does the installer just exit?

Can you see if the installer has generated a log file in the same folder as where you ran the installer - if so, can you please attach. If not, and the installer is still running after the invalid opcode message, you could click the 'Show details' button and copy the contents and paste them here for me to see.

It looks like the installer is failing to create the add-on.xml for some reason. Could you also try installing via the dll.xml method instead please - just un-tick the 'add-on.xml'  checkbox in the components selection during installation. You can also try running the uninstaller that has been created first.

Share this post


Link to post
Share on other sites

Hi Giovanni

Yes, the error message is displayed towards the middle of the installation but the green progressive bar continues up to the point where it is indicated in the screen sent. Very little is missing for completion.

Once OK is selected, the program does not complete and closes on its own if you press the Cancel button. In the two generated folders, there is no log file with the extension * .log.

Deselecting the "add-on.xml" component the problem is identical while FSUIPC5 installs correctly.

When starting the uninstaller, compare a mask with the path indicated Uninstalling from: 😄 \ Users \ Pircal \ Documents \ Prepar3D v5 Add-ons \ FSUIPC6 \ and pressing the key compares the message "FSUIPC v6.0.8 has been successfully removed from your computer "but it also generates a txt file containing" Determine which version to uninstall ...
***** Unable to determine which version of P3D to uninstall FSUIPC ****** "

I attach screenshots of what is requested.

I thank and greet Pierluigi

Share this post


Link to post
Share on other sites
7 minutes ago, Pircal said:

Once OK is selected, the program does not complete and closes on its own if you press the Cancel button

Can you press the 'Next' button, or is that inactive? If its active, please try that.

Quote

In the two generated folders, there is no log file with the extension * .log.

The installation .log file will be in the same folder as the installer - it is only copied to the installation folder at the end of (successful) installation. Could you check to see if you have a .log file there and if so please show it to me.

8 minutes ago, Pircal said:

Deselecting the "add-on.xml" component the problem is identical while FSUIPC5 installs correctly.

So you still get the pop-up 'Invalid opcode' message, but you can complete the installation? Do you have an installation log for this - if so, please post it.

So FSUIPC is actually installed and running via this method?

10 minutes ago, Pircal said:

"but it also generates a txt file containing" Determine which version to uninstall ...
***** Unable to determine which version of P3D to uninstall FSUIPC ****** "

That message is most probably because the installer didn't complete and didn't write the reg keys expected by the uninstaller. It would also be helpful if you attached the full uninstall log, so I can check this.

Do you have any anti-virus software running (besides Windows Defender)? If so, maybe also try with this de-activated.

Thanks PierLuigi,

John

Share this post


Link to post
Share on other sites

Maybe you could also try only installing the dll (i.e. uncheck the other sections - 'Documentation' and 'Extras'). I need to narrow it down to determine which install section is generating that error. If that works ok, you can then add the others back in, one at a time, to determine which install section is generating that error.

Thanks,

John

 

Share this post


Link to post
Share on other sites

As far as you highlight, I answer by point:

- Once the error message is shown, the only active button is Cancel

- No log file is present otherwise I would have already sent it to you but have you read the doc file where I entered the Details screens? otherwise I send it back.

- When deselecting the "add-on.xml" component, the problem is identical, ie it does not install anything new or different. Once the error message appears, the only key that is active is Cancel. To check if there was any problem with my system I tried to install the previous version of FSUIPC6 or FSUIPC5, which uses the old installation method by generating the Modules folder in P3D and everything is regular.

- No uninstall log.

- The only antivirus running is that of Windows defender which I have disabled but the problem persists.

And sorry for my not perfect english.

Thanks

Share this post


Link to post
Share on other sites

John the application does not load me the video file to be sent but the dice -  YOU CAN ONLY UPLOAD A TOTAL OF 0MB – PLEASE CONTACT US  FOR ASSISTANCE

Can you tell me another way to send you the files?

Thanks

Share this post


Link to post
Share on other sites
1 hour ago, Pircal said:

John the application does not load me the video file to be sent but the dice -  YOU CAN ONLY UPLOAD A TOTAL OF 0MB – PLEASE CONTACT US  FOR ASSISTANCE

Can you tell me another way to send you the files?

Thanks

My suggestion is upload the file using Dropbox or Google Drive and post the link here

Share this post


Link to post
Share on other sites

Pierluigi,

thanks for the pictures, but what I really need is the log. Next time, if the log file isn't produced, can you copy the log text that is displayed when you click the 'Details' button, and paste that for me.

But the picture of the small section of the log shows what you issue is: the installer can't determine where your P3D installation is from the registry (or if it is installed at all). I will look into handling this better - the installer should really have aborted (nicely!) and not installed anything, as it cannot find either P3Dv4 or P3Dv5 on your system. This is also why its defaulting to a P3Dv5 folder for your installation.

What version of P3Dv4 to you have installed? I've not installed the latest v4.5 HF, maybe they've changed the registry keys used.
 

Share this post


Link to post
Share on other sites

I have corrected the problem in the installer. It will now show a message an exit if it cannot determine where either P3Dv4 or P3Dv5 is installed.

However, this will not help you that much as you still won't be able to install FSUIPC6. I need to determine why you don't have the P3D registry keys installed. Could you try re-installing the P3D Client, then download and try the latest installer for FSUIPCv6.0.8 \9installer version 1.2.2)

I am going to install the latest 4.5 HF to see if there is an issue there.

Thanks,

John

Share this post


Link to post
Share on other sites

Hello John.
As previously communicated, the log file is not generated. In the ZIP file, called screenshot_FSUIPC6, there is the log that is displayed when you press the "Details" button. However I have launched the installation again and I am attaching the registry screeschots and inserting them in the DOC file mentioned in the link:
https://drive.google.com/file/d/1Uwn7XQr2_m_BM7DqgeestFk6n3i_NiZU/view?usp=sharing

My current version is Prepar3D_v4_Accademic_4.5.14.34698

Share this post


Link to post
Share on other sites

I've just added a check for a second reg key if the first can't be found, in installer 1.2.3. Can you please download again and try that one.

 

Share this post


Link to post
Share on other sites
10 minutes ago, Pircal said:

As previously communicated, the log file is not generated. In the ZIP file, called screenshot_FSUIPC6, there is the log that is displayed when you press the "Details" button.

I know this. I am asking you to copy the text from the Details window and paste that for me to see (so I can see the whole text) rather than taking a screen-shot. However, this is now redundant as I know what the problem is.

Share this post


Link to post
Share on other sites

Sorry John but I don't know how to copy the text from the Details window, so the only way is to take screenshots.
I downloaded the new version from the site but as soon as I start the installer, an error message "Cannot find P3Dv4 or P3Dv5 installation ans so cannot install" appears.


My P3Dv4 is installed on a harddisk other than 😄 even if it is present on "C: \ ProgramData \ Lockheed Martin \ Prepar3D v4" and on "C: \ Users \ Pircal \ AppData \ Roaming \ Lockheed Martin \ Prepar3D v4".

Share this post


Link to post
Share on other sites

What version of the installer did you try (check first line in Details output)?

For installer v1.2.2 this is what I expected. If you get that with v1.2.3, then there are no reg keys I can use to determine the location. Did you try re-installing the client?

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.