Jump to content
The simFlight Network Forums
l3ubba

Multiple Axis Assignments

Recommended Posts

I am currently running FSUIPC6 with P3Dv4, my current setup is a PFC Yoke and throttle quadrant, but unfortunately I don't have rudder pedals yet (hopefully this year). Typically I use autorudder to taxi around since I don't have anything better to use, but when I started flying the FS Labs Airbus I got a message saying autorudder should be disabled or the aircraft won't fly properly. I played around with some settings in FSUIPC and noticed I could assign an axis to Steering Tiller. I decided to assign the X Axis of my yoke to both ailerons and the steering tiller and while this works without a problem on the ground as soon as I get in the air I noticed the steering tiller assignment is also tied to the rudder pedals so when I get in the air and start turning to the left with the ailerons it also puts in left rudder. I have tried using a few other options to control the tiller that aren't on the yoke, but the second issue is I have the buttons on the back of my yoke assigned to my left and right brakes so I would have to move my hands back and forth to control the tiller and the brakes.

This all being said, my question is: is possible to either disable the steering tiller axis from also controlling the rudder pedals or if not, is it possible to only have the steering tiller assignment kick in when I'm on the ground or below a certain speed?

Share this post


Link to post
Share on other sites

Have you assigned to the FSUIPC control SteeringTiller? If so, try the FS control Steering Set (or Axis Steering Set) instead.

 

 

Share this post


Link to post
Share on other sites
5 hours ago, John Dowson said:

Have you assigned to the FSUIPC control SteeringTiller? If so, try the FS control Steering Set (or Axis Steering Set) instead.

 

 

Yes, I have my FSUIPC axis to send direct to FSUIPC calibration and the X Axis is tied to both my ailerons and Steering Tiller. Unfortunately I cannot use FS Controls because if I enable controllers through P3D I have an issue where the brakes on my aircraft are stuck on and won't release so in the control options I have disabled controllers and that seems to be the only way I can fix it.

Share this post


Link to post
Share on other sites

I mean you should choose 'Send to FS as normal axis' in FSUIPC instead of 'Send direct to FSUIPC calibration'. The controls when this is selected are the standard P3D ones, not the "special" ones added by FSUIPC. You do not need to able controllers in P3D for this. Probably also a good idea to delete/remove any calibration entries for the tiller when you do this (by editing the ini).

So, as I previously said, try selecting 'Send to FS as normal axis' and then select the Steering Set or Axis Steering Set control from there. This should then use the standard P3D control with no rudder/tiller blending.

Share this post


Link to post
Share on other sites
8 hours ago, John Dowson said:

I mean you should choose 'Send to FS as normal axis' in FSUIPC instead of 'Send direct to FSUIPC calibration'. The controls when this is selected are the standard P3D ones, not the "special" ones added by FSUIPC. You do not need to able controllers in P3D for this. Probably also a good idea to delete/remove any calibration entries for the tiller when you do this (by editing the ini).

So, as I previously said, try selecting 'Send to FS as normal axis' and then select the Steering Set or Axis Steering Set control from there. This should then use the standard P3D control with no rudder/tiller blending.

Just gave that a try and it didn't seem to work. Ailerons work fine, but the aircraft doesn't steer at all.

Share this post


Link to post
Share on other sites
On 6/19/2020 at 4:07 AM, John Dowson said:

Do you have the rudder pedals off in the MCDU options menu? See this post over on the FSL forum:
https://forums.flightsimlabs.com/index.php?/topic/7942-setting-up-the-tiller-using-fsuipc-registered/

 

I've been testing it in the PMDG NGXu and that seemed to do the trick. However when I swtiched the elvavtor to send to FS as normal axis it didn't work, so I've left that on send direct to FSUIPC calibration and the ailerons and steering set are normal.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.