Jump to content
The simFlight Network Forums
BillA

Dual Monitor

Recommended Posts

Hi, does anyone have issues when using dual monitors where the windows showing the airport ground traffic and the slides with takeoff and departing aircraft disappear when transferred over to the other monitor? When I click the option for the pop out window it transfer it over to the second monitor for a split second, then it disappears. This did not happen to me before, yet I haven't played Tower 3D in some time.

Share this post


Link to post
Share on other sites

That did the trick, I was not running it in admin mode. Did something change? I never had to run it in admin mode in the past.

Share this post


Link to post
Share on other sites

Thought I’d jump on this thread as I’m currently having problems/issues using a second monitor.  Up to about 3 month ago I had no problem displaying the strips, ADIRS and DBrite on my second monitor.  Then my DBrite started not to show up on the second monitor, while the DBrite would disappear from my main monitor (as it should) and a window icon for the DBrite would show up on the ribbon at the bottom of my main monitor but only as a gray, blank, window when the cursor is placed on it.  The ADIRS and strip windows would still open up on my second monitor.  Now for the last month or so none of the three windows will open on my second monitor, but do show up as gray blank window icons on my bottom ribbon (like the DBrite first did).  

I’m running T3DP (non-steam) as Administrator, tried uninstalling and reinstalling T3DP, restarting my computer, running the program with my Avast anti-virus disabled, trying the mmwindow’s “.bat” files, and running full screen and non-full screen ; but none of these actions made any difference.

I have an older AMD Phenom II X6 1055T Processor, 8.0GB ram, an older AMD Radeon 6570 video card and Windows 10 Home (64 bit) Version 1903 (build 18362.836) O/S.

My primary monitor is a fairly new LG 27” full HD (connected with an HDMI cable) and my secondary monitor is an older Acer 20” 202HL (connected with a DVI cable).

I’ve also attached the mmwindow Data file output log and a screen shot showing the results after I try to move the DBrite to my second monitor (same thing now happens for the strips and ADIRS).

I believe I have basic computer and software manipulation knowledge but I’m not the most literate on the spec or hardware side of the house; so please try not get too technical, if possible.

I’ve ran out of ideas to try so any help would be greatly appreciated.

 

image.png

output_log.txt

Share this post


Link to post
Share on other sites

Most likely yes (or could be) to both questions; however, unfortunately, I don’t remember the dates when both my dual monitor issue started or if both issues started right after an update.  I normally restart my computer every couple of weeks and a lot of the time there seems to be some kind of update when I do, but I don’t keep track of such or if there were any noticeable changes in any of my programs after the update.

Share this post


Link to post
Share on other sites

If so I don’t know how.  I did find the history of the Window 10’s updates to my computer.  It appears the initial version 1903 “Feature Installation” was installed on 9-29-19.  Since then there have been “Quality” cumulative updates installed each month after that along with numerous security, .NET Framework and other feature updates.  I don’t have the slightest idea what the updates specifically included or how they may have affected my computer.  I suppose it is possible that my DBrite dual monitor issue could have started about the time of the initial version 1903 installation and possibly later spread to the strips and ADIRS windows after one of the monthly cumulative updates.  I’m assuming that most other Window 10 users got the same updates as I did, but apparently I’m the only one reporting to have this issue using dual monitors.  I’ve reached the limit of my knowledge on this subject, so I’m hoping that maybe you or some else in the forum may be able to help me solve this issue.

Share this post


Link to post
Share on other sites

I have tried so many things that I cannot say exactly how I managed to reproduce the error. (Possibly using the Windows resize function.)
But what I do know is that if you hover over the (in this case) DBRITE icon in the taskbar and the preview window doesn't show a picture, then Windows or most likely the game has very likely saved the information that the window should be displayed with 0 pixels width and height. This should never happen and is definitely a bug.
In this case, the window is opened as intended, but then shrunk to 0x0 pixels.

The only way I got out of it is that I detached a window, in my case the STRIP, which did not have the 0 pixel information saved yet. This overwrote any 0 pixel information and after that I was able to use the DBRITE on a second monitor as usual.

I don't know what you can do if the 0 pixel information is stored for all windows. This is something the developer has to answer.

If you hover over the icon in the taskbar and a preview image is displayed, then it is easy. Here, e.g. by pressing [Windows-Logo] + [D], the window has moved to the background and can be brought back to the foreground by clicking on the icon or the preview window.

Share this post


Link to post
Share on other sites

It's also possible the window is being drawn outside of the area that your monitors cover ie. drawn off-screen.

An old trick to get these back onto your drawn area.

  • Right-click on the title at the top of the empty preview square that pops up from the taskbar.
  • If "Restore" is clickable, click that first.
  • Right click the title again, this time click "Move", then press an arrow key.
  • The window should now be stuck to your mouse pointer. Left click to drop it somewhere on-screen.
  • It may look like it is just a title bar, if so, move your mouse pointer to the bottom right corner until it changes to a diagonal resize pointer.
  • Left click and drag to resize to correct size.

Share this post


Link to post
Share on other sites

WildCard, thank you for your response.  I tried what you suggested.  “Restore” was not clickable.  “Move” worked until I tried dropping (left click) the small border outline only title bar on the screen.  The title bar will fill in momentarily with what appears to be the T3DP logo along with the minimize, maximize and exit symbols.  This window lasts for about one second and then goes away.  I tried this numerous times with the DBRITE and also with the Strips and ADIRS getting same results for all.  Also, when I try to send the DBRITE  or the other two windows to the second monitor I will get this same looking small title bar on primary monitor’s screen for about one second, followed by a split-second full blue screen which is then followed by the empty window in the task bar.  Anymore suggestions on what to try or what may be causing the problem.

Share this post


Link to post
Share on other sites

EliGrim, thank you for your input.  By the way it sounds FeelThere or maybe a very savvy forum member may be the only I hope I have for solving this issue.  I guess I should have asked for help when only the DBRITE was having the issue (you know what they say about hindsight).  I’m also having some difficulty understanding why I didn’t have any issues for at least a year or so of using dual monitors and then all of a sudden the issue started with the DBRITE and later manifested itself into the other two windows, especially since I’ve re-downloaded and reinstalled the game numerous times since the issues first started. 

I’d also like to add that I really like and appreciate your schedule builder and the other associated tools you’ve created as well as your forum inputs.  So far you’ve hit all the airports I have except for DFW in your schedule builder.  Keep up the good work.

  • Thanks 1

Share this post


Link to post
Share on other sites
30 minutes ago, Ron C said:

 I’m also having some difficulty understanding why I didn’t have any issues for at least a year or so of using dual monitors and then all of a sudden the issue started

Something changed on your system -

Operating system

Videocard (GPU) driver

New software added

New hardware added

Setting change and/or update to antivirus software

 

Any or all can cause an issue (as the game's code hasn't been changed).

Share this post


Link to post
Share on other sites
4 hours ago, scoobflight said:

Any or all can cause an issue (as the game's code hasn't been changed).

Which one might argue could eventually lead to issues.

Share this post


Link to post
Share on other sites
4 hours ago, Ron C said:

I’m also having some difficulty understanding why I didn’t have any issues for at least a year or so of using dual monitors and then all of a sudden the issue started with the DBRITE and later manifested itself into the other two windows, especially since I’ve re-downloaded and reinstalled the game numerous times since the issues first started.

My guess is a Windows or graphics driver update. Because I had the same problem with the flight strips and the DBRITE.

I don't know exactly how I solved it, but I'll try to describe.

The first issue I solved was with the strips. I resized them while they were just game-internal. Then I unlocked them and got a very, very minimized window on the screen, which I resized by pulling on the upper-left corner of the window. Only then I was able to pull on the lower border and lower-right corner of the window and drag it into position on the second monitor.

DBRITE, however, worked similarly, but more difficult, because it hid behind the main application window. I only got to solve it the same way without the flight strips being displayed at all.

Since the problem was solved, both windows now find their place on the second monitor.

I hope that helps.

Share this post


Link to post
Share on other sites

It looks like a few people, including me, have had trouble due to the game settings being wrong for some reason.

Running this file Tower3D Remove Settings.reg as an admin will remove ALL of the game's settings, something an uninstall/reinstall doesn't do.

If the problem still occurs after this, then it isn't due to the game settings/bad window save values/etc.

Then the next step is to get it to work properly on the same monitor first, you haven't said if this works. If this works then the program is working properly.

Then the next step is to get it to work properly on the second monitor. If this doesn't work, after the previous step worked, then it is an issue with windows/drivers.

  • Upvote 1

Share this post


Link to post
Share on other sites
18 hours ago, WildCard said:

It looks like a few people, including me, have had trouble due to the game settings being wrong for some reason.

Running this file Tower3D Remove Settings.reg as an admin will remove ALL of the game's settings, something an uninstall/reinstall doesn't do.

If the problem still occurs after this, then it isn't due to the game settings/bad window save values/etc.

Then the next step is to get it to work properly on the same monitor first, you haven't said if this works. If this works then the program is working properly.

Then the next step is to get it to work properly on the second monitor. If this doesn't work, after the previous step worked, then it is an issue with windows/drivers.

 

On 7/9/2020 at 1:36 PM, scoobflight said:

Any or all can cause an issue (as the game's code hasn't been changed).

Thank you for your input. 

I haven’t changed my operating system, just letting Windows 10 update itself.

No change to video card.  It’s an older one, but it was handling the dual monitors ok before the issues started (however, using the second monitor did slow down the game clock speed to a point where I could only have one window open on the monitor and still run a somewhat real time game clock speed which was usually the DBRITE window).

Only new software I’ve added was CCleaner, which I usually run once a month.

Only new hardware added was my new plug & play LG HD monitor (I can’t remember for sure but I think I was having the initial DBRITE issue before I got the monitor last Christmas).

I’ve had the same free Advast anti-virus software for years.  As far as I know, I’ve not intentionally changed a setting on it; I just run the provided update.  I’ve also tried downloading, installing and playing the simulation with the Avast disabled getting the same issues.

Share this post


Link to post
Share on other sites

Not sure how to reply to each of you individually if there is another post or more after your's before I have a chance to respond (I haven't really learn the ins and outs for working a forum (this is the first one I've ever participated in).  It would be greatly appreciated if someone would tell/show me how (I hate having to learn by just trial and error as indicated above).  Therefore, I'm replying to all of your posts in a single post for now.  

Reply to Scoobflight:

Thank you for your input. 

I haven’t changed my operating system, just letting Windows 10 update itself.

No change to video card.  It’s an older one, but it was handling the dual monitors ok before the issues started (however, using the second monitor did slow down the game clock speed to a point where I could only have one window open on the monitor and still run a somewhat real time game clock speed which was usually the DBRITE window).

Only new software I’ve added was CCleaner, which I usually run once a month.

Only new hardware added was my new plug & play LG HD monitor (I can’t remember for sure but I think I was having the initial DBRITE issue before I got the monitor last Christmas).

I’ve had the same free Advast anti-virus software for years.  As far as I know, I’ve not intentionally changed a setting on it; I just run the provided update.  I’ve also tried downloading, installing and playing the simulation with the Avast disabled getting the same issues.

 

Reply to hexzed:

Thank you for your input.  As far as I know I’ve not added any third party software to the game, just CCleaner to my computer.

Reply to DeltaVII:

Thank you for your input.  I admit I’m not most computer savvy person; therefore, I need a simpler explanation of what/how you did.  Especially for the part of ”I resized them while they were just game-internal.  Then I unlocked them”?

Reply to WildCard (7/10/20):

I want to try the remove setting file included in your post.  But before I do, I’d like to know what this will actually do to my current installed T3DP program.  I’m assuming all extension and airfield folders/files will be unaffected (however I’ll be backing them up first anyway).  Will I have to reinstall the game again and if not will there any noticeable differences or things I’ll need to do after the file is ran to have the game run the way it was before I ran the file?  Forgive me but not being the most computer savvy individual I get a little nervous going into the unknown (for me) when comes to dealing with my computer or its programs (I like to know what to expect before I do it).

Also, you’re correct; I never checked it on my primary monitor.  I’m assuming what you mean by getting it to work on the same monitor you talking about my primary monitor.  If so, it doesn’t work.   When I hit the single screen icon on each of the three windows top bar it does the same thing as when I push the dual screen icon (gray, blank windows on the task bar).  When I turn the windows back on using the command panel all three windows will display on the monitor; however, the blank window icons still remain on the task bar.

Share this post


Link to post
Share on other sites
1 hour ago, Ron C said:

I’d like to know what this will actually do to my current installed T3DP program.

@WildCard can certainly give you better information and it makes sense to wait for his answer. After a look at the file, I take the following from it:

The game stores all settings, like selected runways, sound settings, window positions, etc., in the Windows Registry. By running the file, this data is deleted, or more precisely, overwritten with nothing.
For Windows, it's like starting the game for the first time then. Or at least close to it.
What I can't say is, if it also affects or resets the points and progress of the achievements (if there are any). I guess not, since I could not find any matching entries in the registry. But since I don't know for sure, it probably makes the most sense to wait for a response from @WildCard, as mentioned above, as long as you are not in a rush and need to try it right away.

Share this post


Link to post
Share on other sites
8 hours ago, Ron C said:

Only new hardware added was my new plug & play LG HD monitor (I can’t remember for sure but I think I was having the initial DBRITE issue before I got the monitor last Christmas).

Just a quick thought but probably a red herring but could the problem be a difference in resolution settings between the monitors as it look like they might be different types/sizes/ resolutions. 

Just a thought.

Kev M

Share this post


Link to post
Share on other sites

Thank you for the reply.  That's above my knowledge level to answer. However, the monitor it replaced was a pretty old Dell 19" which I had no issues with.  I believe I was having the initial issue before I got the new monitor just can't remember for sure).  Also, it seems to me that if I'm getting the same blank window icon results on my main monitor that the problem may lie elsewhere (however again this is above my knowledge/expertise level).

Share this post


Link to post
Share on other sites

@EliGrim is correct. The file removes all of the settings that the game stores in the registry. So after using it, the game will behave as if it was being started for the first time. This is now when you check if the pop-out window works on your primary monitor. It should, hopefully, show and work on the primary monitor before you try to move it to another screen.

You are not using the steam version, but for those that are: The file will not reset your steam stats or achievements.

FYI: I am running T3D steam and non-steam versions on Windows 10 (v2004 and have used every previous version), with a dual monitor setup with 2 different resolution monitors and can move the pop-up window from one monitor to the other without issues. Current setup: Primary Samsung 1920x1080, Secondary BenQ 1680x1050. And before I had the Samsung, my primary was a LG 1440x900 with the BenQ as secondary (plus a couple of different HDTVs as tertiary for movies 🙂).

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.