Jump to content
The simFlight Network Forums
Tummi

Massive FPS Drop

Recommended Posts

Hey there,

 

first of all thank your for publish a so far working FSUIPC 7 Version that fast!

Unfortunatly i experience a massive Frame drop of 20-30 FPS, as soon as i connect FSUIPC . Lowerin the MSFS20 Settings to lowest possible has no effect. As soon as i disconnect FSUIPC from the SIM my FPS increase again...

Please let me know if i can offer you any further information or files to get a resolve on this

 

Regards,

 

Björn

Share this post


Link to post
Share on other sites
25 minutes ago, Tummi said:

Unfortunatly i experience a massive Frame drop of 20-30 FPS, as soon as i connect FSUIPC .

This seems to be a known problem with the released version of the SimConnect library, which wasn't present in the beta build. It affects all SimConnect clients, including FSUIPC7. It has been reported to MSFS/Asobo. I'll update when I have further information.

John

  • Like 2

Share this post


Link to post
Share on other sites

Yes, there's something really wrong with the SimConnect connection (e.g. vPilot has the same issues).

More than the reduced FPS it's basically unusable due to stutter, as you can see in the attached screenshot (please ignore the fact that I'm lying upside down in the streets of New York 😁).
You can see on the graphs on the left side the moment FSUIPC connected. Average FPS drop from 40 to 20, but it's much worse than stable 20 FPS.
On the right side the "Manipulators" graph was a steady, green block before the connection.

Other than that FSUIPC is working really well for what I tested so far.
The one special hardware I have that uses FSUIPC for its displays and buttons seems to work just like in P3D.

I really hope Asobo fixes the SimConnect issue fast.

simdrops.jpg

Share this post


Link to post
Share on other sites
5 minutes ago, jaxx said:

I really hope Asobo fixes the SimConnect issue fast.

Well, they should be able to -- the last Beta developers received was fine -- no noticeable degradation with SimConnect applications running.

I don't know why they go and release a version none of the Developers or beta testers have seen beforehand! Very disappointing. 😞

Pete

 

Share this post


Link to post
Share on other sites
11 minutes ago, jaxx said:

Other than that FSUIPC is working really well for what I tested so far.

That's good to know! Shame about the FPS drop/SimConnect issue, hopefully it will be fixed soon.

John

Share this post


Link to post
Share on other sites

Hi!

I've the same problem trying to connect vaBase. Connecting FSUIPC it work fine but fps are really low!

Let we know when there are a fix! 😉

thanks

Share this post


Link to post
Share on other sites

I am experiencing a 50% drop in FPS using FSUIPC7. Now I don't know if the problem is with FSUIPC7 or SimConnect.dll

Share this post


Link to post
Share on other sites
6 minutes ago, Garcez said:

I am experiencing a 50% drop in FPS using FSUIPC7. Now I don't know if the problem is with FSUIPC7 or SimConnect.dll

As already explained just above, if you had read the thread, it is a problem with SimConnect affecting ALL SimConnect client programs. It's a bug added to MSFS since the last Beta release (where performance was excellent).

Pete

 

Share this post


Link to post
Share on other sites
13 minutes ago, Pete Dowson said:

As already explained just above, if you had read the thread, it is a problem with SimConnect affecting ALL SimConnect client programs. It's a bug added to MSFS since the last Beta release (where performance was excellent).

Pete

 

Yes is the problem with SimConnect.

Edited by Garcez

Share this post


Link to post
Share on other sites

I am curious if developer mode needs to be turned on for FSUIPC 7 to work and if that may be part of the frame rate  degredation?

Share this post


Link to post
Share on other sites
8 minutes ago, zfehr said:

I am curious if developer mode needs to be turned on for FSUIPC 7 to work and if that may be part of the frame rate  degredation?

It has nothing to do with that. The problem is in the rendering code in FS2020. The code in FS2020 detects the Simconnect Client Events sent to it, but, go to sleep for a period before executing the Event. It is the same for all Simconnect clients at the moment.

 

Very frustrating bug and not that very professional handling by MS/ASOBO in the process between beta and release if you ask me.

Share this post


Link to post
Share on other sites
24 minutes ago, roa said:

Very frustrating bug and not that very professional handling by MS/ASOBO in the process between beta and release if you ask me.

What do you expect from a software, which was thrown to market in a hurry, not even having time enough for implementing a Splash Screen on the very beginning, showing, that the Software is loading up to the entry with "XBox Gaming Studio" bla bla, which takes about 30 seconds to appear after double click... It would have been good as well to display some text about what it is doing, while loading for so long... It is rediculous that after Xbox, Asobo and the ai logo, I am welcome with "Press any key to start", and until that still not seen a single announcement, that it is MS Flight Simulator, what will be started with "any key"... To me, this all looks like I am taking part now in a public beta, which I paid 129 bugs for... Really rediculous...

Share this post


Link to post
Share on other sites

 Just to let you know, FSUIPC7 is working absolutely perfectly - besides the stuttering. All controls etc for a basic setup works right off the bat. Installation was simple too. 

Hoping for a quick fix from Asobo so that I/we can use FSUIPC7 properly - and then buy a license! 🙂

Share this post


Link to post
Share on other sites

I'm not at my computer so cannot check but I am curious if the simconnect from the SDK (which we are using in the FSUIPC 7 folder) and the simconnect in MSFS are not identical files and that is what is causing the fps drop?

Share this post


Link to post
Share on other sites
2 hours ago, zfehr said:

I'm not at my computer so cannot check but I am curious if the simconnect from the SDK (which we are using in the FSUIPC 7 folder) and the simconnect in MSFS are not identical files and that is what is causing the fps drop?

They do have two different dates associated with them. MSFS ships with one dated 8/8/2020 and the SDK has 7/22/2020. If we could get the two to match but I am unable to copy and paste the newer file into the FSUIPC folder, says I need administrator permission (which I am) and when I press OK it just brings up a try again selection which will not allow the transfer.

Share this post


Link to post
Share on other sites
5 minutes ago, 737-SimGuy said:

Where did you find the one dated 8/8/2020? I'll give it a go. A search doesn't find it.

James

 

Capture.JPG

Share this post


Link to post
Share on other sites
17 minutes ago, 737-SimGuy said:

Thanks.... Tried every trick I know of and couldn't copy it either 😞

James

So did I. Must have trade secrets in it!

 

Share this post


Link to post
Share on other sites

right click on folder- take ownership

but even after that I find the options to do anything in the folder are lokced to read and execute only

Share this post


Link to post
Share on other sites
30 minutes ago, kand said:

right click on folder- take ownership

but even after that I find the options to do anything in the folder are lokced to read and execute only

You're right, that did not work.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.