Jump to content
The simFlight Network Forums
ptimale

problem and discovery FSUIPC

Recommended Posts

Hello

translated by Google

I discover your utility, I like it a lot

I have however a problem with a function which is permanently sent via the HoneyComb Yoke

Here is a screenshot https://zupimages.net/viewer.php?id=20/36/nkdx.jpg

On the other hand, where can we find a list of controls accessible in FSUIPC7?

The offsetStatus-v0.1.ods document is no longer accessible on the download page.

Thank you

 

Edited by ptimale

Share this post


Link to post
Share on other sites
12 minutes ago, ptimale said:

I have however a problem with a function which is permanently sent via the HoneyComb Yoke

Here is a screenshot https://zupimages.net/viewer.php?id=20/36/nkdx.jpg

Have you assigned a button/switch on your HoneyComb yoke to Magneto Off?  If so, it looks like that button/switch is continually firing. Uoi can verify by activating logging for buttons & switches.

14 minutes ago, ptimale said:

The offsetStatus-v0.1.ods document is no longer accessible on the download page.

The latest version is always included in the downloadable zip file.

Share this post


Link to post
Share on other sites
16 minutes ago, ptimale said:

On the other hand, where can we find a list of controls accessible in FSUIPC7?

Only in the drop-down menus at the moment. The ones provided by MSFS are documented in the SDK (under SimConnect: status of sim events).

The controls list for FSX would be mostly applicable (available in the FSUIPC4 documentation pack - see the Download Links -> Documentation section for this).

Share this post


Link to post
Share on other sites

Thank you for the info

I deleted the controls in MFSF2020

I will have to add them to FSUIPC

But only two positions are recognized in fsuipc
2 = PF, 30, C66023,1 - {MAGNETO_OFF} -
3 = PF, 31, C66024,1 - {MAGNETO_RIGHT} -

0 = PC, 22, C65758,1 - {FLAPS_INCR} -
1 = PC, 21, C65759,1 - {FLAPS_DECR} -
2 = PF, 30, C66023,1 - {MAGNETO_OFF} -
3 = PF, 31, C66024,1 - {MAGNETO_RIGHT} -
Add by hand
4 = PF, 32, C66025,1 - {MAGNETO_LEFT} -

How to take it?

Share this post


Link to post
Share on other sites
32 minutes ago, ptimale said:

Add by hand

Why "by hand"? Magneto Left is a valid control.

Turning the magneto in the C172 I see it uses the MAGNETO1_SET control, with parameters 0,1,2 for the various positions. You could try that.

I'm off now, I'll look into this in more detail tomorrow if you are still having issues.

Share this post


Link to post
Share on other sites

my problem is that the left, both, start position is not recognized in fsuipc7
I'm not from Joy # XXX Btne # XXX
for these three positions

Share this post


Link to post
Share on other sites
16 hours ago, ptimale said:

my problem is that the left, both, start position is not recognized in fsuipc7
I'm not from Joy # XXX Btne # XXX
for these three positions

That's because Magneto left, both and start are outside of the 32-button range supported by the default assignment options.

You can have a look at my solution on how to handle all always-on toggle buttons (including all magneto positions) of the Alpha in FSUIPC:

 

  • Like 1

Share this post


Link to post
Share on other sites
18 hours ago, ptimale said:

my problem is that the left, both, start position is not recognized in fsuipc7

Sorry, I didn't realise your issue was that the buttons are outside the usual 0-31 (32 buttons) limit. You will have to use virtual buttons to get these recognised, as given in the solution posted by @jaxx (thanks!).

John

Share this post


Link to post
Share on other sites

Hello

1)
I can't find the ing / start control selector
2)
eng1 and eng2 the command is sent but the switches do not physically switch on the plane

Share this post


Link to post
Share on other sites
17 hours ago, ptimale said:

I can't find the ing / start control selector

Do you mean 'engine start'? Have you tried the Magneto controls - or do you mean something else?

17 hours ago, ptimale said:

eng1 and eng2 the command is sent but the switches do not physically switch on the plane

What 'commands'? Which aircraft?

Share this post


Link to post
Share on other sites

Hello
sorry I was not very precise in my request

A320Neo aircraft:

I try to map these controls

ing.PNG.ceb8183768660aaca25aa76ec3db563c.PNG


to start the engine I use the controls
TOGGLE_MASTER1 / Toggle Starter 1
TOGGLE_MASTER2 / Toggle Starter 2
is this correct?

the engines start to start but the switches ENG1 ENG2
does not tip over on the plane.

For the selector I use:
For the CRANK / Turbine Ignition Toggle function
For NORMAL / Toggle Master Ignition Switch
For the IGN / START function I cannot find the control in fsuipc

 

thank you

 

Share this post


Link to post
Share on other sites

Well, activating those in the UI sends the TOGGLE_STARTER1 and TOGGLE_STARTER2 events. However, sending these via FSUIPC shows no movement. They do move with 'Engine Autostart' though.

24 minutes ago, ptimale said:

to start the engine I use the controls
TOGGLE_MASTER1 / Toggle Starter 1
TOGGLE_MASTER2 / Toggle Starter 2
is this correct?

the engines start to start but the switches ENG1 ENG2
does not tip over on the plane.

Ok, so sounds like they are working but the visuals are not updated. You can report  this in the MSFS forums.

25 minutes ago, ptimale said:

For the selector I use:
For the CRANK / Turbine Ignition Toggle function
For NORMAL / Toggle Master Ignition Switch

Yes, just tried these and they seem to work. In fact, the Turbine Ignition Toggle function seems to toggle between CRANK and NORMAL. However, turning that switch in the UI shows no events.
 

27 minutes ago, ptimale said:

For the IGN / START function I cannot find the control in fsuipc

 No, neither can I!

I'll look into this more tomorrow and if I can't find anything I'll report to Asobo.

Share this post


Link to post
Share on other sites
Quote

with Thrusmaster TPR the right brake is not recognized in FSUIPC

Do you mean that when you move the axis it is not registering the movement in the axes assignment panel? Does windows see the axis?
If when moving the axis FSUIPC is picking up another axis first, you can click the 'ignore' button which will temporarily ignore that axis until you close the dialog box.
I have had some reports of axis temporarily not being seen by FSUIPC. For other users, this seem to resolve itself with a restart (or maybe a reboot), so maybe try that.
If your problem persists, I'll need to see your .ini, .log and JoyScan.csv files (all located in the same folder as FSUIPC7). You could also try downloading nd running the HidScanner program (available from Download links -> Useful Additional Programs).

By the way, you seem to be using this thread for all your unrelated problems. This is not how the forum works and does not help other users who may have the same issues. For future reference, could you please
    - have one topic or thread per issue
    - give the thread a relevant title - 'problem and discovery FSUIPC' doesn't say anything about what your problem(s) is/are
    - always check the provided documentation and previously posted questions to see if your issue (and a solution) or similar has been posted before
    - provide any relevant files

Also, please see this sticky post in the main support forum

 

Thanks.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.