Jump to content
The simFlight Network Forums

FSUIPC7 control problem


Recommended Posts

Hello, 

I came across the problem where i binded my settings up just like in P3D V5 assigned the axis and etc. however when i closed FS2020 last night and open it this morning the sim recognized the hardware but nothing works in the sim itself. (keyboard, mouses (other than pan movement), saitek yoke and throttle and logitech rudders. FSUIPC7 is open and connected and still get no response out of the sim. Went into P3D v5 to make sure it wasnt my drivers and it wasnt. its odd this happened. Could it have something to do with the new update they just released for the sim?

Link to post
Share on other sites
4 minutes ago, alex kulak said:

Could it have something to do with the new update they just released for the sim?

Is there a new update? What is the version? I am still on 1.7.14.0, released on the 28th August.

7 minutes ago, alex kulak said:

the sim recognized the hardware but nothing works in the sim itself

Even if you assign in MSFS? Seems like a problem for MSFS then.

7 minutes ago, alex kulak said:

FSUIPC7 is open and connected and still get no response out of the sim

Could you attach your FSUIPC7.log and FSUIPC7.ini files please and I'll take a look.

John

Link to post
Share on other sites
Just now, John Dowson said:

Is there a new update? What is the version? I am still on 1.7.14.0, released on the 28th August.

Even if you assign in MSFS? Seems like a problem for MSFS then.

Could you attach your FSUIPC7.log and FSUIPC7.ini files please and I'll take a look.

John

yes im on that version.

yeah everything is assigned correctly  ive uninstalled and reinstalled the sim. dont know whats going on 

and yes let me get them for you

Link to post
Share on other sites

Your log file doesn't show anything as FSUIPC7 was not connected to MSFS. Was MSFS running? What do you see in the title bar of FSUIPC7?
When you start FSUIPC7, it should initially have the title 'FSUIPC7: Simulator not detected'. When it detects MSFS, this should change to 'FSUIPC7: Simulator is available: Trying to connect....',  with a log entry of 'Simulator detected'. And when FSUIPC7 connects, this changes to 'FSUIPC7: Simulator is available: Connected'.

So, I am surprised that anything works!

 

 

Link to post
Share on other sites

flight simulator available: connected 

started a flight 

logs below 

yoke and rudder work (send to FS as normal axis). keyboard hotkeys does not. mouse pan does work as well as cockpit button and switches. 

throttle:

send direct to FSUIPC calibration only works for calibration still bot working in sim 

Send to FS as normal axis no response to Joystick calibration and or sim 

 

 

FSUIPC7.log

Link to post
Share on other sites
20 minutes ago, alex kulak said:

keyboard hotkeys does not

You do not have any keys assigned in FSUIPC7.

20 minutes ago, alex kulak said:

as well as cockpit button and switches. 

You don't have any buttons or switches assigned in FSUIPC7 either.

Your log file doesn't show much. Could you activate logging for Axes Controls in FSUIPC7.  Once activated, exit FSUIPC7 and restart . Load an aircraft and then move your throttle through its full range, from 0 to full and then back to 0. Then open and close the axes assignments dialog and repeat. Send me the logs.

There is currently another support request from a user with a similar problem, although his throttle (also mixture/prop) starts working after he has opened and closed the axes assignment dialog, which is why I would like you to also try this. See 

Probably also worth trying with a different aircraft as well, although it works fine here with the TBM 930.

John

 

Link to post
Share on other sites
1 minute ago, John Dowson said:

You do not have any keys assigned in FSUIPC7.

 

 

 

ill assign the "G" for gear this go around and see if it works. i dont understand why it can cross use FSUIPC for AXIS and the Keyboard keys defaulted by the sim like in P3D and FSX

 

assigned "g" for gear toggle nothing happened  log underneath 

FSUIPC7.log

Link to post
Share on other sites
44 minutes ago, Thomas Richter said:

Hi,

in addition please send your FSUIPC7.ini file.

Also activate on Logging tab Buutons & Keys and also Events. After a short session please send the FSUIPC7.log file again.

Is the Saitek software removed?

Thomas

yes saitek is removed. let me get this flight done for you 

Link to post
Share on other sites

figured it out!

 

in the options and controls and keyboard hotkeys of FS2020 there is this stupid CO pilot hand off where the sim does pretty much everything for you. thats where the throttle and my keyboard responses were not playing a roll in!. the hotkey was CTRL+ALT+X so i just cleared. however i have a lot of tweaking to within FSUIPC and might just copy and past my P3D V5 FSUIPC6 INI into 7 if i can 

FSUIPC7.ini FSUIPC7.log

Link to post
Share on other sites

Hi,

there are two things doing the same.

Quote

   568578 ***  AXIS: Cntrl= 65696 (0x000100a0), Param= 1664 (0x00000680) RUDDER_SET
   568578 ***  AXIS: Cntrl= 65696 (0x000100a0), Param= 1920 (0x00000780) RUDDER_SET
   568844 FS Control Sent: Ctrl=65696, Param=1600 RUDDER_SET
   568875 FS Control Sent: Ctrl=65696, Param=1344 RUDDER_SET

I.e. the first both lines show what you defined in FSUIPC and what was sent by FSUIPC. The second both lines direct after are sent by a different application to FS.

Is there anything else running?

Thomas

Link to post
Share on other sites

I've recently had a similar experience, but it happened during a flight (or ground). Everything was set up, I was taxiing back to turn around, and all of sudden all axis controls (don't have any button bindings yet) stopped working. FSUIPC was showing the controls in axes, but the sim was not responded. Even exiting and restarting FSUIPC did not solve it, but it eventually resolved itself randomly (took maybe 2 minutes).

Link to post
Share on other sites

Hi,

For axes can you try instead of selecting "Send to FS as normal axis" selecting "Send direct to FSUIPC Calibration".

For the G key for Gera UP/DN you defined the Gear Toggle function to Key DN and Key Release, so nothing will happen of course. Remove the definition for Key Release, as the function defined is toggle.

[Keys]
2=71,8,65570,0,65570,0     -{G: Press=GEAR_TOGGLE, Release=GEAR_TOGGLE }-

Thomas

Link to post
Share on other sites
9 hours ago, alex kulak said:

I'm guessing it's a disagreement between the sim and FSUIPC?

If you assign in FSUIPC you must NOT also have any assignments in MSFS.  There's bound to be such conflicts if you do. Choose FSUIPC or MSFS for axis assignments, not both.

This has always been the case with FSX and P3D before this -- but at least those had one place where you could disable controllers. I think in MSFS you have to create a blank profile.

Pete

 

Link to post
Share on other sites
9 minutes ago, Pete Dowson said:

If you assign in FSUIPC you must NOT also have any assignments in MSFS.  There's bound to be such conflicts if you do. Choose FSUIPC or MSFS for axis assignments, not both.

This has always been the case with FSX and P3D before this -- but at least those had one place where you could disable controllers. I think in MSFS you have to create a blank profile.

Pete

 

Shoot forgot to delete those axis in MSFS. Thats why I have that disagreement. You can tell the rust on my brain since the last time I had to re calibrate FSUIPC for a new sim. 

Link to post
Share on other sites
12 hours ago, alex kulak said:

and might just copy and past my P3D V5 FSUIPC6 INI into 7 if i can 

Did you not read the announcement or the README.txt file provided in the xip:
 

Quote

If you have previously used FSUIPC, you can also copy and rename your
FSUIPC4/5/6.ini file to the FSUIPC7 installation folder as FSUIPC7.ini, and
also remember to copy any other auxiliary files or folders you may use (.mcro, .lua, .dll, Profiles, etc).

John

Link to post
Share on other sites
5 minutes ago, John Dowson said:

Did you not read the announcement or the README.txt file provided in the xip:
 

John

I did read that but didn't know if things have changed since then. I just wanted to get direct confirmation from you. MSFS has been touchy with me since it came out and im.just kinda making sure I get approval first so it doesn't rear end my side and I have to fix it. 

Thank You for helping! Hopefully its all smooth running from here. In a couple hours ill.hop on my PC delete those MSFS Axis and then put FSUIPC6 INI in FSUIPC7 and see how it performs. Will report back

Link to post
Share on other sites
10 hours ago, alex kulak said:

I do have the controls being sent to FS as normal axis

Can you check if this is calibrated in FSUIPC7. If so, remove the calibration. Or, alternatively, change assignment to ;direct to FSUIPC calibration' instead.

Also, check that you don't have auto-rudder enabled (presuming this is an option in MSFS, as it was in FSX/P3D).

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.