Jump to content
The simFlight Network Forums

Installing E175 V3 SP2?


Recommended Posts

Is there some trick I am missing when I try to install the E175 V3 SP2?  I was using the E175 V2 with absolutely no issues, and months ago I had completely (I thought) removed the E175 V3 SP1 package (you can see my earlier post as to why).  

First I installed the V3 SP2 package, thinking that if the V3 SP1 package was required, the install would be halted.  The install went as expected, but when I tried to select an E175 as my vehicle, it was clearly a V2 aircraft.  In my startup menu under Feel There the only listing was E-Jets V2.  

So then I un-installed the V2 package (no V3 listings in the menu as noted above, and none in the control panel either).  I then went in and deleted every Feel There directory in P3D and in my user data.  I then installed the V3 SP2 package (I had NOT reinstalled the V3 SP1 package), and got the same result, including the E-Jets v2 listing in my startup menu.  

So to repeat the question--if you are currently using the E-Jets V2 package and you want to migrate to E-Jets V3 SP2, what steps should I take in order to un-install the V2 package and successfully install the E-Jets V3 SP2 package?  FYI, I am not trying to run with V2 and V3 installed at the same time--I want to evaluate V3 SP2, and if that package runs as it should all will be just fine.  


Chuck Adams


Link to comment
Share on other sites

There is clearly something wrong with the 175/195 installer.
I have successfully installed the 170/190 into P3Dv5. But the 175/195 installer does not give me the same options to install to v4 or v5 or to treat as a regular airplane or an xml addon. If I change the default path to the same location in v5 to where the 170/190 is installed, it will allow me to do so. But it doesn't work, and I've spent an entire morning uninstalling and reinstalling it without success. Not happy.


Link to comment
Share on other sites

18 minutes ago, scoobflight said:

Folks please state the installer's filename and from whom you are downloading the file.

Haha! Knew it! Just tried to download again from BMT Micro, and the installer for the 175/195 has a different filename than the one I downloaded first thing this morning using exactly the same link

Link to comment
Share on other sites

After looking at this a bit closer, it seems I kept the download link for E-Jets V2 but lost the link for V3 (a different order).  The file I was trying to install was ejetsv2-p3dv4-3 sp2.  This looks like a V2 installer to me.  So I need the link that will allow me to download V3 SP2.  

My V3 order ID is *.  If I need to submit a trouble ticket on this, please let me know.  


Chuck Adams


* Edit: order # removed.  Posting order details on a pink forum means you have shared your purchase with every thief on the Internet.  - Mods.

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.