Jump to content
The simFlight Network Forums

Chance to reverse throttle axis by button?


Recommended Posts

Hey folks,

first I want to say „Thank you“ for the beta version of FSUIPC 7, I have a lot of fun with FS 2020 now!

But I want to ask, if there is a chance to use the throttle axis for the reversers, too? I did a forum search, but found nothing helpful. I do use a Thrustmaster Throttle, with two axes. I send them direct to FSUIPC and assigned them to throttle 1 and 2, working great so far. But with the new FS 2020, there is the possibility to toggle the reverse function. So, you go to idle thrust, toggle the reversers, and then you can apply power via your throttle axes again to add the reverse thrust you want. Like in a real plane. But I don’t know, how I can simulate this behavior via FSUIPC?  

Matthias 

Link to post
Share on other sites

Thank you Thomas,

so I will dive into the Lua manuals I got with previous versions of FSUIPC. I already suspected, that there is no easy way to simply simulate the throttle behavior of MSFS with all the advantages of the throttle axes possibilities in FSUIPC. Project for long rainy autumn weekends, I guess 🙂

Thanks for your reply, 

Matthias

Link to post
Share on other sites
21 hours ago, ankh21 said:

But I want to ask, if there is a chance to use the throttle axis for the reversers, too? I did a forum search, but found nothing helpful. I do use a Thrustmaster Throttle, with two axes. I send them direct to FSUIPC and assigned them to throttle 1 and 2, working great so far. But with the new FS 2020, there is the possibility to toggle the reverse function. So, you go to idle thrust, toggle the reversers, and then you can apply power via your throttle axes again to add the reverse thrust you want. Like in a real plane. But I don’t know, how I can simulate this behavior via FSUIPC?  

I may be misunderstanding this, but with the throttles so assigned in FSUIPC, if you make sure the "No reverse zone" option is off in the calibration tabs (which i think it is by default), and calibrate a "centre" (idle) zone, the reverse thrust is obtained on the same axes by pulling back beyond the calibrated idle position.

That's the normal way of having reverse on the same levers. It gives you whatever range you need to reverse control -- normally you'd calibrate 4/5ths of the movement to forward thrust and just 1/4th to reverse, but you can choose exactly where to place "idle".

Pete

 

Link to post
Share on other sites

Thank you Pete,

that‘s the way I know from many other posts. But in FS 2020, you can assign a button to activate the reverser. So you pull your throttles back, activate reversers with this button like flipping the reverse handle in a real plane, and then push the throttles forward again, but now with reversed thrust. So you can somehow „reverse“ the throttle axes by pressing a button. 
The problem with the dead zone is, that the Thrustmaster Hotas Quadrant is not designed to have a reverse zone. There is no stop or something like this. You easily come into the reverse zone while pulling throttles to idle. Making the dead zone larger decreases the range you have to „finetune“ forward thrust. 
But as in all other simulators before, I use the spoiler axis for reverse thrust, works fine. I was just curious if there is an easy way to use the new function of FS 2020 with all the benefits of axes assignment and calibration of FSUIPC. 

Thank you for your support!

Matthias
 

Link to post
Share on other sites
2 hours ago, ankh21 said:

But in FS 2020, you can assign a button to activate the reverser. So you pull your throttles back, activate reversers with this button like flipping the reverse handle in a real plane, and then push the throttles forward again, but now with reversed thrust. So you can somehow „reverse“ the throttle axes by pressing a button. 

So you can do what you want immediately with MSFS? With all jet aircraft and props with reverse?

2 hours ago, ankh21 said:

the Thrustmaster Hotas Quadrant is not designed to have a reverse zone. There is no stop or something like this. You easily come into the reverse zone while pulling throttles to idle. Making the dead zone larger decreases the range you have to „finetune“ forward thrust. 

Yes. I use to glue a little piece of card cut into a triangle which overlapped the lever groove a little, to mark the idle position.  These days I have separate reverser axes, which can be assigned separately in FSUIPC.

2 hours ago, ankh21 said:

I was just curious if there is an easy way to use the new function of FS 2020 with all the benefits of axes assignment and calibration of FSUIPC.

I must admit I'd not heard of such a facility in MSFs. Seems oddly unrealistic for something like that to be implemented as standard.  However, it appears that others have had this idea before -- see this thread in the User Contributions subforum above. I think you'll not need to spend a long rainy autumn weekend on it after all?

Pete

 

Link to post
Share on other sites

Hey Pete,

thank you very much for the link to the subforum! Shame on me i didn't find it on my own 😞

I didn't test with all aircrafts or props. I testet the Citation, Airbus and the 747. And expecially in older planes, kicking in the reversers and apply reverse thrust by pushing the throttle lever forward is realistic, i think?! I have seen it like this on the 727, 737 and 747. With the Airbus there might be a reverse zone behind the idle position, i am not shure about that.

The problem with the FS implemented throttle assignment is to assign 3 or 4 engine aircrafts to 2 throttle axes. You can assign Engine 1+2, but then you will do wheeles on the runway with the 747 🙂 Not talking about perhaps my beloved 727 coming once as an addon perhaps... Therefore and for all the buttons and switches on the Hotas, i use FSUIPC. But i will have a close look at the lua theme as Thomas suggested above, and perhaps with your help and the linked subforum, i will have the solution within only half a semi-rainy day 🙂

Thank you so much!

Matthias

Link to post
Share on other sites

I have the Thrustmaster Hotas Warthog and simply used FSUIPC 4 or 7 to link 1, 2, 3 and 4 engines for reverse. Remember with this throttle when you are in idle you have to lift the throttle up and back over the bar and reverse kicks in. Just push it forward and you are back in front of the bar, then a slight nudge forward to continue with normal throttle usage. I sent John, by DM, my data/log etc and I have not changed it since. It is buttons 29 and 30 and ZR and Z Axis, with 16384 as idle.

May be this help?

Martin

 

Link to post
Share on other sites

@ankh21 Could you try the attached FSUIPC7 build. In this build, I have added a new Control 'Throttle Reverse Thrust Toggle', and a corresponding read/write offset for this at 0x0B4A (1 Byte). To use this new 'throttle reverser' function, you need to assign your throttle axis in FSUIPC to 'Send direct to FSUIPC calibration' and to the Throttle1/2/3/4 controls. Then calibrate with no reverse zone. If you then assign a button/switch/key to this new toggle control (or to toggle offset 0x0B4A), toggling this control will switch the axis between 0-full forward thrust and 0-full reverse thrust, but only when the aircraft is on the ground.

FSUIPC7.exe

Link to post
Share on other sites

OMG 🤩 Just arrived after a long day in clinic, in expectation of dealing with the lua thing this evening, and now, bam, what a gift!

Thank you so much, John! Tested immediately with the 747 and the Citation Longitude, works like charm! Just got airborne in Linate, will have a great trip over the Alps, watching a breathtaking sunset, and after touchdown in EDDH I will have a big smile on my face using the new function. That’s my day highlight 🤗 Great support!

With compliments

Matthias

  • Like 1
Link to post
Share on other sites
  • 2 weeks later...

Sorry for pushing this thread up again.

I had a little WIN 10 crash and struggled the last two days with getting FS working again. Yesterday i saw the new build of FSUIPC 7 and downloaded, but the implemented "Throttel Reverse Thrust Toggle" does not work anymore for me?! I assigned a button to this function, FSUIPC shows the assignment when the button is pressed, but there is no reaction in FS. 

The FSUIPC.exe Version No. is always the same, but the .exe shows the 6th of October, so it should be the latest build. 

Anything i can do to help investigate this behaviour?

Matthias

Link to post
Share on other sites

There is no change with this functionality in the latest build, and I just tested in the Lomgitude and its working as expected.

23 minutes ago, ankh21 said:

Anything i can do to help investigate this behaviour?

You can try logging Events and Axis Controls.  Before you activate the toggle, you should see the THROTTLEn_SET controls with a positive Param:

Quote

...
   714156 ***  AXIS: Cntrl= 65820 (0x0001011c), Param= 194 (0x000000c2) THROTTLE1_SET
   714156 ***  AXIS: Cntrl= 65821 (0x0001011d), Param= 226 (0x000000e2) THROTTLE2_SET
   714156 ***  AXIS: Cntrl= 65820 (0x0001011c), Param= 454 (0x000001c6) THROTTLE1_SET
   714156 ***  AXIS: Cntrl= 65821 (0x0001011d), Param= 484 (0x000001e4) THROTTLE2_SET
   714234 ***  AXIS: Cntrl= 65820 (0x0001011c), Param= 649 (0x00000289) THROTTLE1_SET
   714234 ***  AXIS: Cntrl= 65821 (0x0001011d), Param= 679 (0x000002a7) THROTTLE2_SET
   714234 ***  AXIS: Cntrl= 65820 (0x0001011c), Param= 876 (0x0000036c) THROTTLE1_SET
   714250 ***  AXIS: Cntrl= 65821 (0x0001011d), Param= 905 (0x00000389) THROTTLE2_SET
   714250 ***  AXIS: Cntrl= 65820 (0x0001011c), Param= 1103 (0x0000044f) THROTTLE1_SET
   714250 ***  AXIS: Cntrl= 65821 (0x0001011d), Param= 1131 (0x0000046b) THROTTLE2_SET
   714250 ***  AXIS: Cntrl= 65820 (0x0001011c), Param= 1315 (0x00000523) THROTTLE1_SET
   714250 ***  AXIS: Cntrl= 65821 (0x0001011d), Param= 1342 (0x0000053e) THROTTLE2_SET
   714250 ***  AXIS: Cntrl= 65820 (0x0001011c), Param= 1591 (0x00000637) THROTTLE1_SET
   714250 ***  AXIS: Cntrl= 65821 (0x0001011d), Param= 1617 (0x00000651) THROTTLE2_SET
   714281 *** EVENT: Cntrl= 66093 (0x0001022d), Param= 0 (0x00000000) AP_AIRSPEED_ON
   714312 ***  AXIS: Cntrl= 65820 (0x0001011c), Param= 1883 (0x0000075b) THROTTLE1_SET
   714312 ***  AXIS: Cntrl= 65821 (0x0001011d), Param= 1908 (0x00000774) THROTTLE2_SET
   714312 ***  AXIS: Cntrl= 65820 (0x0001011c), Param= 2126 (0x0000084e) THROTTLE1_SET
   714328 ***  AXIS: Cntrl= 65821 (0x0001011d), Param= 2150 (0x00000866) THROTTLE2_SET
...

When the assigned button is pressed, you should see the toggle control:

Quote

   722484 *** EVENT: Cntrl= 68069 (0x000109e5), Param= 0 (0x00000000) THROTTLE_REVERSE_THRUST_TOGGLE

and after this, the Param for the THROTTLEn_SET controls should be negative:

Quote

...
   723500 ***  AXIS: Cntrl= 65820 (0x0001011c), Param= -24 (0xffffffe8) THROTTLE1_SET
   723500 ***  AXIS: Cntrl= 65821 (0x0001011d), Param= -32 (0xffffffe0) THROTTLE2_SET
   723625 ***  AXIS: Cntrl= 65820 (0x0001011c), Param= -68 (0xffffffbc) THROTTLE1_SET
   723625 ***  AXIS: Cntrl= 65821 (0x0001011d), Param= -76 (0xffffffb4) THROTTLE2_SET
   723703 ***  AXIS: Cntrl= 65820 (0x0001011c), Param= -101 (0xffffff9b) THROTTLE1_SET
   723703 ***  AXIS: Cntrl= 65821 (0x0001011d), Param= -108 (0xffffff94) THROTTLE2_SET
   723703 ***  AXIS: Cntrl= 65820 (0x0001011c), Param= -137 (0xffffff77) THROTTLE1_SET
   723703 ***  AXIS: Cntrl= 65821 (0x0001011d), Param= -145 (0xffffff6f) THROTTLE2_SET
   723765 ***  AXIS: Cntrl= 65820 (0x0001011c), Param= -186 (0xffffff46) THROTTLE1_SET
   723765 ***  AXIS: Cntrl= 65821 (0x0001011d), Param= -193 (0xffffff3f) THROTTLE2_SET
   723765 ***  AXIS: Cntrl= 65820 (0x0001011c), Param= -218 (0xffffff26) THROTTLE1_SET
   723765 ***  AXIS: Cntrl= 65821 (0x0001011d), Param= -226 (0xffffff1e) THROTTLE2_SET
   723781 ***  AXIS: Cntrl= 65820 (0x0001011c), Param= -255 (0xffffff01) THROTTLE1_SET
   723781 ***  AXIS: Cntrl= 65821 (0x0001011d), Param= -262 (0xfffffefa) THROTTLE2_SET
   723828 ***  AXIS: Cntrl= 65820 (0x0001011c), Param= -292 (0xfffffedc) THROTTLE1_SET
   723844 ***  AXIS: Cntrl= 65821 (0x0001011d), Param= -298 (0xfffffed6) THROTTLE2_SET
   723844 ***  AXIS: Cntrl= 65820 (0x0001011c), Param= -365 (0xfffffe93) THROTTLE1_SET
   723844 ***  AXIS: Cntrl= 65821 (0x0001011d), Param= -371 (0xfffffe8d) THROTTLE2_SET
   723875 *** EVENT: Cntrl= 66093 (0x0001022d), Param= 0 (0x00000000) AP_AIRSPEED_ON
   723890 *** EVENT: Cntrl= 65962 (0x000101aa), Param= 19 (0x00000013) FUEL_SELECTOR_SET
   723890 *** EVENT: Cntrl= 66523 (0x000103db), Param= 20 (0x00000014) FUEL_SELECTOR_2_SET
   723906 ***  AXIS: Cntrl= 65820 (0x0001011c), Param= -413 (0xfffffe63) THROTTLE1_SET
   723906 ***  AXIS: Cntrl= 65821 (0x0001011d), Param= -420 (0xfffffe5c) THROTTLE2_SET
   723906 ***  AXIS: Cntrl= 65820 (0x0001011c), Param= -446 (0xfffffe42) THROTTLE1_SET
   723906 ***  AXIS: Cntrl= 65821 (0x0001011d), Param= -452 (0xfffffe3c) THROTTLE2_SET
   723906 ***  AXIS: Cntrl= 65820 (0x0001011c), Param= -482 (0xfffffe1e) THROTTLE1_SET
   723922 ***  AXIS: Cntrl= 65821 (0x0001011d), Param= -488 (0xfffffe18) THROTTLE2_SET
   723922 ***  AXIS: Cntrl= 65820 (0x0001011c), Param= -527 (0xfffffdf1) THROTTLE1_SET
   723922 ***  AXIS: Cntrl= 65821 (0x0001011d), Param= -533 (0xfffffdeb) THROTTLE2_SET
   723937 ***  AXIS: Cntrl= 65820 (0x0001011c), Param= -568 (0xfffffdc8) THROTTLE1_SET
   723969 ***  AXIS: Cntrl= 65821 (0x0001011d), Param= -573 (0xfffffdc3) THROTTLE2_SET
   723969 ***  AXIS: Cntrl= 65820 (0x0001011c), Param= -604 (0xfffffda4) THROTTLE1_SET
   723969 ***  AXIS: Cntrl= 65821 (0x0001011d), Param= -610 (0xfffffd9e) THROTTLE2_SET
   723984 ***  AXIS: Cntrl= 65820 (0x0001011c), Param= -661 (0xfffffd6b) THROTTLE1_SET
   723984 ***  AXIS: Cntrl= 65821 (0x0001011d), Param= -666 (0xfffffd66) THROTTLE2_SET
   723984 ***  AXIS: Cntrl= 65820 (0x0001011c), Param= -701 (0xfffffd43) THROTTLE1_SET
   724000 ***  AXIS: Cntrl= 65821 (0x0001011d), Param= -707 (0xfffffd3d) THROTTLE2_SET
...

Are you using the same FSUIPC7.ini file? You could attach that and I'll check it for you.

Link to post
Share on other sites

What have been Shakespeare‘s words?! Much ado about nothing?!

Really, FS is driving me crazy. I promise, I started FS and FSUIPC several times before sending the SOS, the toggle button did not toggle. Cause of another program I restarted the PC, and without touching anything now it works as expected. Oh Lord....

Thank you so much for your quick reply and your help. I will do a complete restart before I ever post a problem here again 😞

Matthias

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.