Jump to content
The simFlight Network Forums

Other Software not Connecting to MSFS


EdwardSm
 Share

Recommended Posts

I am looking for help in trying to figure out what could be stopping other software from connecting through FSUIPC7. Prior to the last update of FSUIPC7 Beta I used LINDA, SLC, and the ACARS from my VA to connect to MSFS without issue. I am currently using the Beta dated 30th September and having this issue although FSUIPC7 says it is connected. SLC and ACARS say they are not connected. LINDA reports that it is connected; however, none of the assigned keys work. To make the matter more confusing; I have uninstalled both ACARS and LINDA, then installed them back. When I run either software for the first time, they will connect to MSFS and work as expected. Once I restart them though they stop working. Attached is my log file. Any guidance would be greatly appreciated.

FSUIPC7.log

Link to comment
Share on other sites

Sorry, but I cannot help with other products that use FSUIPC7. You need to talk to LINDA, ACARS and SLC support for this.

There is an issue with the pause state indicator in that build, due to changes in the 1.9.3.0 release of MSFS. I'm not sure if that would affect LINDA and ACARS, but you can try the following build where this issue has been corrected:  

FSUIPC7.exe

  • Thanks 1
Link to comment
Share on other sites

Thank you, John. I did reach out to one of those software makers, LINDA. They sent me to you reporting it as a potential FSUIPC7 Beta issue. I updated with the exe you provided but the problem is still there. I have FSUIPC7 installed in the C:\ [...]\AppData\Local\Packages\ [...] \Packages\Community folder. Could it be that I have it in the wrong location? I attached the newest log file, this one is post update.

Edit: I am not sure if this is important and thought it best to report just in case. If I start any of the above programs when FSUIPC7 is running those programs become partially unresponsive. What I mean is, if I try to enter data (flight plan, passenger count, etc) or try to drag the software window to a different position, I have to wait for the input to register or the window to move. When the data does start appearing, or the window starts moving, it is very jerky and takes some time to complete. Even actions such as typing one or two words takes as much as 10 seconds after I am done typing. This does not happen when running the software while FSUIPC7 is not running. So, to summarize, if FSUIPC7 is running the software that links into it becomes partially unresponsive. This happens even if MSFS is not running. If MSFS is running and FSUIPC7 is not, the problem is not present. If I shut down FSUIPC7, the issue stops and everything runs as expected.

Thank you in advance for all your assistance,

Ed Smoker Sr.

FSUIPC7.log

Link to comment
Share on other sites

Hi,

Quote

I have FSUIPC7 installed in the C:\ [...]\AppData\Local\Packages\ [...] \Packages\Community folder. Could it be that I have it in the wrong location?

I did read somewhere in the MSFS forum, I think, where MS/Asobo pointed out that nothing other than packes should be installed in that location as it would give problems.

As FSUIPC7 doesn't need a special location in relation to MSFS other than to be installed on the same PC, just try a simple location, copy and paste the FSUIPC7 folder on the C drive (C:\FSUIPC7\)

Thomas

Link to comment
Share on other sites

If the problem is with the client programs that use FSUIPC7, you really need to talk to their support. Do you have any issues with FSUIPC7 when not running those clients?

On 10/4/2020 at 12:40 AM, EdwardSm said:

Prior to the last update of FSUIPC7 Beta I used LINDA, SLC, and the ACARS from my VA to connect to MSFS without issue. I am currently using the Beta dated 30th September

If the previous version was with a build date of 26/09, then there were very few changes between the versions, the main one being the change to simconnect 0.6.0.0.
Also, if it was a problem with FSUIPC7 and LINDA or ACARS, I would have thought it would affect many other users.

Link to comment
Share on other sites

John, it was an earlier version than that. Unfortunately I did not save the last working copy but it was a version from either late August or early September. I don't recall which now. I know you had released an updated version for testing, which I did not grab due to my work schedule and not having free time.

Thamas, let me check into that as I am not sure that I have MSFS running as Admin.

 

I don't suppose there is an older version from end of August time frame I can test with?

Link to comment
Share on other sites

14 hours ago, Thomas Richter said:

Hi,

is everything running at the same level, i.e. 'Run as administrator'? Depends on installation but if MSFS runs with administrator privileges then all other have to as well. In case FSUIPC7 does work correct you might check if the not connecting software runs at the same level.

Thomas

Thomas, many thanks. I was certain that I was running all the software as admin. While updating or installing the software mentioned, I had not selected for anything except FSUIPC7 Beta to run as admin. I made that change and now everything except the ACARS is running perfectly. In the case of the ACARS, I am not sure how to run it as admin as there is no option that I can find. I have contacted the dev for it for assistance. At any rate, I am very pleased that this was user error. 🙂

 

Link to comment
Share on other sites

That's what I'm used too as well. This is a ClickOnce app and was not sure how to find the exe. The Dev taught me a new lesson to find it, use the Task Manager to locate the file the exe is in. I really enjoy learning new things about computers. It's great that even though I've been working with them for so long, my first computer was an Apple IIc, their is always another factoid to pick up.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.