Jump to content
The simFlight Network Forums

WideFS not connecting


Recommended Posts

Hello everybody,

I' m afraid my WideFS won't connect to FSUIPC7. I have 2 PCs (Windows 10 fully updated) in the same IP-network, one holding MS FS 2020 and FSUIPC7 Beta, the other one holding WideFS. WideFS is registered correctly and FSUIPC connects to the Simulator while WideFS is constantly waiting for a connection:

image.png.f5b9adce4fed0206bab51e97e3077eb9.pngimage.png.b92c61d3d556da21ff6525c99c864ccb.pngimage.png.4ea5f2fac409a6352a8468497a2ae138.png

The Workgroup for both PCs is the same, Windows firewall is disabled on both of them:

image.png.c2408feffa4e6808f74da926d0d488a0.png  image.png.0cce8c4c916b855afc3d21cf0e6b6222.png

Attached are the ini- and log-files. WideServer.log is only created sporadically, so I can only provide an older version created by one of my previous attempts.

Any help would be greatly appreciated. Many thanks in advance.

Oliver

 

 

 

 

WideClient - Kopie.log

WideClient - Kopie.ini FSUIPC7 - Kopie.log WideServer.log FSUIPC7 - Kopie.ini

Edited by John Dowson
key file removed
Link to post
Share on other sites

Hi,

Quote

********* WideClient Log [version 7.159] Class=FS98MAIN *********
Date (dmy): 23/10/20, Time 14:53:29.461: Client name is DESKTOP-1R1N1AV
      563 Attempting to connect now
      563 Trying TCP/IP addr x.x.x.x, port 8002 ...

x.x.x.x is not a PC address.

In the WideClient.ini file use a proper address or use "ServerName=" instead.

ServerIPAddr=x.x.x.x

Thomas

Link to post
Share on other sites
33 minutes ago, Mav2307 said:

WideServer.log is only created sporadically,

The WideServer.log file is created when the WideServer component, embedded in FSUIPC6, is started. Note that the WideServer component is only started once 'ready-to-fly'. Can you check what is in FSUIPC7's WideFS menu - do you see an 'Enable' entry or a 'Disable' entry? If the latter, the WideServer component is running, and you should see the status in the MSFS title bar. If its 'Enable', then it could either be grayed (in-active) or active. If its grayed, then you are not 'ready-to-fly'. Load an aircraft and get ready-to-fly and you should see this made active. Then select to enable if it does not do this automatically.

Note also that. when FSUIPC7 starts, it will only automatically start WideServer if it was previously enabled. If you close down with WideFS (manually) disabled, it will also be disabled the next time you restart.

So, first check that the WideServer component is running when it fails to connect please, and a WideServer.log file has been created.

I've also recently made a few changes to the starting of the WideServer component (not yet released), but these relate to restarting WideServer when MSFS is closed and restarted, so I don't think these would help.

Later: ok, just checked your ini and you do have WideFS enabled:
    WideFSenabled=Yes
So the WideServer component should start automatically once 'ready-to-fly, and any clients will not connect before this.
As Thomas says, check your address config.

Edited by John Dowson
Further info added
Link to post
Share on other sites
2 hours ago, Mav2307 said:
2 hours ago, Mav2307 said:

WideFS is registered correctly and FSUIPC connects to the Simulator while WideFS is constantly waiting for a connection

 

In the Client log the problem of connection becomes clearer:

      563 Trying TCP/IP addr x.x.x.x, port 8002 ...
      563 LUA: "C:\...\Initial.LUA": not found
     2625 Error on client pre-Connection Select() [Error=10061] Connection refused
     2625 Ready to try connection again
     3625 Attempting to connect now
    62688 Trying TCP/IP addr 10.48.249.244, port 8002 ...


I don't know why the first attempt has "x.x.x.x" for the IP address. You seem to have that set in the INI:

ServerIPAddr=x.x.x.x

I assume you did that? If it was only for posting here, I don't know why as WideClient only operates on your local network, and local IP addresses are no interest to others. Most of us have the same set of IP addresses for all PCs etc in our local network -- mostly 10.1.x.x or 192.168.x.x.  These are the ranges allocated for LAN use. It isn't something useful outside.

The second time, which luckily you missed, shows 10.48.249.244, which is most unlikely to be an IP address of anything on your Network. I think this is to do with the way your router/hub is configured. 

What you need to do is set the correct IP address for your server in the ServerIPAddr parameter in the client INI file. You can find that in the Network settings in Windows.

Pete

 

Link to post
Share on other sites

Good morning to all and thanks for trying to help.

First of all, sorry for all the confusion about the IP-address. Yes, I replaced the real address in the screenshot. In the files used there is the actual address.

Please believe me I did a lot of testing and reading the documentation over and over again before posting my problem as I didn't want to waste your time. I have been a long-term simmer and user of FSUIPC and Wideclient since around 2006. But I couldn 't get it to work. After reading your posts this morning, I wanted to check all the hints you gave. But (un)fortunately, now (without knowingly changing anything to the configuration) it is working for the very first time since installing the new simulator and FSUIPC7 beta. Tried it a second time and it worked again so I dare say the problem seems to be solved (whatever the problem was).

Sorry again and thanks again for your support.

Oliver

 

Link to post
Share on other sites
  • 2 months later...

Same issue plus Initial set up 

Good afternoon to you both, it has been a very long time since I have used and set-up FSUIPC and WideFS, in fact possibly 18 years ago when I had a small FDS set-up. However, I now want to start again and have purchased both FSUIPC and WideFS. I have WideFS installed on my 2nd PC, which intend to run A320 ND and PFD etc. The Main PC has FSUIPC installed and when I click on its shortcut it launches MSFS2020. However, when I then click on the 2nd PC and launch WideClient, it just says 'Trying to Connect'.

I am not sure if I am doing everything correct? Am I missing something, like I have to set my Main and 2nd PC up? All I can confirm is that they are on the same LAN.

Sorry if I sound stupid.

 

Regards,

Karl

Link to post
Share on other sites

@Karl B Did you read this post? Did you read the documentation? Did you check that your PCs are in the same workgroup? Did you try explicitly setting the IP addresses?

You have also provided no real information - we need to see your logs (WideClient and WideServer) and your ini files. However, I strongly suggest that you first read the documentation, check your windows Workgroups are the same, make sure there is no firewall acting in-between the PCs (and if so, either disable or add exceptions). If thats all ok, try specifying the ServerIPAddr in the WideClinet.ini.

 

 

Link to post
Share on other sites

Hi John, yes I have read all docs, although they relate to earlier Window versions and sim versions, I'm assuming that everything still applies.

Ok this is what I have done so far;

1. I have set up and allowed sharing from my Main FS2020 PC, including the Client PC

2. Both Main PC and Client PC are on the same network

3. I have allowed the Firewall on the Main and Client to have access

4. I have installed FSUIPC and WideFS on both the Main PC as well as the Client PC, is that correct?

5. I have created a folder on the Client PC and placed the WideFS.exe, there is also a WideClient.ini, WideClient.log, and WideClient0.log file in the same folder, I have also created a shortcut for the WideFS on the desktop of the client PC

6. I also have a shortcut of the WideFS on the Main PC and a MSFS7 shortcut that was automatically created when I installed FSUIPC on the main PC.

I have attached the WideClint.ini log

 

Regards,

 

Karl 

wideclient file.txt

Link to post
Share on other sites
12 minutes ago, Karl B said:

4. I have installed FSUIPC and WideFS on both the Main PC as well as the Client PC, is that correct?

No. You install FSUIPC on the main PC only, and WideClient on the client PCs.

12 minutes ago, Karl B said:

6. I also have a shortcut of the WideFS on the Main PC

You do not need WideFS on the main PC. The WideServer component is built into FSUIPC7.

12 minutes ago, Karl B said:

3. I have allowed the Firewall on the Main and Client to have access

Have you confirmed that they are both in the same Windows Workgroup?

12 minutes ago, Karl B said:

5. I have created a folder on the Client PC and placed the WideFS.exe, there is also a WideClient.ini, WideClient.log, and WideClient0.log file in the same folder, I have also created a shortcut for the WideFS on the desktop of the client PC

You mean the WideClient.exe, no? Why don't you attach those files (not renamed or changed!) so I can take a look?

And make sure you are using WideFS7. There shouldn't even be a WideFS.exe in the WideFS7 download!

12 minutes ago, Karl B said:

yes I have read all docs, although they relate to earlier Window versions and sim versions, I'm assuming that everything still applies.

Yes, still applies. Did you try setting the ServerIPAddr to se if that helps?

John 

P.S. Also check that your WideFS is registered and WideServer is enabled in FSUIPC7, and you should also have a WideServer.log file in your FSUIPC7 installation folder that you should also attach if you still can't connect.

Edited by John Dowson
PS added
Link to post
Share on other sites
16 minutes ago, Karl B said:

4. I have installed FSUIPC and WideFS on both the Main PC as well as the Client PC, is that correct?

No. Just FSUIPC on the main PC, and WideClient on the Client, as per the instructions (the Installation section on page 3 of the WideFS User Guide).

16 minutes ago, Karl B said:

5. I have created a folder on the Client PC and placed the WideFS.exe, there is also a WideClient.ini, WideClient.log, and WideClient0.log file in the same folder, I have also created a shortcut for the WideFS on the desktop of the client PC

There's no such thing as "WideFS.exe", so i assume you mean WideClient.exe.

16 minutes ago, Karl B said:

I have attached the WideClint.ini log

That's just WideClient.ini, not a log, and it shows you haven't tried all of the suggestions in the user guide, page 4. This part:

Configure your Network
IT IS IMPORTANT FOR ALL USERS TO READ AT LEAST PART OF THIS!

Scroll down to the paragraph starting "...  However, if you find the connection is still not happening". Try the suggestion there.

Finally, in order for us to help with problems we need not only your settings (the INI file) but also the Log file. That is why a Log is produced, to show what problems might occur and help fix them.

There will also be a WideServer.Log file in the folder where you installed FSUIPC.

Pete

[LATER] Oh, I see John replied simultaneously, saying much the sam thing! 

 

Link to post
Share on other sites

Hi John, thanks for the clarification.

You install FSUIPC on the main PC only, and WideClient on the client PCs.. Now Done

You do not need WideFS on the main PC. Now Deleted

You mean the WideClient.exe, no? Why don't you attach those files (not renamed or changed!) so I can take a look? Yes sorry WideClient.exe and I have attached the correct log files;

Have you confirmed that they are both in the same Windows Workgroup? The Main PC is on the default Window 10 name called 'Workgroup' I have double checked the client  and the Client PC is also named as 'Workgroup' name.

 

Thanks,

 

Karl

 

WideClient0.log WideClient.log

Link to post
Share on other sites

The log simply shows that the Server isn't seeing the Client. This could be to do with the firewall on either PC. On the client you must allow WideClient through. On the Server, FSUIPC7 and, if possible, WideClient.

The fact that the Broadcast from the server is seen (providing the Server name "DESKTOP-I1IEAU4", and its IP address 192.168.1.76 is encouraging. However, it looks like the Server isn't seeing the requests from the Client, so it definitely looks like a firewall problem. You could try (temporarily) disabling the firewall on each machine in turn to see where that is occurring.

You didn't provide the WideServer.LOG file as requested, though. That may show more.

Pete

 

Link to post
Share on other sites
1 hour ago, Karl B said:

Would you suggest disabling the Firewall and then trying again?

Yes, as the best way to determine if its a firewall issue or not is to (temporarily) disable them. Try each in turn and also both together (client and server PCs).

Link to post
Share on other sites

Last night I disabled both the Server PC and Client, however, when MSFS2020 was running on the server PC, I clicked on the WideFS in the Client PC and it just 'Awaiting to connect'

 

Regards,

 

Karl 

Link to post
Share on other sites
1 minute ago, Karl B said:

Last night I disabled both the Server PC and Client, however, when MSFS2020 was running on the server PC, I clicked on the WideFS in the Client PC and it just 'Awaiting to connect'

As always, we need to see your logs and ini files.

Did you read the documentation as suggested? Did you try setting the ServerName and Protocol ini parameters? Or ServerAddress?

Link to post
Share on other sites

Morning John, last night I spent some time going through my Network set-up, and it appears that I had not ticked permission to share files on my Network. So after running MSFS 2020 and then clicking on WideFS on the client PC, I got a connection. The only thing I'd like to confirm is, looking at the log file, initially, you can see that it shows it was unable to connect, but then goes on to connect, so it appears to be working now.

However, looking at this line 125 LUA: "C:\Users\Karl\Desktop\WideClient\Initial.LUA": not found I am not sure why its showing this?

 

Regards,

 

Karl 

WideClient (1).log

Link to post
Share on other sites
12 minutes ago, Karl B said:

However, looking at this line 125 LUA: "C:\Users\Karl\Desktop\WideClient\Initial.LUA": not found I am not sure why its showing this?

That can be safely ignored. WideClient always runs an Initial.lua file on start-up, if found in the WideClient.exe folder. See the WideFS User manual, section Lua plug-in facilities.

One thing to note though is that you are running WideClient from a desktop folder. Did you mean to do this?

Anyway, I'm happy that its now connecting. Such issues usually are caused by the network/sharing/firewall configuration.

John

Link to post
Share on other sites
33 minutes ago, Karl B said:

Update, not looking good,

What update? I thought it was now connected/working?
Why attach two log files? Please, EVERY time you think you have an issue, we need to see your WideClinet.ini, your WideClient.log and your WideServer.log. All three, every time.

And have you tried setting the ServerName and Protocol ini parameters? Or ServerAddress?

 

Link to post
Share on other sites
13 hours ago, Karl B said:

You can see it eventually connected,

It connected initially after 18 seconds:

Quote

18188 Incoming connection Accepted ok (skt=1408) TCP

Note that WideServer is only started/enabled by FSUIPC once you have an  aircraftin a ready-to-fly state. You can manually enable it earlier if you wish.
WideClient cannot connect before WideServer is started.

 

13 hours ago, Karl B said:

but MSFS2020 crashed after 20 minutes.

But this is a separate issue and cannot be related to your wideclient connection issue, which seems to be solved.

There are currently known issues with MSFS crashing due to issues with simconnect, and so provoked by simconnect clients. Asobo are aware of the problem and are looking into it (there are various threads on this in this forum).

All MSFS CTDs should really be reported to Asobo via zendesk, with relevant details (event log details + crash dump) if available.

Link to post
Share on other sites

Ah, ok yes I did not realise that I had to wait for the aircraft to be ready in a 'Fly State'. Lets hope that everything will be ok for now on.

Thank you again for your help with this.

Regards,

Karl

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.