Jump to content
The simFlight Network Forums

FSC10 forgets its database (answered)


Recommended Posts

I've just re-installed MS FSX completely from scratch and a new installation for FSC10. One of the reasons I re-installed everything was that whenever I started FSC10, the program has forgotten its database and I have to run the database manager again.

With the new install, the same problem exists.

I installed FSX to its default location (C:\Program Files (x86)\Microsoft Games\Microsoft Flight Simulator X) and FSC 10 to my D drive (D:\FSC10)

It appears that the DB is present in the FSC10 folder, but it's not recognised by FSC...) I have excluded FSC and FSX folders from my virus scans. (false positives in FSC). Also I have admin rights + folder ownership (full control) of these folders.

Any thoughts anyone?



Link to comment
Share on other sites


I have uninstalled both FSC and FSUIPC and re-installed them as administrator and for all users.

FSX and FSC are installed as located above. I have also checked file naming as per  I. Kerber's advice and confirmed that scenery.cfg is actually scenery.cfg

FSC starts and re-starts as per normal (i.e. close and re-open) except after a reboot of the system. After a boot/re-boot, FSC cannot find the database...

I don't think the issue is actually FSC as it used to work perfectly before. Any idea what could be causing it?

One curious new wrinkle is that now FSC won't recognise an existing flight plan in my FSX flight plan folder but does note a new flight plan I just created. Checking the folder and both are there side by side so I have set the paths correctly.

Also, I do have MSFS 2020 installed under C:\Microsoft Flight Simulator. I used the existing flight plan in MSFS so it may have changed the saved plan... This is not an issue for me though... The database issue pre-dates the MSFS installation so I don't believe that's the problem...


Link to comment
Share on other sites

Hi Rob,

You're right, it can't be an FSC problem if it worked before.
I don't see any connection between your problem and the MFS installation.

In order to better investigate the problem, open the FSC10 folder and send me
the complete subfolder /SUPPORT as a ZIP file to my e-mail address.
You can find the e-mail address here:




Link to comment
Share on other sites

Hi Volker...

As discussed off-line, a kind hearted gremlin from above has miraculously fixed my errant machine! (At least for the time being until the bad gremlins catch wind of it...)

For the time being I guess you can mark this one solved...!

Thanks mate...


Link to comment
Share on other sites

This topic is now closed to further replies.

  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.