Jump to content
The simFlight Network Forums

AP_VS_HOLD event not fired


Recommended Posts

Hi,

I can't fire the AP_VS_HOLD event to select the VS mode in the autopilot panel.

If I push the corresponding button in the simulator panel I can see in the log console the event fired. When I click on my button I can't see the event fired in the console.

The code is quite simple and it's work for all the other event:             FSUIPCConnection.SendControlToFS(FsControl.AP_VS_HOLD, 0);

Is this my fault or its a SimConnect bug?


Thanks,

Fabio

Link to post
Share on other sites

Paul, I've tried all the controls you listed but none is working. I mean, when the control is sent to the FS nothing happen and the event is not shown in the FSUIPC7 log console.

Spokes reported that the AP_VS_HOLD  is not workign since FS2002 (18 years??? Is it possible?).

This could be a big show stopper for my project for the autopilot panel 😞

Link to post
Share on other sites
11 hours ago, Fabio Drago said:

Paul, I've tried all the controls you listed but none is working.

What aircraft are you using (A320 or B787 perhaps?)? Those controls were reported as working (by two users) in this post: 

 

You should also maybe look into the use of the _SLOT_INDEX controls, which switch between managed and selected AP modes.
See this post: https://forums.flightsimulator.com/t/simulator-events-for-switching-between-managed-and-selected-mode-in-the-a320/323838

And also this may help: 

 

John

Link to post
Share on other sites

Thanks John for your reply,

I solved using the new FSUIPC7.exe found in your reply to Guenseli.

Honestly speaking I'm a little bit confused about the differences between airplane.  Is there a way to standardize the button behaviour in a way that it works on every aircraft? I know, it's a silly question but my goal is to build a mini Autopilot panels with the common functions in order to be used by my flight sim community.  

I started testing my prototype with MSFS (because I love to do VFR flights and the graphic is stunning) but I have tested it with Xplane11 and I found that controls like AP_VS_VAR_DEC are not working on Xplane11. I can do it only suing OffSets. Is it a my fault ?

 

Fabio

Link to post
Share on other sites
54 minutes ago, Fabio Drago said:

I solved using the new FSUIPC7.exe found in your reply to Guenseli.

But that is probably an old version now. You should download and install v7.0.2, released yesterday.

55 minutes ago, Fabio Drago said:

Is there a way to standardize the button behaviour in a way that it works on every aircraft?

Not really. This is why we provide profiles, so you can configure your assignments for the controls or features that work for the aircraft in that profile.

59 minutes ago, Fabio Drago said:

I started testing my prototype with MSFS (because I love to do VFR flights and the graphic is stunning) but I have tested it with Xplane11 and I found that controls like AP_VS_VAR_DEC are not working on Xplane11. I can do it only suing OffSets. Is it a my fault ?

Sorry, I don't know Xplane 11, and FSUIPC doesn't support it. I think thats XUIPC by a different developer.

John

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.