Jump to content
The simFlight Network Forums

CRS encoder via EventID's 65663 - 65662 param 0


Recommended Posts

Hi,
I dont know if this behaviour is correct or not:
I set the VOR COURSE value with an encoder and 65662 param 0 for decrease value and 65663 param 0 for increase.
When I'm NOT in fly (at parking) this works always correct (decrease and increase by plus or minus 1 degree).
When I'm in flight and attempt to reach VOR radial the value change plus or minus 5 degrees.

The encoder works correctly and not send false impulses.

Thanks for suggestions.

Link to post
Share on other sites

Could you activate event logging and produce a FSUIPC7.log file, showing the control being activated both when parking and when flying. Please also attach your FSUIPC7.ini.
I'll take a look at your files, but if FSUIPC7 is sending the same controls (with a 0 parameter) then it seems like this is a problem with MSFS and needs to be raised to Asobo via zendesk.

John

Link to post
Share on other sites

I wonder if this report might be relevant?

Quote

That latter file immediately identifies that (without me knowing about this¬¬ I clearly have (well, 'had'!!) the "APU START" switch on my HOTAS Throttle in the 'on' position!!!!    it was the first words in EVERY line!!!

I turned that switch to 'off'.....lo and behold my ALtitude now changes in 100's and my Hdg changes in single degrees!!!!!

That was part of this thread: https://forum.simflight.com/topic/91275-is-it-just-me/?tab=comments#comment-552215

Pete

 

 

Link to post
Share on other sites
1 hour ago, John Dowson said:

Could you activate event logging and produce a FSUIPC7.log file, showing the control being activated both when parking and when flying. Please also attach your FSUIPC7.ini.
I'll take a look at your files, but if FSUIPC7 is sending the same controls (with a 0 parameter) then it seems like this is a problem with MSFS and needs to be raised to Asobo via zendesk.

John

Hi John,
thanks for replay.
In attachment the requested files.

I also saw that in logs are other events logged not used by me like  :
13640703 *** EVENT: Cntrl= 66096 (0x00010230), Param= 0 (0x00000000) AP_MACH_ON
It is better to include that events in "DontLogThese" item in fsuipc7.ini ?

Thanks for support.

Bye

FSUIPC7.at ground.log FSUIPC7.in fly.log FSUIPC7.ini

Link to post
Share on other sites
42 minutes ago, zorzini said:

I also saw that in logs are other events logged not used by me like  :
13640703 *** EVENT: Cntrl= 66096 (0x00010230), Param= 0 (0x00000000) AP_MACH_ON
It is better to include that events in "DontLogThese" item in fsuipc7.ini ?

No, or at least not at the moment, as it may be these events causing the difference in increment values, as with the APU Start in the support request that Pete referenced.
I'll look into this (when time permits) and get back to you. I've been without internet most of the day so have a bit of a backlog, so will probably take me a day or two to get around to looking at this,

John

Link to post
Share on other sites
1 hour ago, John Dowson said:

No, or at least not at the moment, as it may be these events causing the difference in increment values, as with the APU Start in the support request that Pete referenced.
I'll look into this (when time permits) and get back to you. I've been without internet most of the day so have a bit of a backlog, so will probably take me a day or two to get around to looking at this,

John

Hi John and thanks for answer.

The CRS issue is not a big problem and I can wait.

Regarding connection problem I'm afraid if You are without it. Fortunatelly I discovered this morning that my provider double me the speed (from 100 to 200 Mb) without extra cost...probably a Christmas gift...non only bad covid news also.

Bye

Link to post
Share on other sites
16 minutes ago, zorzini said:

Regarding connection problem I'm afraid if You are without it. Fortunatelly I discovered this morning that my provider double me the speed (from 100 to 200 Mb) without extra cost...probably a Christmas gift...non only bad covid news also.

That's good for you! Unfortunately here in rural Galicia, my connection is via  R/F (line-of-sight) delivery. I occasionally get my speed doubled or improved,  but I still have a max of 20MBps, but more usually around the 10-15Mbps mark... I also gave permission for an internet provider to lay a fiber cable over my property back in January, but am still waiting for this to become active so I can use that instead - should improve things a lot once available! 100Mbps for me is a dream!

John

Link to post
Share on other sites
13 minutes ago, John Dowson said:

That's good for you! Unfortunately here in rural Galicia, my connection is via  R/F (line-of-sight) delivery. I occasionally get my speed doubled or improved,  but I still have a max of 20MBps, but more usually around the 10-15Mbps mark... I also gave permission for an internet provider to lay a fiber cable over my property back in January, but am still waiting for this to become active so I can use that instead - should improve things a lot once available! 100Mbps for me is a dream!

John

Hi John, i'm retired technician and in the latest ten year i have installed here in Sicily about 800 internet connections like yours. The speed could not go more over 30 Mb (at reasonable cost).

Good luck for next provider and Merry Christmaa and Happy New Year (without covid we hope).

Link to post
Share on other sites
  • 1 month later...

This bug can be quite useful. The bug only affects events assigned to an "always on" type switch and only if the event is assigned in MSFS. The bug is not triggered if you assign all of your controls in FSUIPC7 (thanks John). 

To make use of the bug I have 1 switch (a physical toggle switch) assigned directly in MSFS . When i want larger increments for alt select, heading bug select, autothrottle speed select etc i flick my switch then switch it off again after i have selected my altitude or whatever. 

Regards

Keith

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.