Jump to content
The simFlight Network Forums

FSX Will Not Run with FSUIPC installed

Recommended Posts

FSX Boxed version (single installation)

OS - Windows 10

  • CPU - Intel Core i3 @ 3GHz
  • RAM - 4GB
  • SSD - 250GB

FSUIPC version - 4.975

System Security - BitDefender


FSX runs fine prior to FSUIPC install.

FSUIPC install runs like clockwork, indicating that the install worked. At the Registration window, I selected "Not now".

After installing FSUIPC I started FSX and answered "yes" to the prompts about trusting the FSUIPC program and running it each time FSX is started. The FSX opening graphic stayed on my screen for approximately 5 seconds and the program closed. I tried to start FSX 2 more times with the same result (opening graphic for 5 seconds, then program exit). I removed FSUIPC.DLL and FSX works fine. I went through the FSX.CFG and DLL.XML files, removed all lines pertaining to FSUIPC, deleted the modules folder (at this point FSUIPC was the only item in the folder), ran FSX with no issues, and tried reinstalling FSUIPC (as Administrator) only to get the same results.

What am I missing?


Link to comment
Share on other sites

First, you posted in the FAQ section where it explicitly states 'Not for Support Requests'. I have moved your post this time, but please raise all support requests in the correct forum.

You have also not attached any files (e.g. your install log or your FSUIPC4.log file), so I have no idea what your version of FSX is.
However, if you are using a 'boxed' version, its almost certain that you need to install both of the FSX service packs (SP1 and SP2). There have been MANY similar support requests about this....

So, please check your FSX version, and install any service packs that may be needed, and try again. If you still have issues, post again and provide the information that we need to be able to assist - please read the following before posting again:



Link to comment
Share on other sites

Sorry John.

My mistake. Thanks for the redirect.

FYI, my boxed version is right out of the box. No service packs installed, but I'll go look for them now that you've mentioned them. Hopefully, they're still out on the ether somewhere.

Thanks again,


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.