Jump to content
The simFlight Network Forums

Tower 3d Pro stopped working


Recommended Posts

The last time i played tower 3d pro was during the end November 2020.  I even bought and played two new airports and started playing them.  Now, I try to launch and it take 5 seconds and the screen just disappears.  Please help.  I've tried validating files.  Tried uninstalling/reinstalling.  What is weird is that my other game on steam works perfectly.

Link to post
Share on other sites

Have you confirmed your antivirus program isn't blocking the game?

Did you install any new programs on computer since last time Tower worked?

Did you install any new hardware? CPU? GPU? etc?

Did you experience a system, aka Win10, update?

You can see if there is a Tower log file (...\<tower root folder> \tower3d_Data\output_log,txt) and share it by attaching the document to your post. Attach the file, do not cut and past the file contents into a post!

Link to post
Share on other sites

I confirmed antivirus wasn't blocking.  I even fully disabled the virus/spam program and still nothing.  No new programs, updates, or hardware.  I purchased this computer in January 2020.  I don't use it much except for zoom, word, and of course...TOWER!  I uninstalled all windows updates that installed in December and that still didn't fix it.

 

Attached is the output file.  Someone out there has to know what I can do to fix.  

YOUR HELP IS GREATLY APPRECIATED.

output_log.txt

Link to post
Share on other sites
9 hours ago, mickey2damouse said:

Mine just started again,

Have you confirmed your antivirus program isn't blocking the game?

Did you install any new programs on computer since last time Tower worked?

Did you install any new hardware? CPU? GPU? etc?

Did you experience a system, aka Win10, update?

You can see if there is a Tower log file (...\<tower root folder> \tower3d_Data\output_log,txt) and share it by attaching the document to your post. Attach the file, do not cut and past the file contents into a post!

Link to post
Share on other sites
Just now, DavyJones said:

Really?!  any idea how to reset speech?  Where in the log do you see that?

That's the deal - I don't see it in the log file. Your log file ends with:

BUILD VERSION: v1.2.78.946 SP3.3c
GfxDevice: creating device client; threaded=1

You should see something like this if it loads successfully.

BUILD VERSION: v1.2.78.946 SP3.3c
GfxDevice: creating device client; threaded=1
start speech!
Record error state: False
SPEAK: Start speak plugin.

So, based on that, the speech engine could be the point of failure.

 

Link to post
Share on other sites
  • 2 weeks later...
10 minutes ago, DavyJones said:

Do I just need to reset my retire computer?

As the game was working and then stopped something on your system changed.

A clean rebuild _may_ solve the issue.  Hard to say as for some just updating drivers and/or allowing the latest Windows update to install has solved the issue.

Link to post
Share on other sites

Please check and report your windows version (is it the 2004?). We are aware of the new Windows update somehow changes the voice recognition and sometimes a clean Windows is needed to solve the problem.

 

Vic

Link to post
Share on other sites

Sorry been traveling.  It worked yesterday so I played EGLL and today is not working.  

I did notice it was stopping at the speech part before it crashed.  

I can agree maybe Windows Update did it because I have not played since the bigger update.

Link to post
Share on other sites
25 minutes ago, mickey2damouse said:

Sorry been traveling.  It worked yesterday so I played EGLL and today is not working.  

I did notice it was stopping at the speech part before it crashed.  

I can agree maybe Windows Update did it because I have not played since the bigger update.

 

output_log.txt

Link to post
Share on other sites
58 minutes ago, mickey2damouse said:

... It worked yesterday so I played EGLL and today is not working.  

... maybe Windows Update did it because I have not played since the bigger update.

So your computer went through a Win10 update after you last played Tower successfully?  It is only after the update, assuming from what you wrote update occurred sometime last night, that Tower crashes at start?

Link to post
Share on other sites
1 hour ago, scoobflight said:

So your computer went through a Win10 update after you last played Tower successfully?  It is only after the update, assuming from what you wrote update occurred sometime last night, that Tower crashes at start?

Currently it is working...I went through every option for the microphone and enabled it.  Then I turned off the WiFi and ran the program "As Administrator" as normal and it is working.  Now I just checked after enabling the WiFi and it is not working.

I did an update some time in Dec, I played on my flight 12/21 and it worked.  After installing EGLL, it didn't work.  I tried at the time of my original reply to this post and the WiFi was on.  So it has something to do w/ the speech and WiFi but I have not put the two together to figure out why.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.