Jump to content
The simFlight Network Forums

A step by Step for FSUIPC7, Honeycomb Alpha Yoke, and MSFS2020

David Brewster

Recommended Posts

So it took me like a whole evening of piecing together multiple forum posts, and combing through manuals to figure out how to get this working perfectly. I don't have the Bravo throttle quadrant ... yet... but I've included some instructions that should apply when I do. Here we go...

1) Go to SimMarket and BUY FSUIPC7. The free version won't help you. You need to buy it. There is a missing (by design) menu option from the free version so this is a must. Here's a link for the google challenged ūüėú


2) You will get an email with your key and an install program that you should run. Do that. I installed into c:\FSUIPC7\

3) You'll need some LUA scripts to install, namely "hidAlphaButtons.lua", and "hidBravobuttons.lua". For context, here are the links to find those files from post Lua scripts for Honeycomb Bravo Quadrant and Alpha Flight Controls buttons > 32 - User Contributions - The simFlight Network Forums. I've attached them here as well.



4) Copy both of those files into your C:/FSUIPC7 directory (or where ever you installed it).

5) Open up c:\FSUIPC7\FSUIPC7.ini in notepad. Add these sections to it (make sure these sections are not duplicated anywhere else, they shouldn't be. To make it tidy I went through the file and added a blank line before every section name in square brackets (like [General], [JoystickCalibration], etc.). It's very important in the auto section to have "lua " before the file name, I spent an hour without that in there trying to figure out why it wasn't working. ūüėú¬†I've also seen a few times where the [LuaFiles] section gets duplicated. Not sure why that happened, probably my fault. It didn't seem to cause problems but I deleted the duplicated section anyhow.

1=lua hidAlphaButtons
2=lua hidBravoButtons


[Lua files no longer needed to assign to buttons > 32]

6) Launch MSFS2020. Go into Options Controls, and go to the configuration page for the Alpha Yoke. Delete all the switch and magneto bindings. If this is the first time you've gone in here you'll be prompted to calibrate first. 

7) Launch/relaunch FSUIPC7. Not sure this is needed but hey... just do it.

ūüėé Select the FSUIPC7 menu option Assignments > Buttons & Switches

9) Flip all the Alpha Yoke switches to the off position.

10) For each switch do this ... Turn on. You'll see in the "PRESS" "BUTTON" boxes you'll see some values pop up.

11) For each function, go over and click the "Select for FS control" checkbox. You'll see the "Control sent when button pressed" dropdown is enabled, this is where you scroll down and find the applicable function.

12) Seems many don't know this, but you don't have to scroll through the hundreds of options, this is a searchable list, so just type in say Landing and you'll be taken down close to Landing lights. Select the right option for each toggle switch. Then flip the switch off and select the off command.

13) Some options don't have separate On Off list items in the drop down, namely Beacon, Taxi Lights, Nav Lights, and Strobes. For these you select "Taxi Lights Set" (etc), and for the OFF position you put a 0 in the parameters text box, and for the ON you put a 1 into the parameters.

14) The magneto selection still messes me up a bit. I think to do these and have the LUA scripts running correctly you have to have MSFS up and running and "connected" to FSUIPC. Otherwise I don't think you'll see changes in the "PRESS" "BUTTON" text boxes when you cycle past the first 2 Magneto positions.

15) So twist to the Mag position switch position to configure, click the "Select for FS Control" check box and select the appropriate command from the list.

16) I have also made available to download a partial piece of my INI file that shows the button allocations and how the LUA scripts get implemented attached to this post. I guess you could just skip these instructions and dump these in there... but hey ... maybe you want to be a little more hands on than that right?

Maybe once I get my hands on the throttle quadrant in Feb, I'll do a youtube video from start to end for both devices to work with FSUIPC and MSFS2020... but until then I hope this helps.

And please.. if there is a problem anywhere in my instructions... drop me a note and I'll try to duplicate your problem and fix this post.





hidAlphaButtons.lua hidBravoButtons.lua FSUIPC7-some.ini

Edited by John Dowson
Alpha and Bravo lus scripts no longer needed.
  • Like 1
Link to comment
Share on other sites

  • 2 weeks later...

Hi Andrew,

it looks like you went into the assignments panel BEFORE the lua file was auto-started.
Could you try again please, but don't open the assignments panel until after you see this line in the log (or load an aircraft first):
    -------------------- Starting everything now ----------------------
If it still doesn't work, show me your new log, and we can try adding some extra logging to the lua script to see whats happening.


Link to comment
Share on other sites

  • 4 weeks later...

@David BrewsterI've just noticed that you are manually adding the [LuaFiles] section on these instructions. You really shouldn't do this as this is an automatically generated section, which is written by FSUIPC on start-up when it scans your folder for lua files. Probably also why you were getting this section twice in some instances.

Link to comment
Share on other sites

@David Brewster Thank you for this invaluable resource.  @John Dowson Thank you for the clarification on the setup. I just went through all the steps to set up my Alpha yoke and all the switches on the main panel were able to be programmed through FSUIPC. However, the hat switch and all the buttons on the handle aren't responding. I opened MSFS, loaded a plane and waited for the log to read 'Starting everything now' but there was still no response in the assignment tab for any of those buttons/switches.  Any help would be appreciated.



Link to comment
Share on other sites

First, if you don't have a Honeycomb Bravo, you can remove that lua script and the entry in your FSUIPC7.ini under [Auto] that starts that script. You don't need it. 

Can you activate offset logging in FSUIPC for 0x3340 as U32 in hex. Load you aircraft and produce another log file where you have activated those buttons. Also please make sure that you exit FSUIPC7 before you attach the log, so its closed and I can see the full log.

Link to comment
Share on other sites

@John Dowson Thanks for getting back to me.  I will delete the Bravo Lua.  Just put it in there so it's ready when it arrives. 

Second, this is my first time working with FSUIPC and I'm not sure how to activate the offset you instructed me to do. I went into the log tab and clicked offset and a table popped up but it wouldn't let me enter 0x3340 in the field. Is that what you meant?  A step by step how-to would be greatly appreciated. 

Link to comment
Share on other sites

John, I went into the offset tab in the log tab and entered 3340 in the offset box, type U32 and clicked the hex box.  There was still no response from the hat switch or any of the buttons or switches on the handles of the Alpha yoke.  I also removed the Bravo entry from the ini. I have included both the log and .ini below.


Link to comment
Share on other sites

14 hours ago, Corey Jones said:

There was still no response from the hat switch or any of the buttons or switches on the handles of the Alpha yoke.

This was to log the activity - I didn't expect it to work.
However, you log file shows that you started MSFS but  didn't start a flight. Please load an aircraft and start a flight and then test those buttons. Also, please close down FSUIPC before attaching the log so I can see the full log file.

Someone else has also recently reported the same issue but for the Bravo.
Could you also try temporarily re-enabling the default profile for the Alpha in MSFS, and see if those switches are recognised there - or see if they are recognised by MSFS.

Link to comment
Share on other sites

1 hour ago, Corey Jones said:

I believe this has the full log you were looking for

Your log does show some button state changes for those buttons:


  1894641 LUA.1: ALPHA Buttons= 15955000 1
  1894687 LUA.1: ALPHA Buttons= 15955000 2
  1894703 Monitor IPC:3340 (U32) = 0x2
  1894734 LUA.1: ALPHA Buttons= 15955000 4
  1894766 LUA.1: ALPHA Buttons= 15955000 4
  1894781 Monitor IPC:3340 (U32) = 0x4
  1894812 LUA.1: ALPHA Buttons= 15955000

Are those not shown in the button assignments panel?

1 hour ago, Corey Jones said:

I tried to reset the alpha yoke in MSFS but didn't see any function that let me do that.

I as only suggesting going back to the default MSFS profile temporarily  for the Alpha to see if MSFS recognised the buttons > 32. You should really create a new empty profile for this device if/when assigning in FSUIPC.

1 hour ago, Corey Jones said:

I'm playing under the default settings as of now since it wouldn't recognize the commands. 

So you are using the MSFS default settings now for the Alpha?
Don't you get issues with the 'always on' switches, as reported by many alpha users?


Link to comment
Share on other sites

I've just plugged in my Alpha and get the same. However I don't think this is to do with buttons in the >32 range. I can see the virtual buttons for those when I switch the starter rotary to Left, Both or Start, and get virtual device 64 with buttons 0,1 & 2 respectively.

So the script is working for the buttons > 32.  The issues seems to be that the buttons/switches on the yoke, with button numbers 1-12 (according to MSFS) aren't recognised. They are also not recognised in the default Alpha profile for MSFS.

I didn't install any Alpha drivers or software yet. Did you? I am going to try that now.....


Link to comment
Share on other sites

8 minutes ago, John Dowson said:

I didn't install any Alpha drivers or software yet. Did you? I am going to try that now.....

You shouldn't need the Alpha software installed....
I also cannot see those buttons in the Windows game controller panel. They should show as buttons 1-12 but aren't. I am not sure why. I am going to ask on Honeycomb support.


Link to comment
Share on other sites

  • 3 weeks later...

All of the links for the "hidAlphaButtons.lua", and "hidBravobuttons.lua" files say Unavailable. Are they still available and if not how can you fix FSUIPC7  to recognize buttons 32, 33, and 34? I do see the button assignments in the Control Setup Page in MSFS 2020 and the switches work in the plane. Only in MSFS 2020 itself it show the buttons as 31-35 instead of 30-34. But in FSUIPC7 it shows buttons 30 & 31, but does not see buttons 32, 33, or 34.

Edited by gaivy912
Link to comment
Share on other sites

5 hours ago, gaivy912 said:

All of the links for the "hidAlphaButtons.lua", and "hidBravobuttons.lua" files say Unavailable.

The scripts are available here: 


5 hours ago, gaivy912 said:

can you fix FSUIPC7  to recognize buttons 32, 33, and 34?

There is a beta release available with native support for up to 128 buttons. Please see 



Link to comment
Share on other sites

Hi all,

Somewhere in the forums I read that you have to have a flight started before you start making the assignments in FSUIPC, but now I can't find that post. Could someone please confirm if this is the case, and in which step of the process above this should be done? I followed the first post and was not able to get the magnetos assigned properly.

Many thanks!

Link to comment
Share on other sites

This topic is now closed to further replies.
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.