Jump to content
The simFlight Network Forums

Minor issue with 7.04 and error 740


Recommended Posts

In my cfg file I have these two entries:

Run1=CLOSE,"E:\FS-ATC-Chatter\FS-ATC-Chatter.exe"

Run2=CLOSE,"E:\NaturalPoint\TrackIR5\TrackIR5.exe"

I have both properties set to run as admin

In 7.02 - all is good

in 7.04 I get error 740 on the TrackIR entry.

I run the fsuipc batch file as admin and do it the same all the time.

Uninstalled 7.04 and switched back - no errors.  Reinstalled 7.04 - error is back.

Not the end of the world but is there something I am missing here?

Thanx,

 

Vic
 

Link to post
Share on other sites
10 hours ago, vgbaron said:

I have both properties set to run as admin

In 7.02 - all is good

in 7.04 I get error 740 on the TrackIR entry.

I run the fsuipc batch file as admin and do it the same all the time.

Uninstalled 7.04 and switched back - no errors.  Reinstalled 7.04 - error is back.

Not the end of the world but is there something I am missing here?

Error 740 can only occur when the program being loaded needs elevation and the program loading it doesn't have it. So there must be a problem in your setting of 7.0.4 to run in "admin mode". Set that in the FSUIPC7.EXE Properties-Compatibility. 

Note that the 7.0.4 installer sets MSFS to load FSUIPC7 automatically, rather than via the Batch file.

Pete

 

Link to post
Share on other sites

Hmmm - ok this is with 7.04 on w10 pro

if I set run as admin in compatibility for FSUIPC7.EXE - msfs loads perfectly but FSUIPC7 is not loaded

if I set flightsimulator.exe to run as admin in compatibility - there's a flash when FSUIPC7 tries to load and then sim CTD

if I remove run as admin from both -  FSUIPC7 starts and I get 740 error on TrackIR.

Link to post
Share on other sites

Its obviously a permissions issue but I've no idea what is causing this, you need to play  around.
I have TrackIR as well, but I never run anything in admin mode.... I always start TrackIR manually (as I only use it occasionally and for tests), but I'll try starting in via both FSUIPC and the MSFS EXE.xml to see if there are any permission issues for me (but I doubt it!).

You  could also try running TrackIR from the EXE.xml, rather than from FSUIPC?

Link to post
Share on other sites

Just had a look at this in more detail.

TrackIR is not set to  run in administrator mode, but it requests this when ran, so it does run in administrator mode.
You therefore need to set FSUIPC7 to run in administrator mode if starting trackIR from FSUIPC7.

Then, as MSFS stars FSUIPC7 from the EXE.xml, you need to run MSFS in administrator mode for it to be able to launch FSUIPC7, which will then be able to launch trackIR. I did this by setting this option on my FlightSimulator.exe file. After doing that, all start ok.

Alternatively, you can remove the start-up of FSUIPC7 from the EXE.xml,  and re-enable the start of FSUIPC7 from the MSFS.bat file.To do this, change

Quote

:: wait for MSFS to start (2mins)
::timeout /t %delay% /nobreak > NUL

:: start FSUIPC7
::start "" "INSTDIR\FSUIPC7.exe"

to

Quote

:: wait for MSFS to start (2mins)
timeout /t %delay% /nobreak > NUL

:: start FSUIPC7
start "" "INSTDIR\FSUIPC7.exe"

and replace INSTDIR with the full path to the FSUIPC7.exe

John

Link to post
Share on other sites
14 hours ago, vgbaron said:

if I set flightsimulator.exe to run as admin in compatibility - there's a flash when FSUIPC7 tries to load and then sim CTD

This should be the one that works, with both flightsimulator.exe set and FSUIPC7.exe set to run as admin. I don't know why you get a CTD with this config.
Maybe try that again? If it crashes again, check for a crash event in the windows event viewer. You can post that here but I'm not sure I can do much with it...

John

Link to post
Share on other sites

I'll also remove everything from the community folder in case some add on is affecting the loading. I looked at the event viewer but no relevant entries. I'll play a bit, if all else fails I'll throw TIR in the exe.xml file - probably the easiest solution. I'm just curious as to why the permissions conflict.

Thanx for the help - 

 

Vic

Link to post
Share on other sites
1 minute ago, vgbaron said:

I'll also remove everything from the community folder in case some add on is affecting the loading.

I don't think this will make a difference.

1 minute ago, vgbaron said:

if all else fails I'll throw TIR in the exe.xml file - probably the easiest solution.

You can try it, but make sure MSFS is set to run as administrator. I didn't try this though, but should work...

Link to post
Share on other sites

I'll keep tinkering on and off but no joy so far.

MSFS set as admin - shortly after initial screens - CTD - no entry in event viewer. Tried running it directly from the msfs icon - same. Didn't try it w/o FSUIPC entry in exe.xml file - will have time tomorrow.

Adding TrackIR to exe.xml - wouldn't load 

with FSUIPC7.exe set as admin - it doesn't load with MSFS - no errors - just doesn't start FSUIPC

on a lark, I added a trackir entry to the msfs.bat file - loads perfectly along with FSUIPC - only issue is I have to manually end it.

in case I didn't mention it - it's a MS Store install to my F: drive not the default.

I'll keep tinkering just on principle..

 

]Vic

Link to post
Share on other sites

The config that should work is when you get the CTD. Very strange.
I think the other solution should work though, which is:
    - remove the start of FSUIPC7 from the EXE.xml
    - use FSUIPC's [Programs] section to start TrackIR
    - set FSUIPC7 to run with administrator privileges
    - re-enable the start of FSUIPC7 from the MSFS.bat file (as described above)

Then, if you use the desktop link to start MSFS with FSUIPC7, this will start MSFS without admin privileges and start FSUIPC7 with them, which will then also start trackIR.

John

Link to post
Share on other sites

Well, I've narrowed it down with some success

Replacing instdir and setting admin run on FSUIPC7, TIR and the msfs.bat file did not work.

Setting flightsimulator.exe run as admin - same ctd

so -  restored and took ownership of exe.xml, FSUIPC7 and TIR - run as was set on both. Set run as on flightsimulator,exe

started program from the MS Flightsimulator desktop shortcut - worked perfectly

Tried it from the msfs.bat file with instdir intact - ctd

set up a shortcut with just the fastlaunch cmdline entry - ctd

run flightsim shortcut again - worked

So it seems that I can not use the fastlaunch command in this instance. Tried the fastlaunch command with FSUIPC7 removed from exe.xml - worked just fine IF flightsimulator.exe was NOT set to run as admin..

I'll try some other combinations and see if I can narrow it down but running w/o the fastlaunch option works fine.

Vic

Link to post
Share on other sites

Hi Vic,

Seems like the problem in MSFS is related to code it needs to execute for elevated privileged mode which is bypassed in "fastlaunch" mode. Worthy of a report to Zendesk along with your description and the Event Viewer details of the CTD.

Thanks for your perseverance!

Pete

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.