Jump to content
The simFlight Network Forums

FSUIPC7 and MSFS Accelerator Keys Not Being Passed Through


wulybugger

Recommended Posts

Hello,

I'm trying to configure FSUIPC7 to send a control to MSFS using the "Key Presses" under the "Assignments" tab. I can properly setup the key press to control assignment in FSUIPC7.  However, what I've discovered is that when I run MSFS the following happens:

1. If my key assignment is a single, regular key (such as 'a', 'b', 'c', etc), then the assignment works properly in MSFS.

2. If my key assignment involves an accelerator key (ctrl, shift, alt or any combination of these), the key assignment does not work.

3. If FSUIPC7 has the focus, then the key assignment even with the accelerator keys DOES work.

4. But if MSFS has the focus, then it does not pass through any of the accelerator keys.

I can see this behavior in FSUIPC7's log. When FSUIPC7 has the focus, then it properly picks up any accelerator keys in combination with the regular key (e.g. ctrl + shift + a). It displays the keydown/keyup for each of these keys, detects the key combination and sends the appropriate control to MSFS. MSFS reacts appropriately.

HOWEVER, if MSFS has the focus, when I press any accelerator key, it does NOT appear in FSUIPC7's log. Only the 'a' in the sequence ctrl + shift + a gets sent to FSUIPC7 and shows in its log. Therefore FSUIPC7 does not detect the full key press sequence and so does not send the assigned control.

I'm sorry if this is a known issue, but I've tried a number of searches to find previously reported issues and looked through FSUIPC7's documentation.  I realize this may be an issue with MSFS and not resolvable by FSUIPC7. But my experience with MSFS support has been abysmal to put it nicely so I thought I'd ask here to see if anyone had any insight into this?

 

Thanks.

Link to comment
Share on other sites

FSUIPC7 only supports a max of one 'accelerator' key. Did you try with just one - this was working in previous MSFS versions, but I haven't tested it in the latest version.
Also, FSUIPC7 handles these accelerator keys (shift, ctrl, alt) in a different manner than other keys. It doesn't receive these keys via simconnect, but detects if they are pressed/held down when the main key is received via simconnect. Thats why the logging is different.

So, please try with a single accelerator key. If thats not working, I'll take a look.

 

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
×
×
  • Create New...

Important Information

By using this site, you agree to our Terms of Use. Guidelines Privacy Policy We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.